summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-04-26 06:31:30 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-04-26 06:31:30 +0000
commitc670893b5884a97db7245485a3cf4fac00fd43a7 (patch)
tree7543a40eddc2e61670fbf50d0a715c766f1e78b0 /sci-biology
parentRev bump to install the dictsource directory for bug #218597. (diff)
downloadgentoo-2-c670893b5884a97db7245485a3cf4fac00fd43a7.tar.gz
gentoo-2-c670893b5884a97db7245485a3cf4fac00fd43a7.tar.bz2
gentoo-2-c670893b5884a97db7245485a3cf4fac00fd43a7.zip
Add the Java version, which is actually maintained. This could possibly use some more enhancement to add wrappers for the GUI and such, but the ebuild is already a fully functional replacement for the old version.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/readseq/ChangeLog12
-rw-r--r--sci-biology/readseq/readseq-20080420.ebuild46
2 files changed, 56 insertions, 2 deletions
diff --git a/sci-biology/readseq/ChangeLog b/sci-biology/readseq/ChangeLog
index cd592ed8308c..235794f9a61e 100644
--- a/sci-biology/readseq/ChangeLog
+++ b/sci-biology/readseq/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-biology/readseq
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/readseq/ChangeLog,v 1.5 2006/08/17 22:20:51 weeve Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/readseq/ChangeLog,v 1.6 2008/04/26 06:31:30 dberkholz Exp $
+
+*readseq-20080420 (26 Apr 2008)
+
+ 26 Apr 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +readseq-20080420.ebuild:
+ Add the Java version, which is actually maintained. This could possibly
+ use some more enhancement to add wrappers for the GUI and such, but the
+ ebuild is already a fully functional replacement for the old version.
17 Aug 2006; Jason Wever <weeve@gentoo.org> readseq-19930201.ebuild:
Added ~sparc keyword wrt bug #144246.
diff --git a/sci-biology/readseq/readseq-20080420.ebuild b/sci-biology/readseq/readseq-20080420.ebuild
new file mode 100644
index 000000000000..3897b2ffbe25
--- /dev/null
+++ b/sci-biology/readseq/readseq-20080420.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/readseq/readseq-20080420.ebuild,v 1.1 2008/04/26 06:31:30 dberkholz Exp $
+
+EAPI=1
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-source-${PV}"
+DESCRIPTION="Reads and writes nucleic/protein sequences in various formats."
+HOMEPAGE="http://iubio.bio.indiana.edu/soft/molbio/readseq/"
+# Originally unversioned at
+# http://iubio.bio.indiana.edu/soft/molbio/readseq/java/readseq-source.zip.
+# Renamed to the date of the modification and mirrored
+SRC_URI="http://dev.gentoo.org/~dberkholz/distfiles/${MY_P}.zip"
+#SRC_URI="mirror://gentoo/${MY_P}.zip"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+COMMON="dev-java/xerces:2
+ dev-java/jaxp"
+RDEPEND="${COMMON}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON}
+ >=virtual/jdk-1.4
+ app-arch/unzip"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ java-pkg_jar-from xerces-2 xercesImpl.jar lib/ibm-xml4j-min.jar
+ java-pkg_jar-from jaxp jaxp-ri.jar lib/orgxml.jar
+}
+
+src_install() {
+ java-pkg_dojar build/readseq.jar
+
+ java-pkg_dolauncher
+}
+
+pkg_postinst() {
+ elog "Documentation is available at"
+ elog "http://iubio.bio.indiana.edu/soft/molbio/readseq/java/Readseq2-help.html"
+}