summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-10-18 22:49:15 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-10-18 22:49:15 +0000
commitd8821e5c9bd811b4b4911cfff3d91907edbae6a4 (patch)
treec70bfbf7cfe68a63a32cf205585cd397bda10f15 /sci-biology
parentremoved old versions - switched maintainer to qt herd (diff)
downloadgentoo-2-d8821e5c9bd811b4b4911cfff3d91907edbae6a4.tar.gz
gentoo-2-d8821e5c9bd811b4b4911cfff3d91907edbae6a4.tar.bz2
gentoo-2-d8821e5c9bd811b4b4911cfff3d91907edbae6a4.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/seaview/ChangeLog8
-rw-r--r--sci-biology/seaview/files/seaview-4.2-gcc44.patch36
-rw-r--r--sci-biology/seaview/seaview-4.2.ebuild80
3 files changed, 123 insertions, 1 deletions
diff --git a/sci-biology/seaview/ChangeLog b/sci-biology/seaview/ChangeLog
index d60721f7ef3e..2c5613175b04 100644
--- a/sci-biology/seaview/ChangeLog
+++ b/sci-biology/seaview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/seaview
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/ChangeLog,v 1.29 2009/10/07 18:36:07 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/ChangeLog,v 1.30 2009/10/18 22:49:14 weaver Exp $
+
+*seaview-4.2 (18 Oct 2009)
+
+ 18 Oct 2009; Andrey Kislyuk <weaver@gentoo.org>
+ +files/seaview-4.2-gcc44.patch, +seaview-4.2.ebuild:
+ Version bump and gcc-4.4 patch
07 Oct 2009; Andrey Kislyuk <weaver@gentoo.org> metadata.xml,
+seaview-4.1.ebuild, seaview-20071113.ebuild:
diff --git a/sci-biology/seaview/files/seaview-4.2-gcc44.patch b/sci-biology/seaview/files/seaview-4.2-gcc44.patch
new file mode 100644
index 000000000000..e472ea96048c
--- /dev/null
+++ b/sci-biology/seaview/files/seaview-4.2-gcc44.patch
@@ -0,0 +1,36 @@
+diff -durr seaview.orig/seaview.cxx seaview/seaview.cxx
+--- seaview.orig/seaview.cxx 2009-10-12 14:33:40.000000000 +0000
++++ seaview/seaview.cxx 2009-10-18 17:02:56.612201461 +0000
+@@ -3903,7 +3903,7 @@
+ if( clipboard_contains_alignment(clipboard) ) {
+ char **seqs, **seqnames, **comments, *p, *message;
+ int i, count, num, changedwname = FALSE;
+- p = strchr(clipboard, ':') + 1;
++ p = const_cast<char*>(strchr(clipboard, ':')) + 1;
+ count = read_mase_seqs_header(p, &seqs, &seqnames,
+ &comments, NULL, &message);
+ if(count == 0) return;
+diff -durr seaview.orig/use_mase_files.cxx seaview/use_mase_files.cxx
+--- seaview.orig/use_mase_files.cxx 2009-10-10 15:36:30.000000000 +0000
++++ seaview/use_mase_files.cxx 2009-10-18 17:02:56.612201461 +0000
+@@ -1523,7 +1523,7 @@
+ void inform_prog_dir(const char *arg0)
+ {
+ char *p;
+-if((p = strrchr(arg0, '/')) != NULL) {
++if((p = const_cast<char*>(strrchr(arg0, '/'))) != NULL) {
+ memcpy(seaview_prog_dir, arg0, p - arg0 + 1);
+ seaview_prog_dir[p - arg0 + 1] = 0;
+ }
+@@ -1764,9 +1764,9 @@
+ char *p;
+
+ #if defined(WIN32)
+- p = strrchr(pathname,'\\');
++ p = const_cast<char*>(strrchr(pathname,'\\'));
+ #else
+- p = strrchr(pathname,'/');
++ p = const_cast<char*>(strrchr(pathname,'/'));
+ #endif
+ if(p == NULL) dirname[0] = 0;
+ else {
diff --git a/sci-biology/seaview/seaview-4.2.ebuild b/sci-biology/seaview/seaview-4.2.ebuild
new file mode 100644
index 000000000000..9b4964d418be
--- /dev/null
+++ b/sci-biology/seaview/seaview-4.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.2.ebuild,v 1.1 2009/10/18 22:49:14 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs multilib eutils base
+
+DESCRIPTION="A graphical multiple sequence alignment editor"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/seaview.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/archive/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf +xft"
+
+DEPEND="x11-libs/fltk:1.1
+ pdf? ( media-libs/pdflib )
+ xft? ( x11-libs/libXft
+ x11-libs/fltk[xft] )"
+RDEPEND="${DEPEND}
+ sci-biology/clustalw
+ || ( sci-libs/libmuscle sci-biology/muscle )
+ sci-biology/phyml"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/seaview-4.2-gcc44.patch" )
+
+src_prepare() {
+ # respect CXXFLAGS (package uses them as CFLAGS)
+ sed -i \
+ -e "s:^CXX.*:CXX = $(tc-getCXX):" \
+ -e "s:\$(OPT):${CXXFLAGS}:" \
+ -e "s:^OPT:#OPT:" \
+ -e "s:^#IFLTK .*:IFLTK = $(fltk-config --use-images --cxxflags):" \
+ -e "s:^#LFLTK .*:LFLTK = $(fltk-config --use-images --ldflags):" \
+ -e "s:^USE_XFT:#USE_XFT:" \
+ -e "s:^#HELPFILE:HELPFILE:" \
+ -e "s:^#PHYMLNAME:PHYMLNAME:" \
+ Makefile || die "sed failed while editing Makefile"
+
+ if use pdf; then
+ sed -i \
+ -e "s:PDF_PS_FLAGS = -DNO_PDF:#PDF_PS_FLAGS = -DNO_PDF:" \
+ -e "s:PDF_PS = postscript:#PDF_PS = postscript:" \
+ -e "s:#PDF_INC = \$(HOME)/PDFlibLite:PDF_INC = /usr/include:" \
+ -e "s:#PDF_LIB = \$(HOME)/PDFlibLite:PDF_LIB = /usr/lib:" \
+ -e "s:#PDF_PS = pdf:PDF_PS = pdf:" \
+ -e "s:#PDF_PS_FLAGS = -I\$(PDF_INC):PDF_PS_FLAGS = -I\$(PDF_INC):" \
+ -e "s:#LPDF = -L\$(PDF_LIB) -lpdf:LPDF = -L\$(PDF_LIB) -lpdf:" \
+ Makefile || die "sed failed while editing Makefile to enable pdf output"
+ fi
+
+ if use xft; then
+ sed -i \
+ -e "s:^#USE_XFT .*:USE_XFT = -DUSE_XFT $(xft-config --cflags):" \
+ -e "s:-lXft:$(xft-config --libs):" \
+ Makefile || die "sed failed while editing Makefile to enable xft"
+ else
+ sed -i -e "s:-lXft::" Makefile || die
+ fi
+ base_src_prepare
+}
+
+src_install() {
+ dobin seaview || die
+
+ # /usr/share/seaview/seaview.html is hardcoded in the binary, see Makefile
+ insinto /usr/share/seaview
+ doins example.nxs seaview.html
+
+ insinto /usr/share/seaview/images
+ doins seaview.xpm || die
+
+ make_desktop_entry seaview Seaview /usr/share/pixmaps/seaview.xpm || die
+
+ doman seaview.1 || die
+}