summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-04-13 06:21:23 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-04-13 06:21:23 +0000
commit8509a81e6f72c8a48ccf67938cdb38e62ee6a258 (patch)
treedcf2257f8bd4e1af56091aa0bd4c4fcf751c26e0 /sci-calculators/tiemu
parentVersion bump. (diff)
downloadgentoo-2-8509a81e6f72c8a48ccf67938cdb38e62ee6a258.tar.gz
gentoo-2-8509a81e6f72c8a48ccf67938cdb38e62ee6a258.tar.bz2
gentoo-2-8509a81e6f72c8a48ccf67938cdb38e62ee6a258.zip
Removed obsolete virtual link cable wrt #363383 by jimtahu
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators/tiemu')
-rw-r--r--sci-calculators/tiemu/ChangeLog6
-rw-r--r--sci-calculators/tiemu/files/tiemu-3.03-r2820.patch28
-rw-r--r--sci-calculators/tiemu/tiemu-3.03.ebuild10
3 files changed, 38 insertions, 6 deletions
diff --git a/sci-calculators/tiemu/ChangeLog b/sci-calculators/tiemu/ChangeLog
index a84039775a7f..008ef5354984 100644
--- a/sci-calculators/tiemu/ChangeLog
+++ b/sci-calculators/tiemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-calculators/tiemu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/ChangeLog,v 1.6 2011/03/02 21:27:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/ChangeLog,v 1.7 2011/04/13 06:21:23 xarthisius Exp $
+
+ 13 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> tiemu-3.03.ebuild,
+ +files/tiemu-3.03-r2820.patch:
+ Removed obsolete virtual link cable wrt #363383 by jimtahu
02 Mar 2011; Justin Lecher <jlec@gentoo.org> tiemu-3.03.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-calculators/tiemu/files/tiemu-3.03-r2820.patch b/sci-calculators/tiemu/files/tiemu-3.03-r2820.patch
new file mode 100644
index 000000000000..cf563e8d4c67
--- /dev/null
+++ b/sci-calculators/tiemu/files/tiemu-3.03-r2820.patch
@@ -0,0 +1,28 @@
+Removed obsolete virtual link cable.
+
+http://svn.tilp.info/cgi-bin/viewvc.cgi?view=rev&root=tiemu&revision=2820
+https://bugs.gentoo.org/show_bug.cgi?id=363383
+
+--- src/gui/device.c
++++ src/gui/device.c
+@@ -102,10 +102,6 @@
+ gtk_option_menu_set_history(GTK_OPTION_MENU(data), 7);
+ break;
+
+- case CABLE_VTL:
+- gtk_option_menu_set_history(GTK_OPTION_MENU(data), 8);
+- break;
+-
+ case CABLE_ILP:
+ gtk_option_menu_set_history(GTK_OPTION_MENU(data), 9);
+ break;
+@@ -194,8 +190,7 @@
+ case 5: tmp.cable_model = CABLE_USB; break;
+ case 6: tmp.cable_model = CABLE_VTI; break;
+ case 7: tmp.cable_model = CABLE_TIE; break;
+- case 8: tmp.cable_model = CABLE_VTL; break;
+- case 9: tmp.cable_model = CABLE_ILP; break;
++ case 8: tmp.cable_model = CABLE_ILP; break;
+ }
+ }
+
diff --git a/sci-calculators/tiemu/tiemu-3.03.ebuild b/sci-calculators/tiemu/tiemu-3.03.ebuild
index 27ac206080d8..a65b027df2aa 100644
--- a/sci-calculators/tiemu/tiemu-3.03.ebuild
+++ b/sci-calculators/tiemu/tiemu-3.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/tiemu-3.03.ebuild,v 1.5 2011/03/02 21:27:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/tiemu-3.03.ebuild,v 1.6 2011/04/13 06:21:23 xarthisius Exp $
EAPI=2
inherit eutils
@@ -14,8 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dbus nls sdl threads xinerama"
-RDEPEND="
- sci-libs/libticables2
+RDEPEND="sci-libs/libticables2
sci-libs/libticalcs2
sci-libs/libtifiles2
sci-libs/libticonv
@@ -32,7 +31,8 @@ DEPEND="${RDEPEND}
xinerama? ( x11-proto/xineramaproto )"
src_prepare() {
- epatch "${FILESDIR}"/${P}-remove_depreciated_gtk_calls.patch
+ epatch "${FILESDIR}"/${P}-remove_depreciated_gtk_calls.patch \
+ "${FILESDIR}"/${P}-r2820.patch
# Don't use GTK_DISABLE_DEPRECATED flags
sed 's:-DGTK_DISABLE_DEPRECATED::g' -i configure.ac configure || die
@@ -53,7 +53,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
rm -f "${D}"usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES}
dodoc AUTHORS NEWS README README.linux RELEASE TODO
make_desktop_entry tiemu "TiEmu Calculator" \