summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-11 10:50:27 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-11 10:50:27 +0000
commit3026a4b7011bef8f11ff2787e0593bb5c36a285d (patch)
tree9472258c89ac872cb816471a9d3e399c2aeae9a2 /sci-calculators/wcalc/wcalc-2.3.1.ebuild
parentNew version for GNOME 2.24. New set of backgrounds. (diff)
downloadgentoo-2-3026a4b7011bef8f11ff2787e0593bb5c36a285d.tar.gz
gentoo-2-3026a4b7011bef8f11ff2787e0593bb5c36a285d.tar.bz2
gentoo-2-3026a4b7011bef8f11ff2787e0593bb5c36a285d.zip
Added patch to fix parallel build issues (bug #241176).
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-calculators/wcalc/wcalc-2.3.1.ebuild')
-rw-r--r--sci-calculators/wcalc/wcalc-2.3.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-calculators/wcalc/wcalc-2.3.1.ebuild b/sci-calculators/wcalc/wcalc-2.3.1.ebuild
index d1bb6ecf14a1..95c5c47126bb 100644
--- a/sci-calculators/wcalc/wcalc-2.3.1.ebuild
+++ b/sci-calculators/wcalc/wcalc-2.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/wcalc/wcalc-2.3.1.ebuild,v 1.1 2008/03/14 13:21:44 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/wcalc/wcalc-2.3.1.ebuild,v 1.2 2008/10/11 10:50:27 markusle Exp $
-inherit eutils
+inherit eutils autotools
MYP="Wcalc-${PV}"
DESCRIPTION="A flexible command-line scientific calculator"
@@ -20,6 +20,13 @@ DEPEND="readline? ( sys-libs/readline )
S="${WORKDIR}"/${MYP}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-parallel-build.patch
+ eautoreconf
+}
+
src_compile() {
econf $(use_with readline) || die "econf failed."
emake || die "emake failed."