summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-18 00:41:14 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-18 00:41:14 +0000
commit54e907d3f772ed57c3a213a20d519468f95169ee (patch)
tree3cb2cba90aac7849faf2881e74a2d30c7da99306 /sci-calculators
parentx11-base/xorg-server: add patch to fix build issue with some locales (see bug... (diff)
downloadgentoo-2-54e907d3f772ed57c3a213a20d519468f95169ee.tar.gz
gentoo-2-54e907d3f772ed57c3a213a20d519468f95169ee.tar.bz2
gentoo-2-54e907d3f772ed57c3a213a20d519468f95169ee.zip
New revision has improved ebuild logic to remove the -fno-exception flag (fixes bug #242276).
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-SENTINEL-3 i686)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/qalculate-kde/ChangeLog9
-rw-r--r--sci-calculators/qalculate-kde/qalculate-kde-0.9.6-r2.ebuild37
2 files changed, 45 insertions, 1 deletions
diff --git a/sci-calculators/qalculate-kde/ChangeLog b/sci-calculators/qalculate-kde/ChangeLog
index d50c10240f98..39fec5ded0ac 100644
--- a/sci-calculators/qalculate-kde/ChangeLog
+++ b/sci-calculators/qalculate-kde/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-calculators/qalculate-kde
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-kde/ChangeLog,v 1.25 2008/10/12 16:02:18 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-kde/ChangeLog,v 1.26 2008/10/18 00:41:14 markusle Exp $
+
+*qalculate-kde-0.9.6-r2 (18 Oct 2008)
+
+ 18 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+ +qalculate-kde-0.9.6-r2.ebuild:
+ New revision has improved ebuild logic to remove the -fno-exception
+ flag (fixes bug #242276).
12 Oct 2008; nixnut <nixnut@gentoo.org> qalculate-kde-0.9.6-r1.ebuild:
Stable on ppc wrt bug 240516
diff --git a/sci-calculators/qalculate-kde/qalculate-kde-0.9.6-r2.ebuild b/sci-calculators/qalculate-kde/qalculate-kde-0.9.6-r2.ebuild
new file mode 100644
index 000000000000..0ff0e63e35e1
--- /dev/null
+++ b/sci-calculators/qalculate-kde/qalculate-kde-0.9.6-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/qalculate-kde/qalculate-kde-0.9.6-r2.ebuild,v 1.1 2008/10/18 00:41:14 markusle Exp $
+
+inherit kde
+
+DESCRIPTION="A modern multi-purpose calculator for KDE"
+LICENSE="GPL-2"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sci-libs/libqalculate-0.9.6-r1"
+
+need-kde 3.1
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}"/${P}-remove-link.patch
+ epatch "${FILESDIR}"/${P}-cln-config.patch
+}
+
+src_compile() {
+ # remove configure to force rebuild of autotools
+ # by the kde eclass
+ rm -f ./configure || die "Failed to remove configure"
+ kde_src_compile myconf configure
+ sed -e "s:-fno-exceptions::g" \
+ -i Makefile -i src/Makefile \
+ || die "Failed to disable -fno-exceptions"
+ kde_src_compile make
+}