summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-03-23 13:15:46 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-03-23 13:15:46 +0000
commite78d9891498d696ae4f02fc8429644e10af27492 (patch)
tree80220beaf46eea00e2a528f851adfec703ab2a78 /sci-chemistry/GromacsWrapper
parentInitial import (diff)
downloadgentoo-2-e78d9891498d696ae4f02fc8429644e10af27492.tar.gz
gentoo-2-e78d9891498d696ae4f02fc8429644e10af27492.tar.bz2
gentoo-2-e78d9891498d696ae4f02fc8429644e10af27492.zip
Initial import
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'sci-chemistry/GromacsWrapper')
-rw-r--r--sci-chemistry/GromacsWrapper/ChangeLog9
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild40
-rw-r--r--sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch28
-rw-r--r--sci-chemistry/GromacsWrapper/metadata.xml9
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-chemistry/GromacsWrapper/ChangeLog b/sci-chemistry/GromacsWrapper/ChangeLog
new file mode 100644
index 000000000000..f24b2bf0d641
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-chemistry/GromacsWrapper
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/GromacsWrapper/ChangeLog,v 1.1 2013/03/23 13:15:46 alexxy Exp $
+
+*GromacsWrapper-0.3.1 (23 Mar 2013)
+
+ 23 Mar 2013; Alexey Shvetsov <alexxy@gentoo.org> +GromacsWrapper-0.3.1.ebuild,
+ +files/0001-Drop-chmod-hack.patch, +metadata.xml:
+ Initial import
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild
new file mode 100644
index 000000000000..48d72e1607cb
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/GromacsWrapper/GromacsWrapper-0.3.1.ebuild,v 1.1 2013/03/23 13:15:46 alexxy Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/orbeckst/${PN}.git
+ https://github.com/orbeckst/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/orbeckst/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="GromacsWrapper - a python framework for Gromacs"
+HOMEPAGE="http://orbeckst.github.com/GromacsWrapper/"
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-python/matplotlib-0.91.3
+ >=dev-python/RecSQL-0.3
+ >=sci-libs/scipy-0.9
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/0001-Drop-chmod-hack.patch"
+)
diff --git a/sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch b/sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch
new file mode 100644
index 000000000000..8645df77b86e
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/files/0001-Drop-chmod-hack.patch
@@ -0,0 +1,28 @@
+From 49b8d9662365e0e9b0725682b8a8479de402b272 Mon Sep 17 00:00:00 2001
+From: Alexey Shvetsov <alexxy@gentoo.org>
+Date: Sat, 23 Mar 2013 16:40:04 +0400
+Subject: [PATCH] Drop chmod hack.
+
+It doesnt work if wrapper installed system-wide
+
+Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
+---
+ gromacs/config.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/gromacs/config.py b/gromacs/config.py
+index cece6fc..2e686e7 100644
+--- a/gromacs/config.py
++++ b/gromacs/config.py
+@@ -619,8 +619,6 @@ del g
+ # Must extract because it is part of a zipped python egg;
+ # see http://peak.telecommunity.com/DevCenter/PythonEggs#accessing-package-resources
+ GridMAT_MD = resource_filename(__name__,'external/GridMAT-MD_v1.0.2/GridMAT-MD.pl')
+-os.chmod(GridMAT_MD, 0755)
+-
+
+ #: 3rd party bundled analysis scripts and tools; this is a list of triplets of
+ #:
+--
+1.8.1.5
+
diff --git a/sci-chemistry/GromacsWrapper/metadata.xml b/sci-chemistry/GromacsWrapper/metadata.xml
new file mode 100644
index 000000000000..fe317282e65d
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>