summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-30 11:52:05 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-30 11:52:05 +0000
commit9a6942379349c626a320129f7060865450542875 (patch)
treeacb79d1bcad81b3b8201e54005a2d26ecbca4a4c /sci-chemistry/apbs
parentversion bump (diff)
downloadgentoo-2-9a6942379349c626a320129f7060865450542875.tar.gz
gentoo-2-9a6942379349c626a320129f7060865450542875.tar.bz2
gentoo-2-9a6942379349c626a320129f7060865450542875.zip
sci-chemistry/apbs: Remove redundant python dir after installation
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog7
-rw-r--r--sci-chemistry/apbs/apbs-1.4.1-r2.ebuild126
2 files changed, 132 insertions, 1 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 8d497d360009..256bd9b03968 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.69 2014/10/30 07:30:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.70 2014/10/30 11:52:05 jlec Exp $
+
+*apbs-1.4.1-r2 (30 Oct 2014)
+
+ 30 Oct 2014; Justin Lecher <jlec@gentoo.org> +apbs-1.4.1-r2.ebuild:
+ Remove redundant python dir after installation
30 Oct 2014; Justin Lecher <jlec@gentoo.org> apbs-1.4.1-r1.ebuild:
Fix build problems, #527344
diff --git a/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild b/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..c7e432777f37
--- /dev/null
+++ b/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild,v 1.1 2014/10/30 11:52:05 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils distutils-r1 flag-o-matic multilib toolchain-funcs
+
+GITHUB_REV="74fcb8676de69ed04ddab8976a8b05a6caaf4d65"
+
+DESCRIPTION="Evaluation of electrostatic properties of nanoscale biomolecular systems"
+HOMEPAGE="http://www.poissonboltzmann.org/apbs/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
+SRC_URI="https://github.com/Electrostatics/apbs-pdb2pqr/archive/${GITHUB_REV}.zip -> ${P}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc examples fast +fetk mpi openmp python tools"
+
+REQUIRED_USE="
+ mpi? ( !python )
+ python? ( tools fetk ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/maloc[mpi=]
+ virtual/blas
+ sys-libs/readline
+ fetk? (
+ sci-libs/fetk
+ sci-libs/amd
+ sci-libs/umfpack
+ sci-libs/superlu
+ )
+ mpi? ( virtual/mpi )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+S="${WORKDIR}"/${PN}-pdb2pqr-${GITHUB_REV}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multilib.patch
+ "${FILESDIR}"/${P}-manip.patch
+ "${FILESDIR}"/${P}-python.patch
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags eigen3)
+
+ sed \
+ -e "s:-lblas:$($(tc-getPKG_CONFIG) --libs blas):g" \
+ -e "/TOOLS_PATH/d" \
+ -i CMakeLists.txt || die
+ use doc && MAKEOPTS+=" -j1"
+ if use python; then
+ unset PATCHES || die
+ cd tools/python && distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DTOOLS_PATH="${ED}"/usr
+ -DSYS_LIBPATHS="${EPREFIX}"/usr/$(get_libdir)
+ -DLIBRARY_INSTALL_PATH=$(get_libdir)
+ -DFETK_PATH="${EPREFIX}"/usr/
+ -DBUILD_SHARED_LIBS=ON
+ -DENABLE_QUIT=OFF
+ $(cmake-utils_use_build doc DOC)
+ $(cmake-utils_use_build tools TOOLS)
+ -DENABLE_BEM=OFF
+# ENABLE_BEM: Boundary element method using TABIPB
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable debug VERBOSE_DEBUG)
+ $(cmake-utils_use_enable fast FAST)
+ $(cmake-utils_use_enable fetk FETK)
+ $(cmake-utils_use_enable mpi MPI)
+ $(cmake-utils_use_enable python PYTHON)
+# ENABLE_TINKER: Enable TINKER support
+# ENABLE_iAPBS: Enable iAPBS
+ -DENABLE_iAPBS=ON
+# MAX_MEMORY: Set the maximum memory (in MB) to be used for a job
+ )
+ cmake-utils_src_configure
+ if use python; then
+ cd tools/python && distutils-r1_src_configure
+ fi
+}
+
+src_compile(){
+ cmake-utils_src_compile
+ if use python; then
+ append-ldflags -L"${S}"/lib
+ cd tools/python && distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ cd tests || die
+ "${PYTHON}" apbs_tester.py -l log || die
+ grep -q 'FAILED' log && die "Tests failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ cmake-utils_src_install
+ local i
+ for i in "${ED}"/usr/bin/*; do
+ if [[ ! "${i}" =~ .*apbs$ ]]; then
+ mv "${i}" "${i}-apbs" || die
+ fi
+ done
+ if use python; then
+ cd tools/python && distutils-r1_src_install
+ rm -rf "${ED}"/usr/share/apbs/tools/python || die
+ fi
+}