summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2010-05-16 03:22:30 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2010-05-16 03:22:30 +0000
commit727d868f840e89d77523aabe03c17d3696508322 (patch)
tree533f42bbdf16e4ac7f0a1e3a5571ecdb8e6640f4 /sci-chemistry/chemical-mime-data
parentRemoving gnome USE flag from libgsf and goffice. (diff)
downloadgentoo-2-727d868f840e89d77523aabe03c17d3696508322.tar.gz
gentoo-2-727d868f840e89d77523aabe03c17d3696508322.tar.bz2
gentoo-2-727d868f840e89d77523aabe03c17d3696508322.zip
Fix docdir thanks to Diego in bug #299328
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/chemical-mime-data')
-rw-r--r--sci-chemistry/chemical-mime-data/ChangeLog10
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r1.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/sci-chemistry/chemical-mime-data/ChangeLog b/sci-chemistry/chemical-mime-data/ChangeLog
index c5729a0f5507..7f594b01923f 100644
--- a/sci-chemistry/chemical-mime-data/ChangeLog
+++ b/sci-chemistry/chemical-mime-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/chemical-mime-data
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemical-mime-data/ChangeLog,v 1.4 2009/09/18 14:42:47 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemical-mime-data/ChangeLog,v 1.5 2010/05/16 03:22:30 je_fro Exp $
+
+*chemical-mime-data-0.1.94-r1 (16 May 2010)
+
+ 16 May 2010; Jeff Gardner <je_fro@gentoo.org>
+ +chemical-mime-data-0.1.94-r1.ebuild:
+ Fix docdir thanks to Diego in bug #299328
18 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
chemical-mime-data-0.1.94.ebuild:
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r1.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r1.ebuild
new file mode 100644
index 000000000000..0eaa7f4470cd
--- /dev/null
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r1.ebuild,v 1.1 2010/05/16 03:22:30 je_fro Exp $
+
+EAPI="2"
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A collection of data files to add support for chemical MIME types."
+HOMEPAGE="http://chemical-mime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/-data/}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/pkgconfig
+ x11-misc/shared-mime-info
+ dev-util/intltool
+ dev-util/desktop-file-utils
+ dev-libs/libxslt
+ media-gfx/imagemagick[xml]
+ gnome-base/gnome-mime-data"
+
+RDEPEND=""
+
+src_configure() {
+ econf --disable-update-database --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ ewarn "You can ignore any 'Unknown media type in type' warnings."
+}