summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-02-04 14:08:14 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-02-04 14:08:14 +0000
commit17e9e0b0062722bc89ee07f630b83a241fdb04b3 (patch)
tree94617f4fc84aceb7310508de900ddfdc2e187408 /sci-chemistry/chemtool
parentfixed typo (diff)
downloadgentoo-2-17e9e0b0062722bc89ee07f630b83a241fdb04b3.tar.gz
gentoo-2-17e9e0b0062722bc89ee07f630b83a241fdb04b3.tar.bz2
gentoo-2-17e9e0b0062722bc89ee07f630b83a241fdb04b3.zip
Version bump (now with gtk2 support)
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sci-chemistry/chemtool')
-rw-r--r--sci-chemistry/chemtool/ChangeLog9
-rw-r--r--sci-chemistry/chemtool/Manifest12
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.3.ebuild4
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.4.ebuild84
-rw-r--r--sci-chemistry/chemtool/files/digest-chemtool-1.6.41
5 files changed, 96 insertions, 14 deletions
diff --git a/sci-chemistry/chemtool/ChangeLog b/sci-chemistry/chemtool/ChangeLog
index cb0a4b8181bd..ee4f184dba72 100644
--- a/sci-chemistry/chemtool/ChangeLog
+++ b/sci-chemistry/chemtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/chemtool
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.2 2004/12/24 20:11:57 swegener Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/ChangeLog,v 1.3 2005/02/04 14:08:14 phosphan Exp $
+
+*chemtool-1.6.4 (04 Feb 2005)
+
+ 04 Feb 2005; Patrick Kursawe <phosphan@gentoo.org> +chemtool-1.6.4.ebuild:
+ Version bump. Adding optional gtk2 support.
*chemtool-1.6.3 (24 Dec 2004)
diff --git a/sci-chemistry/chemtool/Manifest b/sci-chemistry/chemtool/Manifest
index 879498b378c0..58c38ddc784b 100644
--- a/sci-chemistry/chemtool/Manifest
+++ b/sci-chemistry/chemtool/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 6f3d0b7c1bb71e270fac6a81ebe20dce chemtool-1.6.3.ebuild 1951
+MD5 40bf1af053152e68d808bdaa20bbb92d chemtool-1.6.4.ebuild 1952
MD5 1a69eacd6f581744e8085bc97741bf85 ChangeLog 2688
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 4ae73ea952733fc1500a98a82b1b8f3d files/digest-chemtool-1.6.3 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBzHgTI1lqEGTUzyQRAg6BAJsHNLUZkhdBGS+2Ckels7OPzGmTfgCePUux
-2BmOQrhrDtzp4yAAGZEw7TU=
-=XQdm
------END PGP SIGNATURE-----
+MD5 73e6d16f503d84f586445148c62e1a32 files/digest-chemtool-1.6.4 66
diff --git a/sci-chemistry/chemtool/chemtool-1.6.3.ebuild b/sci-chemistry/chemtool/chemtool-1.6.3.ebuild
index 8295fbf5cf34..f3d539553578 100644
--- a/sci-chemistry/chemtool/chemtool-1.6.3.ebuild
+++ b/sci-chemistry/chemtool/chemtool-1.6.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.3.ebuild,v 1.1 2004/12/24 16:32:14 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.3.ebuild,v 1.2 2005/02/04 14:08:14 phosphan Exp $
inherit eutils kde-functions
diff --git a/sci-chemistry/chemtool/chemtool-1.6.4.ebuild b/sci-chemistry/chemtool/chemtool-1.6.4.ebuild
new file mode 100644
index 000000000000..35c5130b7655
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemtool/chemtool-1.6.4.ebuild,v 1.1 2005/02/04 14:08:14 phosphan Exp $
+
+inherit eutils kde-functions
+
+DESCRIPTION="program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gtk2 gnome kde nls"
+
+DEPEND=">=media-gfx/transfig-3.2.3d
+ || (
+ gtk2? ( =x11-libs/gtk+-2* )
+ =x11-libs/gtk+-1*
+ )
+ x86? ( >=media-libs/libemf-1.0 )"
+
+src_compile() {
+ local config_opts
+ local mycppflags
+ local mykdedir
+ if [ -z "${KDEDIR}" ]; then
+ mykdedir="bogus_kde"
+ else
+ mykdedir="${KDEDIR}"
+ fi
+ if [ ${ARCH} = "x86" ]; then
+ config_opts="--enable-emf"
+ mycppflags="${mycppflags} -I /usr/include/libEMF"
+ fi
+
+ if ! use gtk2; then
+ config_opts="${config_opts} --enable-gtk1"
+ fi
+
+ sed -e "s:\(^CPPFLAGS.*\):\1 ${mycppflags}:" -i Makefile.in || \
+ die "could not append cppflags"
+
+ if use kde; then
+ config_opts="${config_opts} --with-kdedir=${mykdedir}" ;
+ fi
+
+ if use gnome ; then
+ config_opts="${config_opts} --with-gnomedir=/usr" ;
+ else
+ config_opts="${config_opts} --without-gnomedir" ;
+ fi
+
+ econf ${config_opts} \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+
+ local mykdedir="${KDEDIR}"
+ if [ -z "${mykdedir}" ]; then mykdedir="bogus_kde"; fi
+ local sharedirs="applnk/Graphics mimelnk/application icons/hicolor/32x32/mimetypes"
+ for dir in ${sharedirs}; do
+ dodir ${mykdedir}/share/${dir}
+ done
+ dodir /usr/share/mime-types
+ dodir /usr/share/pixmaps/mc
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ if ! use kde; then
+ rm -rf ${D}/${mykdedir}
+ fi
+
+ if ! use gnome; then
+ rm -rf ${D}/usr/share/pixmaps ${D}/usr/share/mime-types
+ fi
+
+ dodoc ChangeLog INSTALL README TODO
+ insinto /usr/share/${PN}/examples
+ doins ${S}/examples/*
+ if ! use nls; then rm -rf ${D}/usr/share/locale; fi
+}
diff --git a/sci-chemistry/chemtool/files/digest-chemtool-1.6.4 b/sci-chemistry/chemtool/files/digest-chemtool-1.6.4
new file mode 100644
index 000000000000..68d3f43da24d
--- /dev/null
+++ b/sci-chemistry/chemtool/files/digest-chemtool-1.6.4
@@ -0,0 +1 @@
+MD5 de2258aa710d7b16093b082963732010 chemtool-1.6.4.tar.gz 409400