summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-01-10 04:43:04 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-01-10 04:43:04 +0000
commit427bb4761bccc463f5d9f7e0185f63f5f7ea5f89 (patch)
tree8300df059cbf86359ca9d19b839f690ba0a01aab /sci-chemistry/cns
parentVersion bump. (diff)
downloadgentoo-2-427bb4761bccc463f5d9f7e0185f63f5f7ea5f89.tar.gz
gentoo-2-427bb4761bccc463f5d9f7e0185f63f5f7ea5f89.tar.bz2
gentoo-2-427bb4761bccc463f5d9f7e0185f63f5f7ea5f89.zip
Add a patch to make CNS compile on unknown architecture/OS combinations, of which ppc is one.
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'sci-chemistry/cns')
-rw-r--r--sci-chemistry/cns/ChangeLog9
-rw-r--r--sci-chemistry/cns/cns-1.2-r1.ebuild6
-rw-r--r--sci-chemistry/cns/files/1.2-allow-unknown-architectures.patch15
3 files changed, 26 insertions, 4 deletions
diff --git a/sci-chemistry/cns/ChangeLog b/sci-chemistry/cns/ChangeLog
index 2e3b8243b953..f92b68b7bdd5 100644
--- a/sci-chemistry/cns/ChangeLog
+++ b/sci-chemistry/cns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/cns
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.8 2007/12/07 08:58:57 dberkholz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.9 2008/01/10 04:43:03 dberkholz Exp $
+
+ 10 Jan 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1.2-allow-unknown-architectures.patch, cns-1.2-r1.ebuild:
+ Add a patch to make CNS compile on unknown architecture/OS combinations, of
+ which ppc is one.
*cns-1.2-r1 (07 Dec 2007)
diff --git a/sci-chemistry/cns/cns-1.2-r1.ebuild b/sci-chemistry/cns/cns-1.2-r1.ebuild
index e7884ca2f74c..88c264056f92 100644
--- a/sci-chemistry/cns/cns-1.2-r1.ebuild
+++ b/sci-chemistry/cns/cns-1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2-r1.ebuild,v 1.1 2007/12/07 08:58:57 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2-r1.ebuild,v 1.2 2008/01/10 04:43:03 dberkholz Exp $
inherit eutils fortran toolchain-funcs
@@ -37,6 +37,8 @@ src_unpack() {
# http://gcc.gnu.org/ml/fortran/2006-02/msg00198.html
epatch "${FILESDIR}"/1.1-time-length-10.patch
+ epatch "${FILESDIR}"/1.2-allow-unknown-architectures.patch
+
# Set up location for the build directory
# Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
sed -i \
diff --git a/sci-chemistry/cns/files/1.2-allow-unknown-architectures.patch b/sci-chemistry/cns/files/1.2-allow-unknown-architectures.patch
new file mode 100644
index 000000000000..327ffb2811b3
--- /dev/null
+++ b/sci-chemistry/cns/files/1.2-allow-unknown-architectures.patch
@@ -0,0 +1,15 @@
+--- cns_solve_1.2.orig/bin/install 2008-01-09 17:21:43.000000000 -0800
++++ cns_solve_1.2/bin/install 2008-01-09 17:21:59.000000000 -0800
+@@ -78,12 +78,6 @@
+ exit 1
+ endif
+ #
+-if ( $CNS_ARCH =~ unknown* ) then
+- echo "the architecture of the machine is unknown - CNS_ARCH=$CNS_ARCH"
+- echo 'aborting installation'
+- exit 1
+-endif
+-#
+ set prod=`echo $CNS_ARCH | awk 'BEGIN{FS="-"}{print $1}'`
+ set cpu=`echo $CNS_ARCH | awk 'BEGIN{FS="-"}{print $2}' | sed 's/[0-9]*\.*[0-9]*$//'`
+ set os=`echo $CNS_ARCH | awk 'BEGIN{FS="-"}{print $3}'`