summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-06 12:44:01 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-06 12:44:01 +0000
commit7cff8f0c3a9bfa1f7b6ef36c93ef8c6108129c0e (patch)
tree87fd2aa00a2d94e53db714276ee3a86e73854ff5 /sci-chemistry/elem
parentVersion bump. (diff)
downloadgentoo-2-7cff8f0c3a9bfa1f7b6ef36c93ef8c6108129c0e.tar.gz
gentoo-2-7cff8f0c3a9bfa1f7b6ef36c93ef8c6108129c0e.tar.bz2
gentoo-2-7cff8f0c3a9bfa1f7b6ef36c93ef8c6108129c0e.zip
Respect LDFLAGS wrt bug 336190. Thanks to Diego for the report. Fix implicit function declarations, quote S, add missing RDEPEND.
(Portage version: 2.2_rc73/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/elem')
-rw-r--r--sci-chemistry/elem/ChangeLog9
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r1.ebuild7
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r2.ebuild35
3 files changed, 46 insertions, 5 deletions
diff --git a/sci-chemistry/elem/ChangeLog b/sci-chemistry/elem/ChangeLog
index 22f1c83bb4c1..8495d7adfcad 100644
--- a/sci-chemistry/elem/ChangeLog
+++ b/sci-chemistry/elem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/elem
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/elem/ChangeLog,v 1.9 2006/10/05 21:13:41 gustavoz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/elem/ChangeLog,v 1.10 2010/09/06 12:44:01 xarthisius Exp $
+
+ 06 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org> elem-1.0.3-r1.ebuild,
+ +elem-1.0.3-r2.ebuild:
+ Respect LDFLAGS wrt bug 336190. Thanks to Diego for the report. Fix
+ implicit function declarations, quote S, add missing RDEPEND.
05 Oct 2006; Gustavo Zacarias <gustavoz@gentoo.org> elem-1.0.3-r1.ebuild:
Stable on sparc
diff --git a/sci-chemistry/elem/elem-1.0.3-r1.ebuild b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
index 9ff3e0ded10e..d17c4675c7de 100644
--- a/sci-chemistry/elem/elem-1.0.3-r1.ebuild
+++ b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/elem/elem-1.0.3-r1.ebuild,v 1.6 2007/07/13 05:48:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/elem/elem-1.0.3-r1.ebuild,v 1.7 2010/09/06 12:44:01 xarthisius Exp $
inherit toolchain-funcs
@@ -13,10 +13,11 @@ SLOT="0"
IUSE=""
DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -e 's:\(^LIBS = .*\):\1 -lXpm:' -i Makefile || die "sed failed"
}
diff --git a/sci-chemistry/elem/elem-1.0.3-r2.ebuild b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..78522eef8235
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/elem/elem-1.0.3-r2.ebuild,v 1.3 2010/09/06 12:44:01 xarthisius Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:\(^LIBS = .*\):\1 -lXpm:' \
+ -e "s:\${FLAGS} -o elem:\$(LDFLAGS) &:" \
+ -i Makefile || die #336190
+ sed -e "/string.h/ i #include <stdlib.h>" \
+ -i elem_cb.c || die #implicit exit()
+}
+
+src_compile () {
+ emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+}
+
+src_install () {
+ dobin elem elem-de elem-en || die
+ dohtml -r doc/* || die
+}