summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-23 12:42:59 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-23 12:42:59 +0000
commit4cec1923e07298046718f76f58b8f22f6449875a (patch)
tree4f2f1f879d6a7fba8d21885c35b8444cc47c501e /sci-chemistry/gamess
parentalpha/ia64/sh/sparc stable wrt #348509 (diff)
downloadgentoo-2-4cec1923e07298046718f76f58b8f22f6449875a.tar.gz
gentoo-2-4cec1923e07298046718f76f58b8f22f6449875a.tar.bz2
gentoo-2-4cec1923e07298046718f76f58b8f22f6449875a.zip
[sci-chemistry/gamess] Fix neo build
(Portage version: 2.2.0_alpha18_p3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gamess')
-rw-r--r--sci-chemistry/gamess/ChangeLog10
-rw-r--r--sci-chemistry/gamess/files/gamess-neo-fix.patch24
-rw-r--r--sci-chemistry/gamess/gamess-20101001.1-r1.ebuild (renamed from sci-chemistry/gamess/gamess-20101001.1.ebuild)5
3 files changed, 35 insertions, 4 deletions
diff --git a/sci-chemistry/gamess/ChangeLog b/sci-chemistry/gamess/ChangeLog
index 0b91c031472b..a28f95c02e85 100644
--- a/sci-chemistry/gamess/ChangeLog
+++ b/sci-chemistry/gamess/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/gamess
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.48 2010/12/29 18:31:56 alexxy Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.49 2011/01/23 12:42:58 alexxy Exp $
+
+*gamess-20101001.1-r1 (23 Jan 2011)
+
+ 23 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> -gamess-20101001.1.ebuild,
+ +gamess-20101001.1-r1.ebuild, +files/gamess-neo-fix.patch:
+ Fix neo build for gamess
29 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org>
-gamess-20090112.1-r1.ebuild, -files/gamess-20090112.1.gentoo.patch,
diff --git a/sci-chemistry/gamess/files/gamess-neo-fix.patch b/sci-chemistry/gamess/files/gamess-neo-fix.patch
new file mode 100644
index 000000000000..299b4a0db72d
--- /dev/null
+++ b/sci-chemistry/gamess/files/gamess-neo-fix.patch
@@ -0,0 +1,24 @@
+diff -urN gamess.orig/qmnuc/neo/neogrd.src gamess/qmnuc/neo/neogrd.src
+--- gamess.orig/qmnuc/neo/neogrd.src 2010-06-16 22:46:15.000000000 +0400
++++ gamess/qmnuc/neo/neogrd.src 2011-01-23 15:35:56.000000000 +0300
+@@ -1435,20 +1435,10 @@
+ C
+ DO 790 IC = 1,MAXIC
+ IF(ICHARM.EQ.0) THEN
+- IF(IC.LE.NAT) THEN
+ ZNUC = -ZAN(IC)
+-C ZNUC = ZAN(IC)
+ CX = C(1,IC)
+ CY = C(2,IC)
+ CZ = C(3,IC)
+- ELSE
+- IAZ=IATSP(IC-NAT)
+- ZNUC = -COSZAN(IC-NAT)
+-C ZNUC = COSZAN(IC-NAT)
+- CX = CORZAN(1,IC-NAT)
+- CY = CORZAN(2,IC-NAT)
+- CZ = CORZAN(3,IC-NAT)
+- END IF
+ ELSE
+ ZNUC = -QCHM(ICHARM)
+ CX = XCHM(ICHARM)
diff --git a/sci-chemistry/gamess/gamess-20101001.1.ebuild b/sci-chemistry/gamess/gamess-20101001.1-r1.ebuild
index ca1ae9434627..260b9c53d6e5 100644
--- a/sci-chemistry/gamess/gamess-20101001.1.ebuild
+++ b/sci-chemistry/gamess/gamess-20101001.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20101001.1.ebuild,v 1.7 2010/12/29 18:31:56 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-20101001.1-r1.ebuild,v 1.1 2011/01/23 12:42:58 alexxy Exp $
EAPI="3"
@@ -132,6 +132,7 @@ src_prepare() {
# enable NEO
if use neo; then
+ epatch "${FILESDIR}/${PN}-neo-fix.patch"
sed -e "s:NEO=false:NEO=true:" -i compall lked || \
die "Failed to enable NEO code"
else