summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-26 19:17:33 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-26 19:17:33 +0000
commit757d4d8d317a0562cc971412d6a67dffd4eceb7e (patch)
tree6016c92dd46439e016df3bceb3cca1883bf03772 /sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
parentFix for bug #400595 / CVE-2012-0029 (picked from qemu-kvm ebuild). Restored m... (diff)
downloadgentoo-2-757d4d8d317a0562cc971412d6a67dffd4eceb7e.tar.gz
gentoo-2-757d4d8d317a0562cc971412d6a67dffd4eceb7e.tar.bz2
gentoo-2-757d4d8d317a0562cc971412d6a67dffd4eceb7e.zip
Fix installation with USE=-nls, #395125
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild')
-rw-r--r--sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild b/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
index 3cf2b8a00162..b525e26ad231 100644
--- a/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
+++ b/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild,v 1.3 2011/12/13 23:34:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.10-r2.ebuild,v 1.4 2012/01/26 19:17:33 jlec Exp $
EAPI="2"
@@ -24,15 +24,21 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
- epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-nls.patch
}
src_compile() {
+ local myopts
+ use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
emake CC=$(tc-getCC) ${myopts} || die
}
src_install() {
+ local myopts
+ use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
emake DESTDIR="${D}" ${myopts} install || die
dodoc AUTHORS ChangeLog README NEWS || die
+ newdoc po/README README.translation || die
}