summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-21 12:28:50 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-21 12:28:50 +0000
commitc284e04e9a1b189b39d2519fa73ff7e64d689fdf (patch)
tree27a115eee58e17225bb59d8aa3e8de88b049a21a /sci-chemistry/mm-align
parentWill give it love, added myself as maintainer (diff)
downloadgentoo-2-c284e04e9a1b189b39d2519fa73ff7e64d689fdf.tar.gz
gentoo-2-c284e04e9a1b189b39d2519fa73ff7e64d689fdf.tar.bz2
gentoo-2-c284e04e9a1b189b39d2519fa73ff7e64d689fdf.zip
New addition, written by me
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/mm-align')
-rw-r--r--sci-chemistry/mm-align/ChangeLog10
-rw-r--r--sci-chemistry/mm-align/Manifest5
-rw-r--r--sci-chemistry/mm-align/files/CMakeLists.txt5
-rw-r--r--sci-chemistry/mm-align/metadata.xml26
-rw-r--r--sci-chemistry/mm-align/mm-align-20120321.ebuild22
5 files changed, 68 insertions, 0 deletions
diff --git a/sci-chemistry/mm-align/ChangeLog b/sci-chemistry/mm-align/ChangeLog
new file mode 100644
index 000000000000..013740b098e4
--- /dev/null
+++ b/sci-chemistry/mm-align/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/mm-align
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mm-align/ChangeLog,v 1.1 2012/03/21 12:28:50 jlec Exp $
+
+*mm-align-20120321 (21 Mar 2012)
+
+ 21 Mar 2012; Justin Lecher <jlec@gentoo.org> +mm-align-20120321.ebuild,
+ +files/CMakeLists.txt, +metadata.xml:
+ New addition, written by me
+
diff --git a/sci-chemistry/mm-align/Manifest b/sci-chemistry/mm-align/Manifest
new file mode 100644
index 000000000000..e78ee359010d
--- /dev/null
+++ b/sci-chemistry/mm-align/Manifest
@@ -0,0 +1,5 @@
+AUX CMakeLists.txt 142 RMD160 88da2f65bb9b44b074fa2c8afb3352b108e13a1c SHA1 86242c8dd99f74c5e3d91889f9b2069f60b134d7 SHA256 29f1003a81107cc60a17f0fe26fb59b91a28fb3e46224552b856bf505f777ae0
+DIST MM-align-20120321.tar.xz 20072 RMD160 3bf453c062f9f06e5b4da2f2a174fb15403e9df5 SHA1 94c9633511794e1b71e2d2cbc9447c6f3fde9d2f SHA256 0158a93a06257b885630ab7bed3b7bf8dca2ee12217c84d019829a1e34f3eeb3
+EBUILD mm-align-20120321.ebuild 495 RMD160 c8afb3b8bcd30bbedb712647594fdc5b16c81854 SHA1 ef1a352aab7ab6ef28aec6d3097d2296648e5c41 SHA256 37f7aa31ad51f7068d09ff5d64ab06b9c55e3c8ba2e2f86bfe0312fc4e714019
+MISC ChangeLog 302 RMD160 422377b6d1d67861b2955a5fb023d89415f65e4a SHA1 954218c7bf0047af76f4c33d0c40f34c4d867b48 SHA256 32507b0849c0d226c7ff96b93b7fa55a7f0d1866b33bfefd683edd2fabaae0b3
+MISC metadata.xml 1407 RMD160 a54114b0bf812198ccf5e2a49288c0f403a2b483 SHA1 6f80e88b1cdfd9de0b5031ab83ed297c8c794482 SHA256 7de95c3976eb176863f4356e10193beedd1563bd98f62998d6573986c71b5edc
diff --git a/sci-chemistry/mm-align/files/CMakeLists.txt b/sci-chemistry/mm-align/files/CMakeLists.txt
new file mode 100644
index 000000000000..635ffdd67418
--- /dev/null
+++ b/sci-chemistry/mm-align/files/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required (VERSION 2.6)
+project (MM-align Fortran)
+add_executable(MMalign MM-align.f)
+
+install (TARGETS MMalign DESTINATION bin)
diff --git a/sci-chemistry/mm-align/metadata.xml b/sci-chemistry/mm-align/metadata.xml
new file mode 100644
index 000000000000..6a27c1a3ac5f
--- /dev/null
+++ b/sci-chemistry/mm-align/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+MM-align is an algorithm for structurally aligning multiple-chain
+protein-protein complexes. The algorithm is built on a heuristic
+iteration of a modified Needleman-Wunsch dynamic programming (DP)
+algorithm, with the alignment score specified by the inter-complex residue
+distances. The multiple chains in each complex are first joined, in every
+possible order, and then simultaneously aligned with cross-chain alignments
+prevented. The alignments of interface residues are enhanced by an
+interface-specific weighting factor. An optimal alignment between two complexes,
+as well as the overall TM-score, will be reported for each comparison.
+What is the difference between TM-align and MM-align? TM-align is for aligning
+monomer protein structures while MM-align is designed for aligning
+multiple-chain protein complex structures. Although one can still use TM-align
+to align protein complexes after manually joining the chains, this will lead
+to suboptimal alignments with unphysical cross alignments. Therefore, the
+best result will be obtained if one uses TM-align to monomer structures and
+MM-align for multimer structures.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/mm-align/mm-align-20120321.ebuild b/sci-chemistry/mm-align/mm-align-20120321.ebuild
new file mode 100644
index 000000000000..e5b3c19faddf
--- /dev/null
+++ b/sci-chemistry/mm-align/mm-align-20120321.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mm-align/mm-align-20120321.ebuild,v 1.1 2012/03/21 12:28:50 jlec Exp $
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Protein Complex Structural Alignment"
+HOMEPAGE="http://zhanglab.ccmb.med.umich.edu/MM-align/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/MM-align-${PV}.tar.xz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}