summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-15 10:51:43 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-15 10:51:43 +0000
commit18d89b7b630fa3c351403ae74532885e33d204de (patch)
tree0aadfe273d5882d441598a88dc260f11746c0a6c /sci-chemistry/molrep
parentx86 stable wrt bug #322691 (diff)
downloadgentoo-2-18d89b7b630fa3c351403ae74532885e33d204de.tar.gz
gentoo-2-18d89b7b630fa3c351403ae74532885e33d204de.tar.bz2
gentoo-2-18d89b7b630fa3c351403ae74532885e33d204de.zip
Version Bump, test cases fixed
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/molrep')
-rw-r--r--sci-chemistry/molrep/ChangeLog9
-rw-r--r--sci-chemistry/molrep/files/11.0.00-respect-FLAGS.patch12
-rw-r--r--sci-chemistry/molrep/files/11.0.00-test.patch191
-rw-r--r--sci-chemistry/molrep/molrep-11.0.00.ebuild54
4 files changed, 265 insertions, 1 deletions
diff --git a/sci-chemistry/molrep/ChangeLog b/sci-chemistry/molrep/ChangeLog
index 7816b64c28c4..3446e19445a7 100644
--- a/sci-chemistry/molrep/ChangeLog
+++ b/sci-chemistry/molrep/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/molrep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.4 2010/04/25 11:29:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.5 2010/06/15 10:51:43 jlec Exp $
+
+*molrep-11.0.00 (15 Jun 2010)
+
+ 15 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ +files/11.0.00-respect-FLAGS.patch, +molrep-11.0.00.ebuild,
+ +files/11.0.00-test.patch:
+ Version Bump, test cases fixed
*molrep-10.2.38 (12 Mar 2010)
diff --git a/sci-chemistry/molrep/files/11.0.00-respect-FLAGS.patch b/sci-chemistry/molrep/files/11.0.00-respect-FLAGS.patch
new file mode 100644
index 000000000000..c18b9a1e3f0d
--- /dev/null
+++ b/sci-chemistry/molrep/files/11.0.00-respect-FLAGS.patch
@@ -0,0 +1,12 @@
+diff --git a/src/makefile b/src/makefile
+index 30d0de7..10dd68f 100755
+--- a/src/makefile
++++ b/src/makefile
+@@ -46,6 +46,6 @@ molrep_dummy.o: molrep_dummy.f
+ $(MR_FORT) -c molrep_dummy.f
+
+ molrep: $(OBJS)
+- $(MR_FORT) -o $(BIN)/molrep $(OBJSL) $(MR_LIBRARY)
++ $(MR_FORT) $(LDFLAGS) -o $(BIN)/molrep $(OBJSL) $(MR_LIBRARY)
+
+ # --------------------------------
diff --git a/sci-chemistry/molrep/files/11.0.00-test.patch b/sci-chemistry/molrep/files/11.0.00-test.patch
new file mode 100644
index 000000000000..d90cfb8c7b35
--- /dev/null
+++ b/sci-chemistry/molrep/files/11.0.00-test.patch
@@ -0,0 +1,191 @@
+diff --git a/molrep_check/em.bat b/molrep_check/em.bat
+index 2f0f992..96ddd75 100755
+--- a/molrep_check/em.bat
++++ b/molrep_check/em.bat
+@@ -8,6 +8,8 @@ $MR_TEST/molrep -m ../em/model.pdb -f ../em/pel.map -po out/ -ps scr/ -i <<stop
+ # --------------------------------
+ _NMON 6
+ stop
++echo $?
++[[ $? ]] || exit 1
+ # --------------------------------
+ #
+ # 2. Atomic model --> EM map
+@@ -20,6 +22,7 @@ $MR_TEST/molrep -m ../em/model.pdb -f ../em/pel.map -po out/ -ps scr/ -i <<stop
+ _NMON 6
+ _prf y
+ stop
++[[ $? ]] || exit 1
+ # --------------------------------
+ #
+ # 3. Atomic model --> EM map
+@@ -36,6 +39,7 @@ _ncs 322
+ _centre 0.500 0.490 0.490
+ _angles 0.0 0.0 90.0
+ stop
++[[ $? ]] || exit 1
+ # --------------------------------
+ #
+ cp out/molrep.pdb hexamer.pdb
+@@ -52,6 +56,7 @@ $MR_TEST/molrep -mx hexamer.pdb -f ../em/pel.map -po out/ -ps scr/ -i <<stop
+ # --------------------------------
+ _DOM s
+ stop
++[[ $? ]] || exit 1
+ # --------------------------------
+ #
+ # 5. EM --> X-ray
+@@ -60,6 +65,7 @@ stop
+ $MR_TEST/molrep -f ../em/p2.cif -m ../em/pel.map -po out/ -ps scr/ -i <<stop
+ # --------------------------------
+ stop
++[[ $? ]] || exit 1
+ # --------------------------------
+ #
+ # 6. Placing the model to a particular orientation and position.
+@@ -72,4 +78,5 @@ $MR_TEST/molrep -f ../em/p2.cif -m ../em/pel.map -po out/ -ps scr/ -i <<stop
+ _fun s
+ _file_t ../em/tab
+ stop
++[[ $? ]] || exit 1
+ #==========================================
+diff --git a/molrep_check/mr.bat b/molrep_check/mr.bat
+index 284a4cd..6e00695 100755
+--- a/molrep_check/mr.bat
++++ b/molrep_check/mr.bat
+@@ -10,6 +10,7 @@
+ $MR_TEST/molrep -f ../data/test.mtz -m ../data/test_mod.pdb -po out/ -ps scr/ -i <<stop
+ # --------------------------------
+ stop
++[[ $? ]] || exit 1
+ #
+ # =================================================================
+ #
+@@ -26,6 +27,7 @@ _nmon 2
+ _COMPL .5
+ _SIM .7
+ stop
++[[ $? ]] || exit 1
+ #
+ # =================================================================
+ #
+@@ -46,6 +48,7 @@ $MR_TEST/molrep -f ../data/test.cif -m ../data/test_mod.pdb -mx ../data/test_mod
+ # --------------------------------
+ _NP 3
+ stop
++[[ $? ]] || exit 1
+ #
+ # =================================================================
+ #
+@@ -67,6 +70,7 @@ $MR_TEST/molrep -f ../data/test.cif -m ../data/test_mod.pdb -po out/ -ps scr/ -i
+ _NMON 2
+ _NP 3
+ stop
++[[ $? ]] || exit 1
+ #
+ # =================================================================
+ #
+@@ -85,6 +89,7 @@ _NPT 3
+ _NPTD 3
+ _DYAD D
+ stop
++[[ $? ]] || exit 1
+ #
+ # =================================================================
+ #
+@@ -103,6 +108,7 @@ _NP 3
+ _NPT 10
+ _NMR 3
+ stop
++[[ $? ]] || exit 1
+ #
+ # =================================================================
+ #
+@@ -118,6 +124,7 @@ _PRF Y
+ _compl 1.
+ _sim .2
+ stop
++[[ $? ]] || exit 1
+ #
+ # =================================================================
+ #
+@@ -136,6 +143,7 @@ _ph PH
+ _fom FOM
+ #
+ stop
++[[ $? ]] || exit 1
+ # =================================================================
+ #
+ # 9. use sequence
+@@ -145,6 +153,7 @@ stop
+ $MR_TEST/molrep -f ../data/s100.mtz -m ../data/monomer.pdb -s ../data/s100.seq -po out/ -ps scr/ -i <<stop
+ # --------------------------------
+ stop
++[[ $? ]] || exit 1
+ # =================================================================
+ #
+ # 10. Locked RF
+@@ -157,6 +166,7 @@ _lock y
+ _file_tsrf ../data/srf.tab
+ _nsrf 1
+ stop
++[[ $? ]] || exit 1
+ # =================================================================
+ #
+ # 11. Multi-monomer search using NCS, SELF = 'A' means to compute Self RF and
+@@ -169,6 +179,7 @@ $MR_TEST/molrep -f ../data/s100.mtz -m ../data/monomer.pdb -m2 ../data/monomer.p
+ _self a
+ _nsrf 1
+ stop
++[[ $? ]] || exit 1
+ # =================================================================
+ #
+ # 12. use pst
+@@ -179,6 +190,7 @@ $MR_TEST/molrep -f ../data/pst.mtz -m ../data/model_pst.pdb -po out/ -ps scr/ -i
+ # --------------------------------
+ #
+ stop
++[[ $? ]] || exit 1
+ # =================================================================
+ #
+ # 13. space group check
+@@ -189,7 +201,8 @@ $MR_TEST/molrep -f ../data/test.mtz -m ../data/test_mod.pdb -po out/ -ps scr/ -i
+ # --------------------------------
+ _sg all
+ #
+-stop
++s[[ $? ]] || exit 1
++top
+ # ==========================================================
+ #
+ # 14. Example for finding HA position by MR solution.
+@@ -206,6 +219,7 @@ _SIGFD SIGFD3
+ #
+ _FUN d
+ stop
++[[ $? ]] || exit 1
+ # ==========================================================
+ #
+ # 15. Example for HA search by multi-copy search
+@@ -225,6 +239,7 @@ _diff h
+ _dyad y
+ _nmon 4
+ stop
++[[ $? ]] || exit 1
+ # ==========================================================
+ #
+ # 16. Example HA for search by translation function
+@@ -242,6 +257,7 @@ _FUN t
+ _diff h
+ _nmon 4
+ stop
++[[ $? ]] || exit 1
+ # ==========================================================
+ #
+ # 17. Example for Self RF for Heavy Atom structure in derivative.
+@@ -258,4 +274,5 @@ _SIGFD SIGFD3
+ _FUN r
+ _diff h
+ stop
++[[ $? ]] || exit 1
+ # ==========================================================
diff --git a/sci-chemistry/molrep/molrep-11.0.00.ebuild b/sci-chemistry/molrep/molrep-11.0.00.ebuild
new file mode 100644
index 000000000000..8e0295c756b1
--- /dev/null
+++ b/sci-chemistry/molrep/molrep-11.0.00.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/molrep-11.0.00.ebuild,v 1.1 2010/06/15 10:51:43 jlec Exp $
+
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="molecular replacement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/molrep.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-libs/ccp4-libs-6.1.3
+ sci-libs/mmdb
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-respect-FLAGS.patch
+ epatch "${FILESDIR}"/${PV}-test.patch
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake clean || die
+ emake \
+ MR_FORT="$(tc-getFC) ${FFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ MR_LIBRARY="-L${EPREFIX}/usr/$(get_libdir) -lccp4f -lccp4c -lmmdb -lccif -llapack -lstdc++ -lm" \
+ || die
+}
+
+src_test() {
+ export MR_TEST="${S}/bin/"
+ cd "${S}"/molrep_check/work
+ mkdir out scr
+ cp ../*.bat .
+ bash em.bat || die
+ bash mr.bat || die
+}
+
+src_install() {
+ dobin bin/${PN} || die
+ dodoc readme doc/${PN}.rtf || die
+}