summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 06:43:37 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 06:43:37 +0000
commit5fb6e86869e9d9941d3c8da6d987a557da60cda7 (patch)
tree03be74f09903c62484ed069a5e6790fba2bf83f3 /sci-chemistry/mopac7
parentFix minor syntax errors. (diff)
downloadgentoo-2-5fb6e86869e9d9941d3c8da6d987a557da60cda7.tar.gz
gentoo-2-5fb6e86869e9d9941d3c8da6d987a557da60cda7.tar.bz2
gentoo-2-5fb6e86869e9d9941d3c8da6d987a557da60cda7.zip
Bump. Pull in newer libf2c so configure doesn't fail.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'sci-chemistry/mopac7')
-rw-r--r--sci-chemistry/mopac7/ChangeLog9
-rw-r--r--sci-chemistry/mopac7/mopac7-1.13.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/sci-chemistry/mopac7/ChangeLog b/sci-chemistry/mopac7/ChangeLog
index 6cc63280ba7b..1aa519e2bc49 100644
--- a/sci-chemistry/mopac7/ChangeLog
+++ b/sci-chemistry/mopac7/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/mopac7
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.14 2007/01/07 02:21:42 kugelfang Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/ChangeLog,v 1.15 2008/07/08 06:43:37 dberkholz Exp $
+
+*mopac7-1.13 (08 Jul 2008)
+
+ 08 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>; +mopac7-1.13.ebuild:
+ Bump. Pull in newer libf2c so configure doesn't fail.
07 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -mopac7-1.00-r1.ebuild,
-mopac7-1.10.ebuild:
diff --git a/sci-chemistry/mopac7/mopac7-1.13.ebuild b/sci-chemistry/mopac7/mopac7-1.13.ebuild
new file mode 100644
index 000000000000..e84f05521093
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.13.ebuild,v 1.1 2008/07/08 06:43:37 dberkholz Exp $
+
+WANT_AUTOMAKE="1.8"
+WANT_AUTOCONF="latest"
+
+inherit autotools
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=dev-libs/libf2c-20070912"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Install the executable
+ sed -i \
+ -e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
+ src/Makefile.am \
+ || die "sed failed: install mopac7"
+ # Install the script to run the executable
+ sed -i \
+ -e "s:EXTRA_DIST = run_mopac7:if HAVE_F2C\nbin_SCRIPTS = run_mopac7\nendif:g" \
+ Makefile.am \
+ || die "sed failed: install run_mopac7"
+
+ # Fix parallel build by adding internal dependency on libmopac7.la from
+ # executable
+ sed -i \
+ -e "s:mopac7_LDFLAGS = -lmopac7 -lf2c -lm:mopac7_LDFLAGS = -lf2c -lm:g" \
+ -e "s:\(mopac7_LDFLAGS.*\):\1\nmopac7_LDADD = libmopac7.la:g" \
+ src/Makefile.am \
+ || die "sed failed: fix dependencies"
+
+ eautoreconf
+}
+
+src_install() {
+ # A correct fix would have a run_mopac7.in with @bindir@ that gets
+ # replaced by configure, and run_mopac7 added to AC_OUTPUT in configure.ac
+ sed -i "s:./src/mopac7:mopac7:g" run_mopac7
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog
+}