summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-28 07:58:26 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-28 07:58:26 +0000
commit70d735235265c93aa8c0d11de2e2b37c08b8e1e5 (patch)
tree47d3e281362ef61e6c00f90e41c7018c369c06a8 /sci-chemistry/mosflm/files
parent[bump] dev-perl/extutils-pkgconfig-1.130.0 (diff)
downloadgentoo-2-70d735235265c93aa8c0d11de2e2b37c08b8e1e5.tar.gz
gentoo-2-70d735235265c93aa8c0d11de2e2b37c08b8e1e5.tar.bz2
gentoo-2-70d735235265c93aa8c0d11de2e2b37c08b8e1e5.zip
sci-chemistry/mosflm: Unbundle licbf and libjpeg, fix parallel build, Drop stable ppc keyword due to broken deps
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/mosflm/files')
-rw-r--r--sci-chemistry/mosflm/files/7.0.7-parallel.patch92
1 files changed, 92 insertions, 0 deletions
diff --git a/sci-chemistry/mosflm/files/7.0.7-parallel.patch b/sci-chemistry/mosflm/files/7.0.7-parallel.patch
new file mode 100644
index 000000000000..df0a8b63273a
--- /dev/null
+++ b/sci-chemistry/mosflm/files/7.0.7-parallel.patch
@@ -0,0 +1,92 @@
+ Makefile | 21 ++++++++++-----------
+ cbf/Makefile | 9 +++++++--
+ 2 files changed, 17 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 37f4c7e..51d4164 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,8 +22,8 @@ DPSLIBS = lib/DPSLIB.a
+ CBFLIBS = cbf/lib/libcbf.a
+ JPGLIBS = jpg/libjpeg.a
+
+-all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
+- cd mosflm ; make
++all: $(DPSLIBS)
++ $(MAKE) -C mosflm
+
+ ##########################################################################
+ # #
+@@ -47,22 +47,21 @@ dpslibs:
+
+ cbflibs:
+ rm -f `find ./cbf -name "*.a" -print`
+- cd cbf ; make all ; if [ -f $(RANLIB) ]; \
+- then $(RANLIB) lib/libcbf.a; fi
++ $(MAKE) -C cbf all
+
+ jpglibs:
+- cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; make libjpeg.a
++ cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; $(MAKE) libjpeg.a
+
+ ${DPSLIBS}:
+- make dpslibs
++ $(MAKE) dpslibs
+
+ ${CBFLIBS}:
+- make cbflibs
++ $(MAKE) cbflibs
+
+ ${JPGLIBS}:
+- make jpglibs
++ $(MAKE) jpglibs
+
+-libs: ${DPSLIBS} ${CBFLIBS} ${JPGLIBS}
++libs: ${DPSLIBS} ${CBFLIBS}
+ @echo "****************************************************************"
+ @echo " Making libraries for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+@@ -71,11 +70,11 @@ ipmosflm: libs
+ @echo "****************************************************************"
+ @echo " Making IPMOSFLM for system ${HOSTTYPE}"
+ @echo "****************************************************************"
+- cd mosflm ; make ipmosflm
++ $(MAKE) -C mosflm ipmosflm
+
+ force:
+ rm bin/ipmosflm
+- make ipmosflm
++ $(MAKE) ipmosflm
+
+ install:
+ @echo "the executable is in ${MOSHOME}/bin/ipmosflm"
+diff --git a/cbf/Makefile b/cbf/Makefile
+index e61497c..c3c94ac 100644
+--- a/cbf/Makefile
++++ b/cbf/Makefile
+@@ -362,6 +362,8 @@ HEADERS = $(INCLUDE)/cbf.h \
+ $(EXAMPLES)/img.h \
+ $(INCLUDE)/md5.h
+
++OBJ = $(subst .c,.o,$(SOURCE))
++
+ #
+ # Compile the library and examples
+ #
+@@ -379,11 +381,14 @@ $(INSTALLDIR):
+ $(LIB):
+ mkdir $(LIB)
+
++
++.c.o: $(SOURCE) $(HEADERS)
++ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
++
+ #
+ # CBF library
+ #
+-$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
+- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
++$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
+ $(AR) cr $@ *.o
+ rm *.o
+ if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi