summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-06 11:39:53 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-06 11:39:53 +0000
commitd9ba341f9d77c800ab33eebf753f99d8c9cf4102 (patch)
tree6f3acedbb9694bb964de8d2374db3c30139f26e6 /sci-chemistry/oasis
parentStable on amd64 wrt bug #303247 (diff)
downloadgentoo-2-d9ba341f9d77c800ab33eebf753f99d8c9cf4102.tar.gz
gentoo-2-d9ba341f9d77c800ab33eebf753f99d8c9cf4102.tar.bz2
gentoo-2-d9ba341f9d77c800ab33eebf753f99d8c9cf4102.zip
Splitted oasis from ccp4
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/oasis')
-rw-r--r--sci-chemistry/oasis/ChangeLog10
-rw-r--r--sci-chemistry/oasis/files/4.0-makefile.patch15
-rw-r--r--sci-chemistry/oasis/metadata.xml11
-rw-r--r--sci-chemistry/oasis/oasis-4.0.ebuild66
4 files changed, 102 insertions, 0 deletions
diff --git a/sci-chemistry/oasis/ChangeLog b/sci-chemistry/oasis/ChangeLog
new file mode 100644
index 000000000000..8843b4c37fb1
--- /dev/null
+++ b/sci-chemistry/oasis/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/oasis
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/oasis/ChangeLog,v 1.1 2010/02/06 11:39:53 jlec Exp $
+
+*oasis-4.0 (06 Feb 2010)
+
+ 06 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/4.0-makefile.patch, +oasis-4.0.ebuild, +metadata.xml:
+ updated version for oasis from ccp4
+
diff --git a/sci-chemistry/oasis/files/4.0-makefile.patch b/sci-chemistry/oasis/files/4.0-makefile.patch
new file mode 100644
index 000000000000..f27a350a1fd2
--- /dev/null
+++ b/sci-chemistry/oasis/files/4.0-makefile.patch
@@ -0,0 +1,15 @@
+diff --git a/src/Makefile b/src/Makefile
+index 1e9128f..eb9edaf 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -20,8 +20,8 @@ IRIX:
+ @ ${F77} -O2 -mips3 -nocpp -OPT:Olimit=1500 -w -rpath ${CCP4_LIB} -o oasis4-0 oasis4-0.f -L${CCP4_LIB}/src -lccp4f -lccp4c -lmmdb -lC -lm -L/usr/lib32 -lblas
+ @ ${F77} -O2 -mips3 -nocpp -OPT:Olimit=1500 -w -rpath ${CCP4_LIB} -o fnp2fp fnp2fp.f -L${CCP4_LIB}/src -lccp4f -lccp4c -lmmdb -lC -lm -L/usr/lib32 -lblas
+ Linux:
+- @ ${F77} -O -w -fno-second-underscore -fno-globals -fno-automatic -o oasis4-0 oasis4-0.f -L${CCP4_LIB} -lccp4f -lccp4c -lmmdb -lstdc++ -lg2c -lm -L${CCP4_LIB}
+- @ ${F77} -O -w -fno-second-underscore -fno-globals -fno-automatic -o fnp2fp fnp2fp.f -L${CCP4_LIB} -lccp4f -lccp4c -lmmdb -lstdc++ -lg2c -lm -L${CCP4_LIB}
++ ${F77} $(CFLAGS) $(LDFLAGS) -o oasis oasis4-0.f -L${CCP4_LIB} -lccp4f -lccp4c -lmmdb -lstdc++ -lm -L${CCP4_LIB}
++ ${F77} $(CFLAGS) $(LDFLAGS) -o fnp2fp fnp2fp.f -L${CCP4_LIB} -lccp4f -lccp4c -lmmdb -lstdc++ -lm -L${CCP4_LIB}
+ Darwin:
+ @ ${F77} -O2 -fno-second-underscore -o fnp2fp fnp2fp.f -L${CCP4_LIB} -lccp4f -lccp4c -lmmdb -lstdc++ -lgcc_s.10.5 -lSystem -lm
+ @ ${F77} -O2 -fno-second-underscore -o oasis4-0 oasis4-0.f -L${CCP4_LIB} -lccp4f -lccp4c -lmmdb -lstdc++ -lgcc_s.10.5 -lSystem -lm
diff --git a/sci-chemistry/oasis/metadata.xml b/sci-chemistry/oasis/metadata.xml
new file mode 100644
index 000000000000..dc88510361c1
--- /dev/null
+++ b/sci-chemistry/oasis/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name='minimal'>Restricts functionality on free software</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-chemistry/oasis/oasis-4.0.ebuild b/sci-chemistry/oasis/oasis-4.0.ebuild
new file mode 100644
index 000000000000..12e33174f330
--- /dev/null
+++ b/sci-chemistry/oasis/oasis-4.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/oasis/oasis-4.0.ebuild,v 1.1 2010/02/06 11:39:53 jlec Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${PN}${PV}_Linux"
+
+DESCRIPTION="A direct-method program for SAD/SIR phasing"
+HOMEPAGE="http://cryst.iphy.ac.cn/Project/protein/protein-I.html"
+SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/${MY_P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="ccp4 oasis"
+IUSE="examples +minimal"
+
+RDEPEND="
+ sci-chemistry/ccp4-apps
+ sci-chemistry/pymol
+ sci-libs/ccp4-libs
+ sci-libs/mmdb
+ sci-visualization/gnuplot
+ !minimal? (
+ sci-chemistry/solve-resolve-bin
+ sci-chemistry/arp-warp-bin )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ rm bin/{fnp2fp,gnuplot,oasis4-0,seq} || die
+ epatch "${FILESDIR}"/${PV}-makefile.patch
+}
+
+src_compile() {
+ emake \
+ -C src \
+ F77="$(tc-getFC)" \
+ CCP4_LIB="${EPREFIX}/usr/$(get_libdir)" \
+ Linux || die
+}
+
+src_install() {
+ dobin src/{${PN},fnp2fp} || die
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/*.*sh || die
+
+ insinto /usr/$(get_libdir)/${PN}/html
+ doins bin/html/* || die
+ fperms 755 /usr/$(get_libdir)/${PN}/html/*.{csh,awk} || die
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r examples || die
+ fi
+
+ cat >> "${T}"/25oasis <<- EOF
+ oasisbin="${EPREFIX}/usr/$(get_libdir)/${PN}"
+ EOF
+
+ doenvd "${T}"/25oasis
+}