summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 16:13:55 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 16:13:55 +0000
commit5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967 (patch)
treed9e74671b0c6ead03b1e182fea3c830da2fcd2be /sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild
parentFix build with GCC-4.5 wrt bug 321209. Thanks Diego for reporting. (diff)
downloadgentoo-2-5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967.tar.gz
gentoo-2-5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967.tar.bz2
gentoo-2-5bc9d2a692e86e47830e4e7c4e6e3c2d2271f967.zip
Fix for recent fortran compilers, #272577
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild')
-rw-r--r--sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild b/sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..eb3969da1086
--- /dev/null
+++ b/sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ortep3/ortep3-1.0.3-r1.ebuild,v 1.1 2010/06/24 16:13:55 jlec Exp $
+
+inherit fortran
+
+FORTRAN="gfortran ifc"
+
+DESCRIPTION="Thermal ellipsoid plot program for crystal structure illustrations"
+HOMEPAGE="http://www.ornl.gov/sci/ortep/"
+SRC_URI="ftp://ftp.ornl.gov/pub/ortep/src/ortep.f"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/pgplot
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${DISTDIR}/${A} ${S}
+}
+
+src_compile() {
+ COMMAND="${FORTRANC} ${FFLAGS:- -O2} ${LDFLAGS} -o ${PN} ortep.f -lpgplot -lX11"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation failed"
+}
+
+src_install() {
+ dobin ${PN} || die
+}