summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-26 08:46:21 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-26 08:46:21 +0000
commitd999196677910753f31d67ed5fca2e2a0ce1c7a5 (patch)
tree3d36d5c4b82755bf900e3d63bedc2802f21e2357 /sci-chemistry/p3d
parentStraight out QA issues (diff)
downloadgentoo-2-d999196677910753f31d67ed5fca2e2a0ce1c7a5.tar.gz
gentoo-2-d999196677910753f31d67ed5fca2e2a0ce1c7a5.tar.bz2
gentoo-2-d999196677910753f31d67ed5fca2e2a0ce1c7a5.zip
migrate from 'git' to 'git-2'
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/p3d')
-rw-r--r--sci-chemistry/p3d/ChangeLog6
-rw-r--r--sci-chemistry/p3d/metadata.xml10
-rw-r--r--sci-chemistry/p3d/p3d-0.4.3.ebuild8
-rw-r--r--sci-chemistry/p3d/p3d-9999.ebuild13
4 files changed, 19 insertions, 18 deletions
diff --git a/sci-chemistry/p3d/ChangeLog b/sci-chemistry/p3d/ChangeLog
index 484c1275359a..8e6cccc14e56 100644
--- a/sci-chemistry/p3d/ChangeLog
+++ b/sci-chemistry/p3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/p3d
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/ChangeLog,v 1.3 2011/03/11 12:18:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/ChangeLog,v 1.4 2011/06/26 08:46:21 jlec Exp $
+
+ 26 Jun 2011; Justin Lecher <jlec@gentoo.org> p3d-0.4.3.ebuild,
+ p3d-9999.ebuild, metadata.xml:
+ migrate from 'git' to 'git-2'
*p3d-0.4.3 (11 Mar 2011)
diff --git a/sci-chemistry/p3d/metadata.xml b/sci-chemistry/p3d/metadata.xml
index 9a0f5eff3224..bd602bd0e68a 100644
--- a/sci-chemistry/p3d/metadata.xml
+++ b/sci-chemistry/p3d/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<longdescription>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
p3d was developed in order to offer a Python module that is powerful and fast,
yet intuitive to use. The simplicity of p3d is due to the usage of object
oriented programming (i.e. atoms are treated as vectors), the implementation
diff --git a/sci-chemistry/p3d/p3d-0.4.3.ebuild b/sci-chemistry/p3d/p3d-0.4.3.ebuild
index 7b27d43ea9a5..967a1354871a 100644
--- a/sci-chemistry/p3d/p3d-0.4.3.ebuild
+++ b/sci-chemistry/p3d/p3d-0.4.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/p3d-0.4.3.ebuild,v 1.1 2011/03/11 12:18:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/p3d-0.4.3.ebuild,v 1.2 2011/06/26 08:46:21 jlec Exp $
-EAPI="3"
+EAPI=3
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
@@ -13,7 +13,7 @@ MY_P="${PN}-$(replace_version_separator 3 -)"
GITHUB_ID="gb8b9a75"
DESCRIPTION="Python module for structural bioinformatics"
-HOMEPAGE="http://p3d.fufezan.net"
+HOMEPAGE="http://p3d.fufezan.net/"
SRC_URI="https://nodeload.github.com/fu/${PN}/tarball/${PV} -> ${P}.tar.gz"
SLOT="0"
@@ -30,6 +30,6 @@ src_install() {
distutils_src_install
if use examples; then
insinto /usr/share/${PN}
- doins -r pdbs exampleScripts
+ doins -r pdbs exampleScripts || die
fi
}
diff --git a/sci-chemistry/p3d/p3d-9999.ebuild b/sci-chemistry/p3d/p3d-9999.ebuild
index 6675a9d46995..9764df7ce4d0 100644
--- a/sci-chemistry/p3d/p3d-9999.ebuild
+++ b/sci-chemistry/p3d/p3d-9999.ebuild
@@ -1,19 +1,16 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/p3d-9999.ebuild,v 1.1 2011/03/09 10:34:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/p3d/p3d-9999.ebuild,v 1.2 2011/06/26 08:46:21 jlec Exp $
-EAPI="3"
+EAPI=3
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-inherit git distutils versionator
-
-MY_P="${PN}-$(replace_version_separator 3 -)"
-GITHUB_ID="gb8b9a75"
+inherit git-2 distutils versionator
DESCRIPTION="Python module for structural bioinformatics"
-HOMEPAGE="http://p3d.fufezan.net"
+HOMEPAGE="http://p3d.fufezan.net/"
SRC_URI=""
EGIT_REPO_URI="git://github.com/fu/p3d.git"
@@ -28,6 +25,6 @@ src_install() {
distutils_src_install
if use examples; then
insinto /usr/share/${PN}
- doins -r pdbs exampleScripts
+ doins -r pdbs exampleScripts || die
fi
}