summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-04 09:35:20 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-04 09:35:20 +0000
commitd27c8f03e88fcf185bc6348e537ba7f841938837 (patch)
tree1bee6878925895fa06cba693c07926a6bd7bd624 /sci-chemistry/pdb2pqr
parentVersion bumped, bug #341911. (diff)
downloadgentoo-2-d27c8f03e88fcf185bc6348e537ba7f841938837.tar.gz
gentoo-2-d27c8f03e88fcf185bc6348e537ba7f841938837.tar.bz2
gentoo-2-d27c8f03e88fcf185bc6348e537ba7f841938837.zip
Added support for psb2pka
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pdb2pqr')
-rw-r--r--sci-chemistry/pdb2pqr/ChangeLog8
-rw-r--r--sci-chemistry/pdb2pqr/metadata.xml3
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild163
3 files changed, 172 insertions, 2 deletions
diff --git a/sci-chemistry/pdb2pqr/ChangeLog b/sci-chemistry/pdb2pqr/ChangeLog
index 07f912ac9f9e..41728a45d3ae 100644
--- a/sci-chemistry/pdb2pqr/ChangeLog
+++ b/sci-chemistry/pdb2pqr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pdb2pqr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.28 2010/10/15 18:56:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.29 2010/11/04 09:35:19 jlec Exp $
+
+*pdb2pqr-1.7.0-r1 (04 Nov 2010)
+
+ 04 Nov 2010; Justin Lecher <jlec@gentoo.org> +pdb2pqr-1.7.0-r1.ebuild,
+ metadata.xml:
+ Added support for psb2pka
15 Oct 2010; Brent Baude <ranger@gentoo.org> pdb2pqr-1.5.0-r2.ebuild:
stable ppc, bug 321897
diff --git a/sci-chemistry/pdb2pqr/metadata.xml b/sci-chemistry/pdb2pqr/metadata.xml
index 03e1d8b50494..a99cdb01d6af 100644
--- a/sci-chemistry/pdb2pqr/metadata.xml
+++ b/sci-chemistry/pdb2pqr/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>sci-chemistry</herd>
<use>
- <flag name='opal'>Add web interface via opal</flag>
+ <flag name='opal'>Add web interface via opal</flag>
+ <flag name='pdb2pka'>Install experimental pdb2pka interface</flag>
</use>
</pkgmetadata>
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..26010325ccd9
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r1.ebuild,v 1.1 2010/11/04 09:35:20 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit eutils fortran multilib flag-o-matic distutils python versionator toolchain-funcs
+
+FORTRAN="g77 gfortran"
+
+MY_PV=$(get_version_component_range 1-2)
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
+LICENSE="BSD"
+HOMEPAGE="http://pdb2pqr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples opal +pdb2pka"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/numpy
+ sci-chemistry/openbabel
+ opal? ( dev-python/zsi )
+ pdb2pka? ( sci-chemistry/apbs[python,-mpi] )"
+DEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if [[ -z ${MAXATOMS} ]]; then
+ einfo "If you like to have support for more then 10000 atoms,"
+ einfo "export MAXATOMS=\"your value\""
+ else
+ einfo "Allow usage of ${MAXATOMS} during calculations"
+ fi
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4.0-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-1.4.0-automagic.patch
+ epatch "${FILESDIR}"/${PV}-install.patch
+ sed '50,200s:CWD:DESTDIR:g' -i Makefile.am \
+ || die "Failed to fix Makefile.am"
+ python_src_prepare
+ preparation() {
+ eautoreconf
+ }
+ python_execute_function -s preparation
+ tc-export CC
+}
+
+src_configure() {
+ # we need to compile the *.so as pic
+ append-flags -fPIC
+ FFLAGS="${FFLAGS} -fPIC"
+
+ configuration() {
+ # Avoid automagic to numeric
+ NUMPY="${EPREFIX}/$(python_get_sitedir)" \
+ F77="${FORTRANC}" \
+ econf \
+ --enable-propka \
+ --with-max-atoms=${MAXATOMS:-10000} \
+ $(use_enable pdb2pka) \
+ $(use_with opal) || \
+ die "econf failed"
+ }
+ python_execute_function -s configuration
+}
+
+src_test() {
+ testing() {
+ emake -j1 test \
+ || die "tests failed"
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ installation() {
+ dodir $(python_get_sitedir)/${PN}
+ emake -j1 DESTDIR="${ED}$(python_get_sitedir)/${PN}" \
+ PREFIX="" install || die "install failed"
+
+ INPATH="$(python_get_sitedir)/${PN}"
+
+ # generate pdb2pqr wrapper
+ cat >> "${T}"/${PN}-$(python_get_version) <<-EOF
+ #!/bin/sh
+ $(PYTHON) ${EPREFIX}${INPATH}/${PN}.py \$*
+ EOF
+
+ cat >> "${T}"/pdb2pka-$(python_get_version) <<-EOF
+ #!/bin/sh
+ $(PYTHON) ${EPREFIX}${INPATH}/pdb2pka/pka.py \$*
+ EOF
+
+ dobin "${T}"/{${PN},pdb2pka}-$(python_get_version) || die "Failed to install pdb2pqr wrapper."
+
+ insinto "${INPATH}"
+ doins __init__.py || \
+ die "Setting up the pdb2pqr site-package failed."
+
+ exeinto "${INPATH}"
+ doexe ${PN}.py || die "Installing pdb2pqr failed."
+
+ insinto "${INPATH}"/dat
+ doins dat/* || die "Installing data failed."
+
+ exeinto "${INPATH}"/extensions
+ doexe extensions/* || \
+ die "Failed to install extensions."
+
+ insinto "${INPATH}"/src
+ doins src/*.py || die "Installing of python scripts failed."
+
+ exeinto "${INPATH}"/propka
+ doexe propka/_propkalib.so || \
+ die "Failed to install propka."
+
+ insinto "${INPATH}"/propka
+ doins propka/propkalib.py propka/__init__.py || \
+ die "Failed to install propka."
+
+ insinto "${INPATH}"/pdb2pka
+ doins pdb2pka/*.{py,so,DAT,h} || \
+ die "Failed to install pdb2pka."
+
+ dosym ../../apbs/_apbslib.so "${INPATH}"/pdb2pka/_apbslib.so
+ dosym ../../apbs/apbslib.py "${INPATH}"/pdb2pka/apbslib.py
+ dosym ../../apbs/apbslib.pyc "${INPATH}"/pdb2pka/apbslib.pyc
+ dosym ../../apbs/apbslib.pyo "${INPATH}"/pdb2pka/apbslib.pyo
+ }
+ python_execute_function -s installation
+
+ dosym ${PN}-$(python_get_version -f) /usr/bin/${PN}
+ dosym pdb2pka-$(python_get_version -f) /usr/bin/pdb2pka
+
+ if use doc; then
+ cd doc
+ sh genpydoc.sh \
+ || die "genpydoc failed"
+ dohtml -r *.html images pydoc \
+ || die "failed to install html docs"
+ cd -
+ fi
+
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r examples || die "Failed to install examples."
+ fi
+
+ dodoc ChangeLog NEWS README AUTHORS || \
+ die "Failed to install docs"
+}