summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-16 05:32:46 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-16 05:32:46 +0000
commitcdf5e4f106cb17b3c0fd00c9aa0ac0986bf10074 (patch)
tree70d3942921abc98df27806eaf3a4e6b7c9415c89 /sci-chemistry/platon/platon-20051215.ebuild
parentVersion bump (bug #110431). (diff)
downloadgentoo-2-cdf5e4f106cb17b3c0fd00c9aa0ac0986bf10074.tar.gz
gentoo-2-cdf5e4f106cb17b3c0fd00c9aa0ac0986bf10074.tar.bz2
gentoo-2-cdf5e4f106cb17b3c0fd00c9aa0ac0986bf10074.zip
Another crystallography package. This one considers itself a versatile, SHELX-97 compatible, multipurpose tool.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-chemistry/platon/platon-20051215.ebuild')
-rw-r--r--sci-chemistry/platon/platon-20051215.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/platon/platon-20051215.ebuild b/sci-chemistry/platon/platon-20051215.ebuild
new file mode 100644
index 000000000000..141d2713d6c8
--- /dev/null
+++ b/sci-chemistry/platon/platon-20051215.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20051215.ebuild,v 1.1 2005/12/16 05:32:46 spyderous Exp $
+
+inherit fortran
+
+FORTRAN="g77"
+DESCRIPTION="Versatile, SHELX-97 compatible, multipurpose crystallographic tool"
+HOMEPAGE="http://www.cryst.chem.uu.nl/platon/"
+SRC_URI="${P}.tar.gz"
+RESTRICT="fetch"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Download ${A/-${PV}} from ${HOMEPAGE},"
+ einfo "rename it to ${A} and place it"
+ einfo "in ${DISTDIR}."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gunzip platon.f.Z xdrvr.c.gz
+}
+
+src_compile() {
+ COMMAND="${FORTRANC} -o platon ${FFLAGS:- -O2} platon.f xdrvr.c -lX11"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation failed"
+}
+
+src_install() {
+ dobin platon
+
+ dosym platon /usr/bin/pluton
+ dosym platon /usr/bin/s
+ dosym platon /usr/bin/cifchk
+ dosym platon /usr/bin/helena
+ dosym platon /usr/bin/stidy
+
+ insinto /usr/lib/platon
+ doins check.def
+
+ echo "CHECKDEF=\"/usr/lib/platon/check.def\"" > ${T}/env.d
+ newenvd ${T}/env.d 50platon
+
+ dodoc README.* VALIDATION.DOC
+}