summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-07 07:17:30 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-07 07:17:30 +0000
commit1074f65058d126d449810745654fed9befa741b7 (patch)
treef592617fbcd57f089e4fa96b6db85716712e7918 /sci-chemistry/psi
parentRemove old versions. (diff)
downloadgentoo-2-1074f65058d126d449810745654fed9befa741b7.tar.gz
gentoo-2-1074f65058d126d449810745654fed9befa741b7.tar.bz2
gentoo-2-1074f65058d126d449810745654fed9befa741b7.zip
(#202980) Bump. Add a gcc-4.3 patch, pull in the latest libint, keyword ~amd64, add src_test() to call the test suite.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'sci-chemistry/psi')
-rw-r--r--sci-chemistry/psi/ChangeLog11
-rw-r--r--sci-chemistry/psi/files/3.3.0-gcc-4.3.patch14
-rw-r--r--sci-chemistry/psi/psi-3.3.0.ebuild55
3 files changed, 78 insertions, 2 deletions
diff --git a/sci-chemistry/psi/ChangeLog b/sci-chemistry/psi/ChangeLog
index 99f3f5bf1ee1..fca6decd5215 100644
--- a/sci-chemistry/psi/ChangeLog
+++ b/sci-chemistry/psi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/psi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/psi/ChangeLog,v 1.6 2007/02/22 01:28:40 jokey Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/psi/ChangeLog,v 1.7 2008/07/07 07:17:30 dberkholz Exp $
+
+*psi-3.3.0 (07 Jul 2008)
+
+ 07 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/3.3.0-gcc-4.3.patch, +psi-3.3.0.ebuild:
+ (#202980) Bump. Add a gcc-4.3 patch, pull in the latest libint, keyword
+ ~amd64, add src_test() to call the test suite.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-chemistry/psi/files/3.3.0-gcc-4.3.patch b/sci-chemistry/psi/files/3.3.0-gcc-4.3.patch
new file mode 100644
index 000000000000..1eed612978a1
--- /dev/null
+++ b/sci-chemistry/psi/files/3.3.0-gcc-4.3.patch
@@ -0,0 +1,14 @@
+--- psi3.orig/src/bin/intder/params.cc 2008-07-06 23:46:56.000000000 -0700
++++ psi3/src/bin/intder/params.cc 2008-07-06 23:48:41.000000000 -0700
+@@ -1,3 +1,4 @@
++#include <cstring>
+ #include "params.h"
+ #include "displacements.h"
+ #include "intco.h"
+--- psi3.orig/src/bin/intder/read_geom.cc 2008-07-06 23:46:56.000000000 -0700
++++ psi3/src/bin/intder/read_geom.cc 2008-07-06 23:48:56.000000000 -0700
+@@ -1,3 +1,4 @@
++#include <cstring>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include "displacements.h"
diff --git a/sci-chemistry/psi/psi-3.3.0.ebuild b/sci-chemistry/psi/psi-3.3.0.ebuild
new file mode 100644
index 000000000000..4cebec936968
--- /dev/null
+++ b/sci-chemistry/psi/psi-3.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/psi/psi-3.3.0.ebuild,v 1.1 2008/07/07 07:17:30 dberkholz Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Suite of ab initio quantum chemistry programs to compute various molecular properties"
+HOMEPAGE="http://www.psicode.org/"
+SRC_URI="mirror://sourceforge/psicode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/blas
+ virtual/lapack
+ >=sci-libs/libint-1.1.4"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+S="${WORKDIR}/${PN}${PV:0:1}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/dont-build-libint.patch
+ epatch "${FILESDIR}"/use-external-libint.patch
+ epatch "${FILESDIR}"/${PV}-gcc-4.3.patch
+ eautoreconf
+}
+
+src_compile() {
+ # This variable gets set sometimes to /usr/lib/src and breaks stuff
+ unset CLIBS
+
+ econf \
+ --with-opt="${CFLAGS}" \
+ --datadir=/usr/share/${PN} \
+ || die "configure failed"
+ emake \
+ SCRATCH="${WORKDIR}/libint" \
+ || die "make failed"
+}
+
+src_test() {
+ emake tests || die
+}
+
+src_install() {
+ einstall \
+ datadir=${D}/usr/share/${PN} \
+ docdir=${D}/usr/share/doc/${PF} \
+ || die "install failed"
+}