summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-01 21:40:04 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-01 21:40:04 +0000
commitfea13f8013dcaaacf7dede103ffb120135043174 (patch)
treee2d02253b58f35246e2f03575017ede73e871140 /sci-chemistry/pymol-apbs-plugin
parentstable x86, bug 302977 (diff)
downloadgentoo-2-fea13f8013dcaaacf7dede103ffb120135043174.tar.gz
gentoo-2-fea13f8013dcaaacf7dede103ffb120135043174.tar.bz2
gentoo-2-fea13f8013dcaaacf7dede103ffb120135043174.zip
Seperated ebuild for pymol apbs plugin
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol-apbs-plugin')
-rw-r--r--sci-chemistry/pymol-apbs-plugin/ChangeLog10
-rw-r--r--sci-chemistry/pymol-apbs-plugin/metadata.xml8
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild48
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-apbs-plugin/ChangeLog b/sci-chemistry/pymol-apbs-plugin/ChangeLog
new file mode 100644
index 000000000000..3cc02c017335
--- /dev/null
+++ b/sci-chemistry/pymol-apbs-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/pymol-apbs-plugin
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/ChangeLog,v 1.1 2010/02/01 21:40:04 jlec Exp $
+
+*pymol-apbs-plugin-0_p11 (01 Feb 2010)
+
+ 01 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +pymol-apbs-plugin-0_p11.ebuild, +metadata.xml:
+ Seperated ebuild for pymol apbs plugin
+
diff --git a/sci-chemistry/pymol-apbs-plugin/metadata.xml b/sci-chemistry/pymol-apbs-plugin/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-chemistry/pymol-apbs-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild
new file mode 100644
index 000000000000..3df525ec13ba
--- /dev/null
+++ b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild,v 1.1 2010/02/01 21:40:04 jlec Exp $
+
+EAPI="2"
+
+inherit python
+
+MY_PV="${PV##*_p}"
+
+DESCRIPTION="APBS plugin for pymol"
+HOMEPAGE="http://sourceforge.net/projects/pymolapbsplugin/"
+SRC_URI="http://pymolapbsplugin.svn.sourceforge.net/viewvc/pymolapbsplugin/trunk/src/apbsplugin.py?revision=${MY_PV} -> ${P}.py"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="pymol"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ !<sci-chemistry/pymol-1.2.2-r1"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${P}.py "${WORKDIR}"/
+}
+
+src_install() {
+ sed \
+ -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/\":g" \
+ -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
+ -i ${P}.py
+
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ newins ${P}.py apbs_tools.py || die
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
+}