summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-13 22:09:19 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-13 22:09:19 +0000
commit4c6229bd50d3b3e42088c423dda51a3c894f7c5c (patch)
tree112dc6a27e93d9ce4a2dd09069ca83fe670017ee /sci-chemistry/pymol/files
parentarm stable, bug #401513 (diff)
downloadgentoo-2-4c6229bd50d3b3e42088c423dda51a3c894f7c5c.tar.gz
gentoo-2-4c6229bd50d3b3e42088c423dda51a3c894f7c5c.tar.bz2
gentoo-2-4c6229bd50d3b3e42088c423dda51a3c894f7c5c.zip
Version Bump
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol/files')
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.1-data-path.patch147
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.1-flags.patch19
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.1-nosplash.patch15
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.1-prefix.patch43
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.1-setup.py.patch39
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.1-vmd.patch36
-rw-r--r--sci-chemistry/pymol/files/pymol-1.5.0.1-web.patch19
7 files changed, 318 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.1-data-path.patch b/sci-chemistry/pymol/files/pymol-1.5.0.1-data-path.patch
new file mode 100644
index 000000000000..e865bfd04174
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.1-data-path.patch
@@ -0,0 +1,147 @@
+ layer0/ShaderMgr.c | 16 ++++++++--------
+ layer1/Setting.c | 2 +-
+ modules/chempy/__init__.py | 2 +-
+ modules/chempy/tinker/__init__.py | 2 +-
+ modules/pymol/commanding.py | 6 +++---
+ modules/pymol/importing.py | 2 +-
+ modules/pymol/wizard/mutagenesis.py | 4 ++--
+ 7 files changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/layer0/ShaderMgr.c b/layer0/ShaderMgr.c
+index cc760ae..364277f 100644
+--- a/layer0/ShaderMgr.c
++++ b/layer0/ShaderMgr.c
+@@ -385,7 +385,7 @@ int CShaderMgr_ShadersPresent(CShaderMgr * I)
+ char * CShaderMgr_ReadShaderFromDisk(PyMOLGlobals * G, const char * fileName) {
+ FILE* f;
+ long size;
+- char* buffer = NULL, *p, *pymol_path, *shader_path, *fullFile;
++ char* buffer = NULL, *p, *pymol_data, *shader_path, *fullFile;
+ size_t res;
+
+ PRINTFB(G, FB_ShaderMgr, FB_Debugging)
+@@ -398,16 +398,16 @@ char * CShaderMgr_ReadShaderFromDisk(PyMOLGlobals * G, const char * fileName) {
+ return NULL;
+ }
+
+- pymol_path = getenv("PYMOL_PATH");
+- if (!pymol_path){
++ pymol_data = getenv("PYMOL_DATA");
++ if (!pymol_data){
+ PRINTFB(G, FB_ShaderMgr, FB_Warnings)
+- " PyMOLShader_NewFromFile-Warning: PYMOL_PATH not set, cannot read shader config files from disk\n" ENDFB(G);
++ " PyMOLShader_NewFromFile-Warning: PYMOL_DATA not set, cannot read shader config files from disk\n" ENDFB(G);
+ return NULL;
+ }
+ /* make this a setting */
+- shader_path = "/data/shaders/";
+- fullFile = malloc( sizeof(char) * (strlen(pymol_path)+strlen(shader_path)+strlen(fileName)+1));
+- fullFile = strcpy(fullFile, pymol_path);
++ shader_path = "/shaders/";
++ fullFile = malloc( sizeof(char) * (strlen(pymol_data)+strlen(shader_path)+strlen(fileName)+1));
++ fullFile = strcpy(fullFile, pymol_data);
+ fullFile = strcat(fullFile, shader_path);
+ fullFile = strcat(fullFile, fileName);
+
+@@ -416,7 +416,7 @@ char * CShaderMgr_ReadShaderFromDisk(PyMOLGlobals * G, const char * fileName) {
+
+ if (!f) {
+ PRINTFB(G, FB_ShaderMgr, FB_Errors)
+- " PyMOLShader_NewFromFile-Error: Unable to open file '%s' PYMOL_PATH='%s'\n", fullFile, pymol_path ENDFB(G);
++ " PyMOLShader_NewFromFile-Error: Unable to open file '%s' PYMOL_DATA='%s'\n", fullFile, pymol_data ENDFB(G);
+ return NULL;
+ } else {
+ PRINTFB(G, FB_ShaderMgr, FB_Blather)
+diff --git a/layer1/Setting.c b/layer1/Setting.c
+index c2b8bbb..4c6fdb7 100644
+--- a/layer1/Setting.c
++++ b/layer1/Setting.c
+@@ -4375,7 +4375,7 @@ void SettingInitGlobal(PyMOLGlobals * G, int alloc, int reset_gui, int use_defau
+ set_b(I, cSetting_line_use_shader, 1);
+ set_b(I, cSetting_sphere_use_shader, 1);
+ set_b(I, cSetting_use_shaders, 0);
+- set_s(I, cSetting_shader_path, "data/shaders");
++ set_s(I, cSetting_shader_path, "shaders");
+ set_i(I, cSetting_volume_bit_depth, 8);
+ set_color(I, cSetting_volume_color, "-1");
+ set_f(I, cSetting_volume_layers, 256);
+diff --git a/modules/chempy/__init__.py b/modules/chempy/__init__.py
+index 23dbe45..795a223 100644
+--- a/modules/chempy/__init__.py
++++ b/modules/chempy/__init__.py
+@@ -235,7 +235,7 @@ if os.environ.has_key('CHEMPY_DATA'): #
+ elif os.environ.has_key('PYMOL_DATA'):
+ path = os.environ['PYMOL_DATA'] + '/chempy/'
+ elif os.environ.has_key('PYMOL_PATH'):
+- path = os.environ['PYMOL_PATH'] + '/data/chempy/'
++ path = os.environ['PYMOL_PATH'] + '/chempy/'
+ elif os.environ.has_key('FREEMOL_MODULES'):
+ path = os.environ['FREEMOL_MODULES'] + '/chempy/'
+ else:
+diff --git a/modules/chempy/tinker/__init__.py b/modules/chempy/tinker/__init__.py
+index a2d8eb1..1e48f81 100644
+--- a/modules/chempy/tinker/__init__.py
++++ b/modules/chempy/tinker/__init__.py
+@@ -147,7 +147,7 @@ else:
+
+ if os.environ.has_key('PYMOL_PATH'):
+ pymol_path = os.environ['PYMOL_PATH']
+- test_path = pymol_path + '/data/chempy/tinker/'
++ test_path = pymol_path + '/chempy/tinker/'
+ if os.path.exists(test_path):
+ params_path = test_path
+
+diff --git a/modules/pymol/commanding.py b/modules/pymol/commanding.py
+index 5a202d0..5cb27a6 100644
+--- a/modules/pymol/commanding.py
++++ b/modules/pymol/commanding.py
+@@ -219,11 +219,11 @@ USAGE
+ _self.unlock(0,_self)
+ r = DEFAULT_SUCCESS
+ if show_splash==1: # generic / open-source
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/splash.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/splash.png")
+ elif show_splash==2: # evaluation builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/epymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/epymol.png")
+ else: # incentive builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/ipymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/ipymol.png")
+ if os.path.exists(png_path):
+ _self.do("_ cmd.load_png('%s',0,quiet=1)"%png_path)
+ else:
+diff --git a/modules/pymol/importing.py b/modules/pymol/importing.py
+index 457ace7..7cc2953 100644
+--- a/modules/pymol/importing.py
++++ b/modules/pymol/importing.py
+@@ -191,7 +191,7 @@ SEE ALSO
+ '''
+ r = DEFAULT_ERROR
+
+- tables = { 'cmyk' : "$PYMOL_PATH/data/pymol/cmyk.png",
++ tables = { 'cmyk' : "$PYMOL_DATA/pymol/cmyk.png",
+ 'pymol' : 'pymol',
+ 'rgb' : 'rgb',
+ 'greyscale': 'greyscale' }
+diff --git a/modules/pymol/wizard/mutagenesis.py b/modules/pymol/wizard/mutagenesis.py
+index 8a5250d..6c1b26c 100644
+--- a/modules/pymol/wizard/mutagenesis.py
++++ b/modules/pymol/wizard/mutagenesis.py
+@@ -53,7 +53,7 @@ class Mutagenesis(Wizard):
+ self.dep = default_dep
+
+ self.ind_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_ind.pkl")
++ "/chempy/sidechains/sc_bb_ind.pkl")
+ self.load_library()
+ self.status = 0 # 0 no selection, 1 mutagenizing
+ self.bump_check = 1
+@@ -218,7 +218,7 @@ class Mutagenesis(Wizard):
+ if self.dep == 'dep':
+ if not hasattr(self,'dep_library'):
+ self.dep_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_dep.pkl")
++ "/chempy/sidechains/sc_bb_dep.pkl")
+
+ def set_mode(self,mode):
+ cmd=self.cmd
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.1-flags.patch b/sci-chemistry/pymol/files/pymol-1.5.0.1-flags.patch
new file mode 100644
index 000000000000..9bdba45f3b1f
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.1-flags.patch
@@ -0,0 +1,19 @@
+ setup.py | 5 +----
+ 1 files changed, 1 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 2b6fa35..9c0556d 100755
+--- a/setup.py
++++ b/setup.py
+@@ -197,10 +197,7 @@ else: # linux or other unix
+ ("_PYMOL_GL_CALLLISTS",None),
+ ("OPENGL_ES_2",None),
+ ]
+- ext_comp_args = [ "-ffast-math",
+- "-funroll-loops",
+- "-O3",
+- "-g" ]
++ ext_comp_args = []
+ ext_link_args = []
+
+
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.1-nosplash.patch b/sci-chemistry/pymol/files/pymol-1.5.0.1-nosplash.patch
new file mode 100644
index 000000000000..b296285e89ca
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.1-nosplash.patch
@@ -0,0 +1,15 @@
+ modules/pymol/invocation.py | 2 --
+ 1 files changed, 0 insertions(+), 2 deletions(-)
+
+diff --git a/modules/pymol/invocation.py b/modules/pymol/invocation.py
+index de47849..c5f4487 100644
+--- a/modules/pymol/invocation.py
++++ b/modules/pymol/invocation.py
+@@ -397,7 +397,5 @@ if __name__=='pymol.invocation':
+ if loaded_something and (options.after_load_script!=""):
+ options.deferred.append(options.after_load_script)
+ options.deferred.extend(final_actions)
+- if options.show_splash and not options.no_gui and not restricted:
+- options.deferred.insert(0,"_do__ cmd.splash(1)")
+ if options.full_screen:
+ options.deferred.append("_do__ full_screen on")
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.1-prefix.patch b/sci-chemistry/pymol/files/pymol-1.5.0.1-prefix.patch
new file mode 100644
index 000000000000..830eb8febbf5
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.1-prefix.patch
@@ -0,0 +1,43 @@
+ setup.py | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index ce0d271..2b6fa35 100755
+--- a/setup.py
++++ b/setup.py
+@@ -104,7 +104,7 @@ elif sys.platform=='darwin':
+ inc_dirs=["ov/src",
+ "layer0","layer1","layer2",
+ "layer3","layer4","layer5",
+- "/usr/X11R6/include",
++ "@GENTOO_PORTAGE_EPREFIX@/usr/include",
+ EXT+"/include",
+ EXT+"/include/GL",
+ EXT+"/include/freetype2",
+@@ -120,7 +120,7 @@ elif sys.platform=='darwin':
+ ]
+ ext_comp_args=[]
+ ext_link_args=[
+- "-L/usr/X11R6/lib64", "-lGL", "-lXxf86vm",
++ "-L@GENTOO_PORTAGE_EPREFIX@/usr/lib64", "-lGL", "-lXxf86vm",
+ "-L"+EXT+"/lib", "-lpng", "-lglut", "-lfreetype"
+ ]
+ #============================================================================
+@@ -159,7 +159,7 @@ else: # linux or other unix
+ "layer3",
+ "layer4",
+ "layer5",
+- "/usr/include/freetype2",
++ "@GENTOO_PORTAGE_EPREFIX@/usr/include/freetype2",
+ # VMD plugin support
+ "contrib/uiuc/plugins/include",
+ "contrib/uiuc/plugins/molfile_plugin/src",
+@@ -180,7 +180,7 @@ else: # linux or other unix
+ "GLU",
+ "glut",
+ "GLEW"]
+- lib_dirs = [ "/usr/X11R6/lib64", ]
++ lib_dirs = [ "@GENTOO_PORTAGE_EPREFIX@/usr/lib64", ]
+ def_macros = [ ("_PYMOL_MODULE",None),
+ ("_PYMOL_INLINE",None),
+ ("_PYMOL_FREETYPE",None),
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.1-setup.py.patch b/sci-chemistry/pymol/files/pymol-1.5.0.1-setup.py.patch
new file mode 100644
index 000000000000..076d6907a183
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.1-setup.py.patch
@@ -0,0 +1,39 @@
+ setup.py | 28 ----------------------------
+ 1 files changed, 0 insertions(+), 28 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 18866a2..705b0c5 100755
+--- a/setup.py
++++ b/setup.py
+@@ -487,31 +487,3 @@ distribution = setup ( # Distribution meta-data
+ define_macros = def_macros
+ )
+ ])
+-
+-# make available for setup2.py
+-try:
+- site_packages = distribution.command_obj['install'].install_libbase
+-except KeyError:
+- print """
+- Error: Please run, 'setup.py install' not 'setup build' or other variant.
+-
+-"""
+- sys.exit(2)
+-
+-f = open('setup3.py', 'w')
+-print >> f, 'site_packages =', repr(site_packages)
+-f.close()
+-
+-print '''
+- After running:
+-
+- python setup.py install
+-
+- Please run, to complete the installation:
+-
+- python setup2.py install
+-
+- To uninstall PyMOL, run:
+-
+- python setup2.py uninstall
+-'''
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.1-vmd.patch b/sci-chemistry/pymol/files/pymol-1.5.0.1-vmd.patch
new file mode 100644
index 000000000000..cf47082efb2b
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.1-vmd.patch
@@ -0,0 +1,36 @@
+ setup.py | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 366d552..ce0d271 100755
+--- a/setup.py
++++ b/setup.py
+@@ -161,8 +161,8 @@ else: # linux or other unix
+ "layer5",
+ "/usr/include/freetype2",
+ # VMD plugin support
+- # "contrib/uiuc/plugins/include",
+- # "contrib/uiuc/plugins/molfile_plugin/src",
++ "contrib/uiuc/plugins/include",
++ "contrib/uiuc/plugins/molfile_plugin/src",
+ "modules/cealign/src",
+ "modules/cealign/src/tnt",
+ "generated/include",
+@@ -190,7 +190,7 @@ else: # linux or other unix
+ # Numeric Python support
+ # ("_PYMOL_NUMPY",None),
+ # VMD plugin support
+- # ("_PYMOL_VMD_PLUGINS",None)
++ ("_PYMOL_VMD_PLUGINS",None),
+ ("_PYMOL_CGO_DRAWARRAYS",None),
+ ("_PYMOL_CGO_DRAWBUFFERS",None),
+ ("_CGO_DRAWARRAYS",None),
+@@ -354,7 +354,7 @@ distribution = setup ( # Distribution meta-data
+ "layer5/main.c"
+ # VMD plugin support
+ # switch the 0 to 1 to activate the additional source code
+- ] + 0 * [
++ ] + 1 * [
+ # (incomplete support -- only TRJ, TRR, XTC, DCD so far...)
+ 'contrib/uiuc/plugins/molfile_plugin/src/PlugIOManagerInit.c',
+ 'contrib/uiuc/plugins/molfile_plugin/src/avsplugin.cpp',
diff --git a/sci-chemistry/pymol/files/pymol-1.5.0.1-web.patch b/sci-chemistry/pymol/files/pymol-1.5.0.1-web.patch
new file mode 100644
index 000000000000..fe61f0264f0b
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.5.0.1-web.patch
@@ -0,0 +1,19 @@
+ setup.py | 5 +----
+ 1 files changed, 1 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 18866a2..366d552 100755
+--- a/setup.py
++++ b/setup.py
+@@ -229,10 +229,7 @@ distribution = setup ( # Distribution meta-data
+ 'pymol/opengl/gl',
+ 'pymol/opengl/glu',
+ 'pymol/opengl/glut',
+- 'pymol/wizard',
+- 'web',
+- 'web/examples',
+- 'web/javascript', ],
++ 'pymol/wizard', ],
+ ext_modules = [
+ Extension("pymol._cmd", [
+ "modules/cealign/src/ccealignmodule.cpp",