summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-24 17:00:58 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-24 17:00:58 +0000
commit5c119af4b42b913b98427a718ca94eb00745e1ba (patch)
tree98e0fb1a4091fa131a8524471b7ef4a155b73a8f /sci-chemistry/pymol/pymol-0.90.ebuild
parentMoving to sci-chemistry/pymol (diff)
downloadgentoo-2-5c119af4b42b913b98427a718ca94eb00745e1ba.tar.gz
gentoo-2-5c119af4b42b913b98427a718ca94eb00745e1ba.tar.bz2
gentoo-2-5c119af4b42b913b98427a718ca94eb00745e1ba.zip
Moved from app-sci/pymol to sci-chemistry/pymol.
Diffstat (limited to 'sci-chemistry/pymol/pymol-0.90.ebuild')
-rw-r--r--sci-chemistry/pymol/pymol-0.90.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/pymol-0.90.ebuild b/sci-chemistry/pymol/pymol-0.90.ebuild
new file mode 100644
index 000000000000..5bf6ec7117e0
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-0.90.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.90.ebuild,v 1.1 2004/12/24 17:00:58 ribosome Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pymol/${PN}-${PV/./_}-src.tgz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+IUSE=""
+KEYWORDS="x86 ~ppc"
+
+DEPEND="dev-lang/python
+ dev-python/pmw
+ dev-python/numeric
+ dev-lang/tk
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/glut"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/setup.py-gentoo.patch
+ epatch ${FILESDIR}/setup2.py-gentoo.patch
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though.
+ [[ -n "$WANT_NOSPLASH" ]] && epatch ${FILESDIR}/nosplash-gentoo.patch
+}
+
+src_install() {
+ distutils_src_install
+ cd ${S}
+ ${python} setup2.py
+
+ local sedexp="s:${D%/}::g"
+ sed -e ${sedexp} pymol.com > pymol
+ exeinto /usr/bin
+ doexe pymol
+ dodoc DEVELOPERS CHANGES
+ #install examples
+ mv examples ${D}/usr/share/doc/${PF}
+}