summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-20 04:12:59 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-20 04:12:59 +0000
commitf529250870f916ed2a42b33fc9c43fd48c78cc60 (patch)
tree96d189aa072dc320fe797404f4b89bc6197f9cf5 /sci-chemistry/validation/validation-6.2.ebuild
parentExtract lots of information from Protein Data Bank files. (diff)
downloadgentoo-2-f529250870f916ed2a42b33fc9c43fd48c78cc60.tar.gz
gentoo-2-f529250870f916ed2a42b33fc9c43fd48c78cc60.tar.bz2
gentoo-2-f529250870f916ed2a42b33fc9c43fd48c78cc60.zip
Add a fixed version; works with other RCSB apps and libraries.
(Portage version: 2.1_pre1)
Diffstat (limited to 'sci-chemistry/validation/validation-6.2.ebuild')
-rw-r--r--sci-chemistry/validation/validation-6.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-chemistry/validation/validation-6.2.ebuild b/sci-chemistry/validation/validation-6.2.ebuild
new file mode 100644
index 000000000000..3072f54ce0ee
--- /dev/null
+++ b/sci-chemistry/validation/validation-6.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/validation/validation-6.2.ebuild,v 1.1 2005/12/20 04:12:59 spyderous Exp $
+
+inherit eutils toolchain-funcs multilib
+
+# pdb-extract includes a newer 'validation' than 'validation' tarball does,
+# and the filterlib from pdb-extract is incompatible with the validation tarball
+MY_PN="pdb-extract"
+MY_PV="1.700"
+MY_P="${MY_PN}-v${MY_PV}-prod-src"
+DESCRIPTION="Set of tools used by the PDB for processing and checking structure data"
+HOMEPAGE="http://sw-tools.pdb.org/apps/VAL/index.html"
+SRC_URI="http://sw-tools.pdb.org/apps/PDB_EXTRACT/${MY_P}.tar.gz"
+LICENSE="PDB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="sci-libs/rcsb-data"
+DEPEND="${RDEPEND}
+ sci-chemistry/pdb-extract"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/respect-cflags-and-fix-install.patch
+ cd ${S}
+
+ # Get rid of unneeded directories, to make sure we use system files
+ ebegin "Deleting redundant directories"
+ rm -rf btree-obj* ciflib-common* cifobj-common* cif-table-obj* maxit* \
+ misclib* regex* pdb-extract*
+ eend
+
+ sed -i \
+ -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
+ -e "s:^\(GINCLUDE=\).*:\1-I${ROOT}usr/include/rcsb:g" \
+ -e "s:^\(LIBDIR=\).*:\1${ROOT}usr/$(get_libdir):g" \
+ ${S}/etc/make.*
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/*
+ dolib.a lib/*
+ insinto /usr/include/rcsb
+ doins include/*
+ dodoc ${FILESDIR}/README*
+}