summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-08-07 13:29:11 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-08-07 13:29:11 +0000
commitb64345237068bfc118259dca9e18ec8287ca05ac (patch)
tree0a905f2d2a5414ed08248ae0325461198e0078d8 /sci-chemistry/vmd
parentbump, fixes IO performance bug in 4.5.0 (diff)
downloadgentoo-2-b64345237068bfc118259dca9e18ec8287ca05ac.tar.gz
gentoo-2-b64345237068bfc118259dca9e18ec8287ca05ac.tar.bz2
gentoo-2-b64345237068bfc118259dca9e18ec8287ca05ac.zip
Removed the EAPI2 check for -truetype and added explicit error logic.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/vmd')
-rw-r--r--sci-chemistry/vmd/ChangeLog8
-rw-r--r--sci-chemistry/vmd/files/vmd-1.8.7-config.patch13
-rw-r--r--sci-chemistry/vmd/vmd-1.8.7.ebuild14
3 files changed, 31 insertions, 4 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index 854a80b5321d..e07546317f1d 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/vmd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.23 2009/08/06 14:19:15 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.24 2009/08/07 13:29:11 markusle Exp $
+
+ 07 Aug 2009; Markus Dittrich <markusle@gentoo.org> vmd-1.8.7.ebuild,
+ files/vmd-1.8.7-config.patch:
+ Remove the EAPI2 check for -truetype and add explicit error logic
+ so tk-8.4 users can emerge vmd as well. Also updated the config
+ patch to handle tk8.4 better.
*vmd-1.8.7 (05 Aug 2009)
diff --git a/sci-chemistry/vmd/files/vmd-1.8.7-config.patch b/sci-chemistry/vmd/files/vmd-1.8.7-config.patch
index 633337105e97..7850e9f32b6b 100644
--- a/sci-chemistry/vmd/files/vmd-1.8.7-config.patch
+++ b/sci-chemistry/vmd/files/vmd-1.8.7-config.patch
@@ -1,6 +1,6 @@
diff -Naur vmd-1.8.7/configure vmd-1.8.7.new/configure
--- vmd-1.8.7/configure 2009-08-01 03:19:34.000000000 -0400
-+++ vmd-1.8.7.new/configure 2009-08-05 09:07:08.000000000 -0400
++++ vmd-1.8.7.new/configure 2009-08-07 09:12:43.000000000 -0400
@@ -13,10 +13,10 @@
$install_name = "vmd";
@@ -73,6 +73,17 @@ diff -Naur vmd-1.8.7/configure vmd-1.8.7.new/configure
$fltk_libs = "-lfltk -lX11";
#@fltk_cc = ('forms_ui.c');
@fltk_cu = ();
+@@ -612,8 +589,8 @@
+ if ($config_tk) { $tcl_include .= " -I$stock_tk_include_dir"; }
+ $tcl_library = "-L$stock_tcl_library_dir";
+ if ($config_tk) { $tcl_library .= " -L$stock_tk_library_dir"; }
+-$tcl_libs = "-ltcl8.5";
+-if ($config_tk) { $tcl_libs = "-ltk8.5 -lX11 " . $tcl_libs; }
++$tcl_libs = "-ltcl";
++if ($config_tk) { $tcl_libs = "-ltk -lX11 " . $tcl_libs; }
+
+ @tcl_cc = ();
+ @tcl_cu = ();
@@ -938,8 +915,8 @@
#######################
$netcdf_defines = "";
diff --git a/sci-chemistry/vmd/vmd-1.8.7.ebuild b/sci-chemistry/vmd/vmd-1.8.7.ebuild
index 2b20f6714aba..4123b59229c4 100644
--- a/sci-chemistry/vmd/vmd-1.8.7.ebuild
+++ b/sci-chemistry/vmd/vmd-1.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.7.ebuild,v 1.2 2009/08/06 15:18:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.7.ebuild,v 1.3 2009/08/07 13:29:11 markusle Exp $
EAPI="2"
@@ -21,7 +21,7 @@ DEPEND="x11-libs/libXft
virtual/opengl
x11-libs/fltk:1.1
>=dev-lang/tcl-8.4
- >=dev-lang/tk-8.4[-truetype]
+ >=dev-lang/tk-8.4
=dev-lang/python-2*
dev-lang/perl
dev-python/numpy
@@ -43,6 +43,16 @@ pkg_nofetch() {
}
src_prepare() {
+ # currently, tk-8.5* with USE=truetype breaks some
+ # tk apps such as Sequence Viewer or Timeline.
+ if has_version =dev-lang/tcl-8.5* && built_with_use dev-lang/tk truetype; then
+ echo
+ eerror "Error: Your tk was build with USE=\"truetype\" which"
+ eerror "will cause some of VMD's tk apps to not work properly"
+ eerror "(Sequence Viewer, Timeline, ..)."
+ die "Please emerge tk with USE=\"-truetype\"".
+ fi
+
# apply LINUX-arch patches to vmd configure
epatch "${FILESDIR}/${P}-config.patch"
epatch "${FILESDIR}/${P}-use-bash-startup.patch"