summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 12:54:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 12:54:00 +0000
commit11bc5b43e1aa7c1ebf9ae20fa4e3fa5ae764c3d2 (patch)
treebd93994d16a02a7ef7f6c6caf127e03fbb273953 /sci-chemistry
parentamd64 stable wrt #298979 (diff)
downloadgentoo-2-11bc5b43e1aa7c1ebf9ae20fa4e3fa5ae764c3d2.tar.gz
gentoo-2-11bc5b43e1aa7c1ebf9ae20fa4e3fa5ae764c3d2.tar.bz2
gentoo-2-11bc5b43e1aa7c1ebf9ae20fa4e3fa5ae764c3d2.zip
New addition of NMR software
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/talos+/ChangeLog17
-rw-r--r--sci-chemistry/talos+/files/rama+.patch12
-rw-r--r--sci-chemistry/talos+/metadata.xml8
-rw-r--r--sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild43
4 files changed, 80 insertions, 0 deletions
diff --git a/sci-chemistry/talos+/ChangeLog b/sci-chemistry/talos+/ChangeLog
new file mode 100644
index 000000000000..e25256580ed6
--- /dev/null
+++ b/sci-chemistry/talos+/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for sci-chemistry/talos+
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/talos+/ChangeLog,v 1.1 2010/03/07 12:54:00 jlec Exp $
+
+*talos+-1.2009.1013.14 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +talos+-1.2009.1013.14.ebuild, +files/rama+.patch, +metadata.xml:
+ TALOS+ is largely based on the same concept as the original TALOS program,
+ and now exploits a larger database of 200 proteins, but more importantly
+ it includes a neural network component whose output is used as an
+ additional empirical term in the conventional TALOS database search. The
+ neural network component of the program relies on a well established
+ computational framework that optimizes the relation between a large number
+ of input variables derived from amino acid types and chemical shifts, and
+ the area of the Ramachandran map where the residue is likely to reside.
+
diff --git a/sci-chemistry/talos+/files/rama+.patch b/sci-chemistry/talos+/files/rama+.patch
new file mode 100644
index 000000000000..826b9edbbfe2
--- /dev/null
+++ b/sci-chemistry/talos+/files/rama+.patch
@@ -0,0 +1,12 @@
+--- rama+ 2009-06-01 23:23:12.000000000 +0200
++++ rama+.new 2009-06-10 11:02:28.000000000 +0200
+@@ -5,7 +5,7 @@
+ # setenv SURF_DIR DIR_HERE/surface
+
+ if ($#argv >= 1) then
+- $TALOS_DIR/rama+.tcl $argv[1-$#argv]
++ $TALOS_DIR/bin/rama+.tcl $argv[1-$#argv]
+ else
+- $TALOS_DIR/rama+.tcl -help
++ $TALOS_DIR/bin/rama+.tcl -help
+ endif
diff --git a/sci-chemistry/talos+/metadata.xml b/sci-chemistry/talos+/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-chemistry/talos+/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild b/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild
new file mode 100644
index 000000000000..9adee0888b1b
--- /dev/null
+++ b/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild,v 1.1 2010/03/07 12:54:00 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="A Hybrid method for predicting protein backbone torsion angles from NMR CS"
+HOMEPAGE="http://spin.niddk.nih.gov/bax/software/TALOS+/index.html"
+SRC_URI="http://spin.niddk.nih.gov/bax/software/TALOS+/talos+.tar.Z -> ${P}.tar.Z"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="dev-lang/tcl"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/rama+.patch
+}
+
+src_install() {
+ sed \
+ -e "s:DIR_HERE:${EPREFIX}/opt/${PN}/:g" \
+ -i *+
+
+ insinto /opt/${PN}/
+ doins -r tab rama.{dat,gif} || die
+
+ exeinto /opt/${PN}/bin
+ newexe bin/TALOS+.linux TALOS+ || die
+ doexe rama+.tcl || die
+
+ dobin bmrb2talos.com talos2dyana.com talos2xplor.com talos+ rama+ || die
+
+ dodoc README || die
+}