summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-24 17:54:56 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-24 17:54:56 +0000
commit3cb454e397412b16603b878a1b02b5b989fd6fa5 (patch)
tree5fcc8e3a7fcd58a4361b18eeecb0f5d687a34d62 /sci-chemistry
parentstable x86, bug 334315 (diff)
downloadgentoo-2-3cb454e397412b16603b878a1b02b5b989fd6fa5.tar.gz
gentoo-2-3cb454e397412b16603b878a1b02b5b989fd6fa5.tar.bz2
gentoo-2-3cb454e397412b16603b878a1b02b5b989fd6fa5.zip
Fix building with recent glibc wrt bug 333843. Thanks to Diego for report and Samuli for the fix.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/burrow-owl/ChangeLog10
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-1.4-r1.ebuild (renamed from sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild)13
-rw-r--r--sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch38
3 files changed, 58 insertions, 3 deletions
diff --git a/sci-chemistry/burrow-owl/ChangeLog b/sci-chemistry/burrow-owl/ChangeLog
index d5e3aab3dd5b..494ce1777cad 100644
--- a/sci-chemistry/burrow-owl/ChangeLog
+++ b/sci-chemistry/burrow-owl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/burrow-owl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.3 2010/07/17 14:42:48 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.4 2010/08/24 17:54:56 xarthisius Exp $
+
+*burrow-owl-1.4-r1 (24 Aug 2010)
+
+ 24 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ -burrow-owl-1.4.ebuild, +burrow-owl-1.4-r1.ebuild,
+ +files/1.4-glibc-2.12.patch:
+ Fix building with recent glibc wrt bug 333843. Thanks to Diego for report
+ and Samuli for the fix.
17 Jul 2010; Kacper Kowalik <xarthisius@gentoo.org> burrow-owl-1.4.ebuild:
Add missing dependencies. Fix tests wrt bug 328561. Thanks to Diego for
diff --git a/sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild b/sci-chemistry/burrow-owl/burrow-owl-1.4-r1.ebuild
index 9efe67d68c07..f8f7c71c5c88 100644
--- a/sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild
+++ b/sci-chemistry/burrow-owl/burrow-owl-1.4-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild,v 1.2 2010/07/17 14:42:48 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/burrow-owl-1.4-r1.ebuild,v 1.1 2010/08/24 17:54:56 xarthisius Exp $
EAPI="2"
-inherit base virtualx
+inherit autotools base virtualx
DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
HOMEPAGE="http://burrow-owl.sourceforge.net/"
@@ -27,8 +27,17 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PV}-include.patch
+ "${FILESDIR}"/${PV}-glibc-2.12.patch #333843
)
+src_prepare() {
+ base_src_prepare
+ # bug 333843
+ mv src/endian.h src/bo_endian.h || die
+ mv src/endian.c src/bo_endian.c || die
+ eautoreconf
+}
+
src_test () {
Xemake check || die
}
diff --git a/sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch b/sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch
new file mode 100644
index 000000000000..cca640a6347d
--- /dev/null
+++ b/sci-chemistry/burrow-owl/files/1.4-glibc-2.12.patch
@@ -0,0 +1,38 @@
+Fix build with GLIBC-2.12
+
+http://bugs.gentoo.org/show_bug.cgi?id=333843
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -82,8 +82,8 @@
+ painter.h \
+ ticket.c \
+ ticket.h \
+-endian.c \
+-endian.h \
++bo_endian.c \
++bo_endian.h \
+ version.c \
+ version.h
+
+--- src/hosbackingfile.c
++++ src/hosbackingfile.c
+@@ -18,6 +18,7 @@
+ */
+
+ #include "hosbackingfile.h"
++#include "bo_endian.h"
+
+ #define DEFAULT_BUF_SIZE 512
+
+--- src/nih.c
++++ src/nih.c
+@@ -24,7 +24,7 @@
+ #include "hosdimensionblock.h"
+ #include "hosbackingblock.h"
+ #include "hosbackingfile.h"
+-#include "endian.h"
++#include "bo_endian.h"
+
+ /* --- header contents ----
+ *