summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-19 10:20:35 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-19 10:20:35 +0000
commit48855f27c5a832a30d1045711d4ce537c622875f (patch)
tree0183ec32a7e3e9247ddb5a6416c3b0986278f246 /sci-chemistry
parentsci-chemistry/pointless: Remove virtual/fortran and always call fortran-2_pkg... (diff)
downloadgentoo-2-48855f27c5a832a30d1045711d4ce537c622875f.tar.gz
gentoo-2-48855f27c5a832a30d1045711d4ce537c622875f.tar.bz2
gentoo-2-48855f27c5a832a30d1045711d4ce537c622875f.zip
sci-chemistry/procheck: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/procheck/ChangeLog7
-rw-r--r--sci-chemistry/procheck/metadata.xml1
-rw-r--r--sci-chemistry/procheck/procheck-3.5.4-r1.ebuild27
3 files changed, 18 insertions, 17 deletions
diff --git a/sci-chemistry/procheck/ChangeLog b/sci-chemistry/procheck/ChangeLog
index 89b30d04b282..f7473ca242e5 100644
--- a/sci-chemistry/procheck/ChangeLog
+++ b/sci-chemistry/procheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/procheck
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/procheck/ChangeLog,v 1.8 2012/07/09 19:01:10 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/procheck/ChangeLog,v 1.9 2012/10/19 10:20:35 jlec Exp $
+
+ 19 Oct 2012; Justin Lecher <jlec@gentoo.org> procheck-3.5.4-r1.ebuild,
+ metadata.xml:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
09 Jul 2012; Johannes Huber <johu@gentoo.org> procheck-3.5.4-r1.ebuild:
Stable for x86, wrt bug #419877
diff --git a/sci-chemistry/procheck/metadata.xml b/sci-chemistry/procheck/metadata.xml
index 8487320ca2a0..04b998aabe31 100644
--- a/sci-chemistry/procheck/metadata.xml
+++ b/sci-chemistry/procheck/metadata.xml
@@ -7,4 +7,3 @@
<name>Justin Lecher</name>
</maintainer>
</pkgmetadata>
-
diff --git a/sci-chemistry/procheck/procheck-3.5.4-r1.ebuild b/sci-chemistry/procheck/procheck-3.5.4-r1.ebuild
index 995157d9dbbe..ddf5470acffc 100644
--- a/sci-chemistry/procheck/procheck-3.5.4-r1.ebuild
+++ b/sci-chemistry/procheck/procheck-3.5.4-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/procheck/procheck-3.5.4-r1.ebuild,v 1.6 2012/07/09 19:01:10 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/procheck/procheck-3.5.4-r1.ebuild,v 1.7 2012/10/19 10:20:35 jlec Exp $
-EAPI="3"
+EAPI=4
-inherit eutils fortran-2 toolchain-funcs versionator
+inherit eutils fortran-2 multilib toolchain-funcs versionator
DESCRIPTION="Checks the stereochemical quality of a protein structure"
HOMEPAGE="http://www.biochem.ucl.ac.uk/~roman/procheck/procheck.html"
@@ -17,9 +17,7 @@ SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND="
- virtual/fortran
- app-shells/tcsh"
+RDEPEND="app-shells/tcsh"
DEPEND="${RDEPEND}"
RESTRICT="fetch"
@@ -46,13 +44,12 @@ src_compile() {
F77=$(tc-getFC) \
CC=$(tc-getCC) \
COPTS="${CFLAGS}" \
- FOPTS="${FFLAGS}" \
- || die "emake failed"
+ FOPTS="${FFLAGS}"
}
src_install() {
for i in *.scr; do
- newbin ${i} ${i%.scr} || die
+ newbin ${i} ${i%.scr}
done
exeinto /usr/$(get_libdir)/${PN}/
@@ -69,22 +66,22 @@ src_install() {
vplot \
viol2pdb \
wirplot \
- nb || die
- dodoc "${DISTDIR}"/${P}-README || die
+ nb
+ dodoc "${DISTDIR}"/${P}-README
insinto /usr/$(get_libdir)/${PN}/
- doins *.dat *.prm || die
- newins resdefs.dat resdefs.data || die
+ doins *.dat *.prm
+ newins resdefs.dat resdefs.data
cat >> "${T}"/30${PN} <<- EOF
prodir="${EPREFIX}/usr/$(get_libdir)/${PN}/"
EOF
- doenvd "${T}"/30${PN} || die
+ doenvd "${T}"/30${PN}
if use doc; then
pushd "${WORKDIR}"
- dohtml -r manual || die
+ dohtml -r manual
popd
fi
}