summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-27 16:53:35 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-27 16:53:35 +0000
commit50dac19d9ee326282ff7c4fb57913b9688973856 (patch)
tree9e55afdced88d217c08be40743e2b5ffa08b8420 /sci-chemistry
parentsci-chemistry/gamess: Use PKG_CONFIG instead of generic pkg-config (diff)
downloadgentoo-2-50dac19d9ee326282ff7c4fb57913b9688973856.tar.gz
gentoo-2-50dac19d9ee326282ff7c4fb57913b9688973856.tar.bz2
gentoo-2-50dac19d9ee326282ff7c4fb57913b9688973856.zip
sci-chemistry/ccp4-apps: Use PKG_CONFIG instead of generic pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/ccp4-apps/ChangeLog6
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r11.ebuild5
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r12.ebuild3
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch6
4 files changed, 13 insertions, 7 deletions
diff --git a/sci-chemistry/ccp4-apps/ChangeLog b/sci-chemistry/ccp4-apps/ChangeLog
index 286ea0168ac6..967b41eba6ae 100644
--- a/sci-chemistry/ccp4-apps/ChangeLog
+++ b/sci-chemistry/ccp4-apps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/ccp4-apps
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.40 2013/01/10 17:29:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.41 2013/02/27 16:53:35 jlec Exp $
+
+ 27 Feb 2013; Justin Lecher <jlec@gentoo.org> files/6.1.3-lapack.patch,
+ ccp4-apps-6.1.3-r11.ebuild, ccp4-apps-6.1.3-r12.ebuild:
+ Use PKG_CONFIG instead of generic pkg-config
*ccp4-apps-6.1.3-r12 (10 Jan 2013)
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r11.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r11.ebuild
index df20f130c96d..b8d1dd12f76e 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r11.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r11.ebuild,v 1.2 2012/10/19 09:41:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r11.ebuild,v 1.3 2013/02/27 16:53:35 jlec Exp $
EAPI=3
@@ -98,6 +98,7 @@ pkg_setup() {
}
src_prepare() {
+ tc-export PKG_CONFIG
einfo "Applying upstream patches ..."
for patch in $(seq $PATCH_TOT); do
base="PATCH${patch}"
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r12.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r12.ebuild
index e9ddb76c4103..87d8f63f9092 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r12.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r12.ebuild,v 1.1 2013/01/10 17:29:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r12.ebuild,v 1.2 2013/02/27 16:53:35 jlec Exp $
EAPI=3
@@ -98,6 +98,7 @@ pkg_setup() {
}
src_prepare() {
+ tc-export PKG_CONFIG
einfo "Applying upstream patches ..."
for patch in $(seq $PATCH_TOT); do
base="PATCH${patch}"
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch b/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch
index cef286b16b7c..62892db01147 100644
--- a/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch
+++ b/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch
@@ -567,10 +567,10 @@ index 833f483..bcfa62d 100755
+ # gentoo is clever
+ make_blas=
+ make_lapack=
-+ BLASLIB=$(pkg-config --libs blas)
-+ LAPACKLIB=$(pkg-config --libs lapack)
++ BLASLIB=$(${PKG_CONFIG} --libs blas)
++ LAPACKLIB=$(${PKG_CONFIG} --libs lapack)
+ XLAPACK_LIB="${BLASLIB} ${LAPACKLIB}"
-+ XFFLAGS_LAPACK="$(pkg-config --cflags lapack blas)"
++ XFFLAGS_LAPACK="$(${PKG_CONFIG} --cflags lapack blas)"
# Otherwise force building of NetLib BLAS and LAPACK libs
- else
- echo