summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-06-23 10:08:45 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-06-23 10:08:45 +0000
commit702ff80e129a6d930e26b02df64c855040d8d733 (patch)
tree4d98d751a002eea4c772cbf8ce4a3897b0c84484 /sci-chemistry
parent[bump] dev-perl/Schedule-At-1.130.0 (diff)
downloadgentoo-2-702ff80e129a6d930e26b02df64c855040d8d733.tar.gz
gentoo-2-702ff80e129a6d930e26b02df64c855040d8d733.tar.bz2
gentoo-2-702ff80e129a6d930e26b02df64c855040d8d733.zip
[sci-chemistry/gromacs] only USE=fkernels needs fortran
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/ChangeLog6
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild9
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild9
3 files changed, 17 insertions, 7 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index a7a1f04573ff..6c2edaf8d683 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gromacs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.89 2011/06/21 16:03:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.90 2011/06/23 10:08:45 ottxor Exp $
+
+ 23 Jun 2011; Christoph Junghans <ottxor@gentoo.org> gromacs-4.5.4-r1.ebuild,
+ gromacs-4.5.4-r2.ebuild:
+ only USE=fkernels needs fortran
21 Jun 2011; Justin Lecher <jlec@gentoo.org> gromacs-4.5.4-r1.ebuild,
gromacs-4.5.4-r2.ebuild:
diff --git a/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild b/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
index 36d103391cc0..ae83d8fc11ab 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild,v 1.8 2011/06/21 16:03:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r1.ebuild,v 1.9 2011/06/23 10:08:45 ottxor Exp $
EAPI="4"
@@ -37,8 +37,7 @@ mpi +single-precision sse2 static-libs test +threads +xml zsh-completion"
REQUIRED_USE="fkernels? ( !threads )"
CDEPEND="
- virtual/fortran
-
+ fkernels? ( virtual/fortran )
X? ( x11-libs/libX11
x11-libs/libSM
x11-libs/libICE )
@@ -56,6 +55,10 @@ RDEPEND="${CDEPEND}
RESTRICT="test"
+pkg_setup() {
+ use fkernels && fortran-2_pkg_setup
+}
+
src_prepare() {
if use mpi && use threads; then
elog "mdrun uses only threads OR mpi, and gromacs favours the"
diff --git a/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild b/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild
index fd5fbcd079f9..5003c502faa6 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild,v 1.3 2011/06/21 16:03:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.4-r2.ebuild,v 1.4 2011/06/23 10:08:45 ottxor Exp $
EAPI="4"
@@ -36,8 +36,7 @@ mpi +single-precision sse2 test +threads xml zsh-completion"
REQUIRED_USE="fkernels? ( !threads )"
CDEPEND="
- virtual/fortran
-
+ fkernels? ( virtual/fortran )
X? (
x11-libs/libX11
x11-libs/libSM
@@ -56,6 +55,10 @@ RDEPEND="${CDEPEND}
RESTRICT="test"
+pkg_setup() {
+ use fkernels && fortran-2_pkg_setup
+}
+
src_prepare() {
#add user patches from /etc/portage/patches/sci-chemistry/gromacs
epatch_user