summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-24 16:27:59 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-24 16:27:59 +0000
commit730b3eb3ed04dc13fc328751abbea63fe9e19243 (patch)
treeefaf4cbf56eaaca8551998bf70713bd951ffe27b /sci-chemistry
parentMoving to sci-chemistry/babel (diff)
downloadgentoo-2-730b3eb3ed04dc13fc328751abbea63fe9e19243.tar.gz
gentoo-2-730b3eb3ed04dc13fc328751abbea63fe9e19243.tar.bz2
gentoo-2-730b3eb3ed04dc13fc328751abbea63fe9e19243.zip
Moved from app-sci/babel to sci-chemistry/babel.
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/babel/ChangeLog41
-rw-r--r--sci-chemistry/babel/Manifest7
-rw-r--r--sci-chemistry/babel/babel-1.6.ebuild49
-rw-r--r--sci-chemistry/babel/files/10babel1
-rw-r--r--sci-chemistry/babel/files/babel-1.6-gcc32.diff28
-rw-r--r--sci-chemistry/babel/files/babel-1.6-gentoo.diff28
-rw-r--r--sci-chemistry/babel/files/digest-babel-1.61
-rw-r--r--sci-chemistry/babel/metadata.xml5
8 files changed, 160 insertions, 0 deletions
diff --git a/sci-chemistry/babel/ChangeLog b/sci-chemistry/babel/ChangeLog
new file mode 100644
index 000000000000..f0c45d07b1b9
--- /dev/null
+++ b/sci-chemistry/babel/ChangeLog
@@ -0,0 +1,41 @@
+# ChangeLog for app-sci/babel
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/ChangeLog,v 1.1 2004/12/24 16:27:59 ribosome Exp $
+
+*babel-1.6 (24 Dec 2004)
+
+ 24 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +files/10babel, +files/babel-1.6-gcc32.diff, +files/babel-1.6-gentoo.diff,
+ +babel-1.6.ebuild:
+ Moved from app-sci/babel to sci-chemistry/babel.
+
+ 15 Jul 2004; Danny van Dyk <kugelfang@gentoo.org> babel-1.6.ebuild:
+ Marked ~amd64.
+
+ 19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> babel-1.6.ebuild:
+ Adding IUSE
+
+ 26 Mar 2004; Patrick Kursawe <phosphan@gentoo.org> babel-1.6.ebuild:
+ Adding "inherit eutils"
+
+ 16 Dec 2003; Jason Wever <weeve@gentoo.org> babel-1.6.ebuild:
+ Added ~sparc keyword to fix broken dependencies in app-sci/xdrawchem.
+
+ 24 Sep 2003; Patrick Kursawe <phosphan@gentoo.org> babel-1.6.ebuild:
+ removed old PROVIDE line, added blocker for openbabel.
+
+*babel-1.6 (1 Feb 2002)
+
+ 15 Sep 2002; Owen Stampflee <owen@gentoo.org> :
+ Fixed a problem where GCC 3.2 fails to compile Babel on PPC.
+
+ 25 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> babel-1.6.ebuild :
+ Added LICENSE, KEYWORDS, SLOT.
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/sci-chemistry/babel/Manifest b/sci-chemistry/babel/Manifest
new file mode 100644
index 000000000000..254b25820704
--- /dev/null
+++ b/sci-chemistry/babel/Manifest
@@ -0,0 +1,7 @@
+MD5 eb76b9e0f837f183cf1ee85e85c77d12 ChangeLog 1413
+MD5 6c13969bd42cefc326c54db1d94f4541 babel-1.6.ebuild 928
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 89cff2c8f6593871433dc050f452fb55 files/10babel 27
+MD5 444ffe6f4986e1fb199a0f2a31cccd7d files/babel-1.6-gcc32.diff 549
+MD5 80848d0c7c776240d8295eadb1593a8e files/babel-1.6-gentoo.diff 569
+MD5 45d9ad9dceace9db87c213339d35e10d files/digest-babel-1.6 60
diff --git a/sci-chemistry/babel/babel-1.6.ebuild b/sci-chemistry/babel/babel-1.6.ebuild
new file mode 100644
index 000000000000..5ea6c75f16ce
--- /dev/null
+++ b/sci-chemistry/babel/babel-1.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6.ebuild,v 1.1 2004/12/24 16:27:59 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
+
+SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
+
+HOMEPAGE="http://smog.com/chem/babel/"
+KEYWORDS="x86 ppc sparc ~amd64"
+SLOT="0"
+LICENSE="as-is"
+IUSE=""
+
+#Doesn't really seem to depend on anything (?)
+DEPEND="!app-sci/openbabel"
+
+src_unpack() {
+
+ unpack ${P}.tar.Z
+ cd ${S}
+#Patch the Makefile for gentoo-isms
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gcc32.diff
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D}/usr/bin install || die
+
+ insinto /usr/share/${PN}
+ doins ${S}/*.lis
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10babel
+
+ dodoc README.1ST
+
+}
+
diff --git a/sci-chemistry/babel/files/10babel b/sci-chemistry/babel/files/10babel
new file mode 100644
index 000000000000..69f3397638dd
--- /dev/null
+++ b/sci-chemistry/babel/files/10babel
@@ -0,0 +1 @@
+BABEL_DIR=/usr/share/babel
diff --git a/sci-chemistry/babel/files/babel-1.6-gcc32.diff b/sci-chemistry/babel/files/babel-1.6-gcc32.diff
new file mode 100644
index 000000000000..ba0964af5352
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-gcc32.diff
@@ -0,0 +1,28 @@
+--- block.c.orig Sun Sep 15 04:51:13 2002
++++ block.c Sun Sep 15 04:58:04 2002
+@@ -99,7 +99,12 @@
+ void *array;
+
+ /* calc how much space we are gonna need */
++#ifdef __va_copy
++ __va_copy (ap, initap);
++#else
+ ap = initap;
++#endif
++
+ size = 0;
+ for(i=0; types[i] != '\0'; i++)
+ {
+@@ -116,7 +121,12 @@
+ /* set up the ptrs if we can alloc the memory */
+ if(*handle != NULL)
+ {
++#ifdef __va_copy
++ __va_copy (ap, initap);
++#else
+ ap = initap;
++#endif
++
+ ptr = 0;
+ for(i=0; types[i] != '\0'; i++)
+ {
diff --git a/sci-chemistry/babel/files/babel-1.6-gentoo.diff b/sci-chemistry/babel/files/babel-1.6-gentoo.diff
new file mode 100644
index 000000000000..77e2cb47ef03
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-gentoo.diff
@@ -0,0 +1,28 @@
+--- Makefile.orig Tue Oct 23 00:20:54 2001
++++ Makefile Tue Oct 23 00:33:36 2001
+@@ -1,11 +1,15 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++CC = gcc
+
+ PROGRAM = babel
+
++DEST = ${DESTDIR}/$(PROGRAM)
++
+ LDFLAGS =
+
+ LIBS =
+@@ -334,6 +338,7 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
++ install -d ${DESTDIR}
+ install -s $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
diff --git a/sci-chemistry/babel/files/digest-babel-1.6 b/sci-chemistry/babel/files/digest-babel-1.6
new file mode 100644
index 000000000000..118db2b06dc9
--- /dev/null
+++ b/sci-chemistry/babel/files/digest-babel-1.6
@@ -0,0 +1 @@
+MD5 101a5dc4858ecacac123571db52b272e babel-1.6.tar.Z 242341
diff --git a/sci-chemistry/babel/metadata.xml b/sci-chemistry/babel/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/sci-chemistry/babel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>