summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-11 10:05:58 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-11 10:05:58 +0000
commitd8fa09999cbeee23e01aaae8927f720ee88eeb2c (patch)
tree9247920169e9c78a25c8dcd706995af302e4648f /sci-chemistry
parentMake sure ldap support is truly enabled before installing the openldap schema. (diff)
downloadgentoo-2-d8fa09999cbeee23e01aaae8927f720ee88eeb2c.tar.gz
gentoo-2-d8fa09999cbeee23e01aaae8927f720ee88eeb2c.tar.bz2
gentoo-2-d8fa09999cbeee23e01aaae8927f720ee88eeb2c.zip
sci-chemistry/relax: Fix again png again
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/relax/ChangeLog8
-rw-r--r--sci-chemistry/relax/relax-3.1.1-r1.ebuild (renamed from sci-chemistry/relax/relax-3.1.1.ebuild)18
2 files changed, 22 insertions, 4 deletions
diff --git a/sci-chemistry/relax/ChangeLog b/sci-chemistry/relax/ChangeLog
index 1b943c4fed96..4c3511b4583a 100644
--- a/sci-chemistry/relax/ChangeLog
+++ b/sci-chemistry/relax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/relax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.14 2013/12/11 07:58:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.15 2013/12/11 10:05:58 jlec Exp $
+
+*relax-3.1.1-r1 (11 Dec 2013)
+
+ 11 Dec 2013; Justin Lecher <jlec@gentoo.org> -relax-3.1.1.ebuild,
+ +relax-3.1.1-r1.ebuild:
+ Fix again png again
*relax-3.1.1 (11 Dec 2013)
diff --git a/sci-chemistry/relax/relax-3.1.1.ebuild b/sci-chemistry/relax/relax-3.1.1-r1.ebuild
index 4ed84854ce37..4005868150fe 100644
--- a/sci-chemistry/relax/relax-3.1.1.ebuild
+++ b/sci-chemistry/relax/relax-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.1.1.ebuild,v 1.1 2013/12/11 07:58:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.1.1-r1.ebuild,v 1.1 2013/12/11 10:05:58 jlec Exp $
EAPI=5
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 )
WX_GTK_VER="2.9"
-inherit eutils python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
DESCRIPTION="Molecular dynamics by NMR data analysis"
HOMEPAGE="http://www.nmr-relax.com/"
@@ -41,13 +41,25 @@ pkg_setup() {
python-single-r1_pkg_setup
}
+fix_png() {
+ pngcrush -q -fix -force ${1} ${1}-fixed &>/dev/null || die
+ mv ${1}-fixed ${1} || die
+ echo -e ".\c"
+}
src_prepare() {
local png
rm -rf minfx bmrblib || die
epatch \
"${FILESDIR}"/${PN}-3.0.1-gentoo.patch
-# "${FILESDIR}"/${P}-sample-script{,-backport}.patch
tc-export CC
+
+ ebegin "Fixing png files"
+ multijob_init
+ for png in $(find -type f -name "*.png"); do
+ multijob_child_init fix_png ${png}
+ done
+ multijob_finish
+ eend
}
src_compile() {