summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-01-08 16:22:24 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-01-08 16:22:24 +0000
commit0134e066e9a7b15b2ca773b14225080ecda802b1 (patch)
tree58cc8f4cc2a43e523d1cf33ce5179bfec88772f6 /sci-electronics/gtkwave/gtkwave-3.3.28.ebuild
parentAdd gsettings-desktop-schemas to dependencies wrt bug #392649. (diff)
downloadgentoo-2-0134e066e9a7b15b2ca773b14225080ecda802b1.tar.gz
gentoo-2-0134e066e9a7b15b2ca773b14225080ecda802b1.tar.bz2
gentoo-2-0134e066e9a7b15b2ca773b14225080ecda802b1.zip
Strip flags (bug #377935). Version bump. Drop old unstable versions
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/gtkwave/gtkwave-3.3.28.ebuild')
-rw-r--r--sci-electronics/gtkwave/gtkwave-3.3.28.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-electronics/gtkwave/gtkwave-3.3.28.ebuild b/sci-electronics/gtkwave/gtkwave-3.3.28.ebuild
new file mode 100644
index 000000000000..c2ed491b45ca
--- /dev/null
+++ b/sci-electronics/gtkwave/gtkwave-3.3.28.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gtkwave/gtkwave-3.3.28.ebuild,v 1.1 2012/01/08 16:22:24 tomjbe Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+
+DESCRIPTION="A wave viewer for LXT, LXT2, VZT, GHW and standard Verilog VCD/EVCD files"
+HOMEPAGE="http://gtkwave.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="doc examples fasttree fatlines judy lzma tcl"
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/pango
+ judy? ( dev-libs/judy )
+ tcl? ( dev-lang/tcl dev-lang/tk )
+ lzma? ( app-arch/xz-utils )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/gperf"
+
+src_prepare(){
+ sed -i -e 's/doc examples//' Makefile.in || die "sed failed"
+}
+
+src_configure(){
+ strip-flags
+ econf --disable-local-libz \
+ --disable-local-libbz2 \
+ --disable-dependency-tracking \
+ --enable-largefile \
+ $(use_enable fatlines) \
+ $(use_enable tcl) \
+ $(use_enable lzma xz) \
+ $(use_enable fasttree) \
+ $(use_enable judy)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ANALOG_README.TXT SYSTEMVERILOG_README.TXT CHANGELOG.TXT
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins "doc/${PN}.odt" || die "Failed to install documentation."
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Failed to install examples."
+ fi
+}