summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-03-23 17:40:34 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-03-23 17:40:34 +0000
commit38b128aac02c523a67d165563fd0028c9cee5576 (patch)
tree942a31b9e978f5a35a05c3af97239c0d4e91d7c6 /sci-electronics/kicad
parentalpha/ia64/sparc stable wrt #214281 (diff)
downloadgentoo-2-38b128aac02c523a67d165563fd0028c9cee5576.tar.gz
gentoo-2-38b128aac02c523a67d165563fd0028c9cee5576.tar.bz2
gentoo-2-38b128aac02c523a67d165563fd0028c9cee5576.zip
Version bump, many thanks to Igor Plyatov (bug #214096).
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-electronics/kicad')
-rw-r--r--sci-electronics/kicad/ChangeLog8
-rw-r--r--sci-electronics/kicad/kicad-20080320.918.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 160ccdd37e84..df44255d1446 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.31 2008/02/29 20:39:59 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.32 2008/03/23 17:40:34 calchan Exp $
+
+*kicad-20080320.918 (23 Mar 2008)
+
+ 23 Mar 2008; Denis Dupeyron <calchan@gentoo.org>
+ +kicad-20080320.918.ebuild:
+ Version bump, many thanks to Igor Plyatov (bug #214096).
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> kicad-20070115.ebuild,
kicad-20070525.ebuild, kicad-20070702.ebuild:
diff --git a/sci-electronics/kicad/kicad-20080320.918.ebuild b/sci-electronics/kicad/kicad-20080320.918.ebuild
new file mode 100644
index 000000000000..7357b55a05bc
--- /dev/null
+++ b/sci-electronics/kicad/kicad-20080320.918.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20080320.918.ebuild,v 1.1 2008/03/23 17:40:34 calchan Exp $
+
+inherit versionator wxwidgets cmake-utils flag-o-matic
+
+MY_PV="$(get_major_version)-r$(get_after_major_version)"
+LIB_VERSION="1.0"
+DOC_VERSION="1.0"
+
+DESCRIPTION="Electronic Schematic and PCB design tools."
+HOMEPAGE="http://kicad.sourceforge.net"
+SRC_URI="mirror://sourceforge/kicad/${PN}-${MY_PV}.tar.bz2
+ !minimal? ( mirror://sourceforge/kicad/${PN}-library-${LIB_VERSION}.tbz2 )
+ doc? ( mirror://sourceforge/kicad/${PN}-doc-${DOC_VERSION}.tbz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc debug examples minimal"
+
+DEPEND="=x11-libs/wxGTK-2.8*
+ dev-libs/boost"
+
+S="${WORKDIR}/${PN}"
+DOCS="change_log.txt todo.txt"
+
+pkg_setup() {
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ check_wxuse opengl
+}
+
+src_unpack() {
+ unpack ${A}
+ if ! use examples ; then
+ sed -i -e "s:^add_subdirectory(demos):#add_subdirectory(demos):" "${S}"/CMakeLists.txt || die "sed failed"
+ fi
+ sed -i -e "s:^install(FILES \${CMAKE_CURRENT_SOURCE_DIR}/install\.txt:#install(FILES \${CMAKE_CURRENT_SOURCE_DIR}/install\.txt:" \
+ "${S}"/CMakeLists.txt || die "sed failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ [[ -d "${WORKDIR}/usr" ]] && doins -r "${WORKDIR}/usr"
+}
+
+pkg_postinst() {
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you open old projects,"
+ ewarn "you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ else
+ elog "Please note that the PDF datasheets that can be linked to components from the default libraries"
+ elog "cannot be mirrored by Gentoo for legal reasons."
+ elog "If you want them, you need to download them yourself from :"
+ elog "${HOMEPAGE}"
+ elog "and install them manually."
+ fi
+ elog
+ elog "You may want to emerge media-gfx/wings if you want to create 3D models of components."
+}