summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2010-03-20 03:49:44 +0000
committerDenis Dupeyron <calchan@gentoo.org>2010-03-20 03:49:44 +0000
commit546efbd1568b04d20e379ee7edeb6fa43cc2fe95 (patch)
tree151033eccdd31b490983652cec6c6eaddf4476f5 /sci-electronics/kicad
parentVersion bump (diff)
downloadgentoo-2-546efbd1568b04d20e379ee7edeb6fa43cc2fe95.tar.gz
gentoo-2-546efbd1568b04d20e379ee7edeb6fa43cc2fe95.tar.bz2
gentoo-2-546efbd1568b04d20e379ee7edeb6fa43cc2fe95.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/kicad')
-rw-r--r--sci-electronics/kicad/ChangeLog9
-rw-r--r--sci-electronics/kicad/kicad-20100314_p2456.ebuild128
-rw-r--r--sci-electronics/kicad/kicad-99999999.ebuild4
3 files changed, 137 insertions, 4 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index bce271811746..8cb32ec3acc6 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/kicad
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.45 2009/11/16 21:44:16 calchan Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.46 2010/03/20 03:49:44 calchan Exp $
+
+*kicad-20100314_p2456 (20 Mar 2010)
+
+ 20 Mar 2010; <calchan@gentoo.org> +kicad-20100314_p2456.ebuild:
+ Version bump.
16 Nov 2009; Denis Dupeyron <calchan@gentoo.org> kicad-99999999.ebuild:
Fixed live ebuild dependencies (a.k.a. hit the commit button too quickly).
diff --git a/sci-electronics/kicad/kicad-20100314_p2456.ebuild b/sci-electronics/kicad/kicad-20100314_p2456.ebuild
new file mode 100644
index 000000000000..316031f42acd
--- /dev/null
+++ b/sci-electronics/kicad/kicad-20100314_p2456.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20100314_p2456.ebuild,v 1.1 2010/03/20 03:49:44 calchan Exp $
+
+EAPI="3"
+WX_GTK_VER="2.8"
+
+inherit cmake-utils wxwidgets fdo-mime gnome2-utils
+
+DESCRIPTION="Electronic Schematic and PCB design tools."
+HOMEPAGE="http://kicad.sourceforge.net"
+SRC_URI="http://dev.gentoo.org/~calchan/distfiles/${PN}-sources-${PV}.tar.xz
+ !minimal? ( http://dev.gentoo.org/~calchan/distfiles/${PN}-library-${PV}.tar.xz )
+ doc? ( http://dev.gentoo.org/~calchan/distfiles/${PN}-doc-${PV}.tar.xz )
+ examples? ( http://dev.gentoo.org/~calchan/distfiles/${PN}-examples-${PV}.tar.xz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dev-doc doc debug examples minimal python"
+
+CDEPEND="x11-libs/wxGTK:2.8[X,opengl]"
+DEPEND="${CDEPEND}
+ >=dev-util/cmake-2.6.0
+ >=dev-libs/boost-1.40
+ app-arch/xz-utils
+ dev-doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}
+ sys-libs/zlib
+ sci-electronics/electronics-menu
+ python? ( dev-lang/python )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Use native boost
+ sed -i -e '/Boost/s/^#check_find_package/check_find_package/' \
+ -e '/Boost/s/^#find_package/find_package/' CMakeLists.txt || die "sed failed"
+
+ # Add important doc files
+ sed -i -e 's/INSTALL.txt/AUTHORS.txt CHANGELOG.txt README.txt TODO.txt/' CMakeLists.txt || die "sed failed"
+
+ # Fix desktop files
+ rm resources/linux/mime/applications/eeschema.desktop
+ sed -i -e 's/Development;//' resources/linux/mime/applications/kicad.desktop || die "sed failed"
+
+ # Handle optional minimal install
+ if use minimal ; then
+ sed -i -e '/add_subdirectory(template)/d' CMakeLists.txt || die "sed failed"
+ else
+ sed -i -e '/add_subdirectory(template)/a \
+add_subdirectory(kicad-library)' CMakeLists.txt || die "sed failed"
+ fi
+
+ # Add documentation and fix necessary code if requested
+ if use doc ; then
+ sed -i -e '/add_subdirectory(demos)/a \
+add_subdirectory(kicad-doc)' CMakeLists.txt || die "sed failed"
+ sed -i -e "s/subdirs.Add( wxT( \"kicad\" ) );/subdirs.Add( wxT( \"${PF}\" ) );/" \
+ -e '/subdirs.Add( _T( "help" ) );/d' common/edaappl.cpp || die "sed failed"
+ fi
+
+ # Install examples in the right place if requested
+ if use examples ; then
+ sed -i -e 's:${KICAD_DATA}/demos:${KICAD_DOCS}/examples:' CMakeLists.txt || die "sed failed"
+ else
+ sed -i -e '/add_subdirectory(demos)/d' CMakeLists.txt || die "sed failed"
+ fi
+}
+
+src_configure() {
+ need-wxwidgets unicode
+
+ mycmakeargs="${mycmakeargs}
+ -DKICAD_MINIZIP=OFF
+ -DKICAD_CYRILLIC=ON
+ -DwxUSE_UNICODE=ON
+ -DKICAD_GOST=OFF
+ -DKICAD_AUIMANAGER=OFF
+ -DKICAD_AUITOOLBAR=OFF
+ -DKICAD_DOCS=/usr/share/doc/${PF}
+ -DKICAD_HELP=/usr/share/doc/${PF}
+ $(cmake-utils_use python KICAD_PYTHON)"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use dev-doc && doxygen Doxyfile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use dev-doc ; then
+ insinto /usr/share/doc/${PF}
+ doins uncrustify.cfg
+ cd Documentation
+ doins -r GUI_Translation_HOWTO.pdf guidelines/UIpolicies.txt doxygen/doxygen
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you"
+ ewarn "open old projects, you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ elog
+ fi
+ elog "You may want to emerge media-gfx/wings if you want to create 3D models of components."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/sci-electronics/kicad/kicad-99999999.ebuild b/sci-electronics/kicad/kicad-99999999.ebuild
index 4914a306fdb8..59ea93cf3417 100644
--- a/sci-electronics/kicad/kicad-99999999.ebuild
+++ b/sci-electronics/kicad/kicad-99999999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-99999999.ebuild,v 1.2 2009/11/16 21:44:16 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-99999999.ebuild,v 1.3 2010/03/20 03:49:44 calchan Exp $
EAPI="2"
WX_GTK_VER="2.8"