summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-01-02 15:36:10 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-01-02 15:36:10 +0000
commit183bcf8ffb7577cf17743550fb1ba0b9688e7a67 (patch)
tree74e4296a3a8549ff9fd4a3b2f95564b2da4372cd /sci-electronics/puff
parentStable on alpha, bug #347223 (diff)
downloadgentoo-2-183bcf8ffb7577cf17743550fb1ba0b9688e7a67.tar.gz
gentoo-2-183bcf8ffb7577cf17743550fb1ba0b9688e7a67.tar.bz2
gentoo-2-183bcf8ffb7577cf17743550fb1ba0b9688e7a67.zip
Initial ebuild (bug #316807). Moved from sci overlay.
(Portage version: 2.1.9.27/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/puff')
-rw-r--r--sci-electronics/puff/ChangeLog14
-rw-r--r--sci-electronics/puff/metadata.xml9
-rw-r--r--sci-electronics/puff/puff-20100127.ebuild48
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-electronics/puff/ChangeLog b/sci-electronics/puff/ChangeLog
new file mode 100644
index 000000000000..be48941e6929
--- /dev/null
+++ b/sci-electronics/puff/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sci-electronics/puff
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/puff/ChangeLog,v 1.1 2011/01/02 15:36:10 tomjbe Exp $
+
+ 02 Jan 2011; Thomas Beierlein <tomjbe@gentoo.org> +puff-20100127.ebuild,
+ +metadata.xml:
+ Initial ebuild (bug #316807). Moved from sci overlay.
+
+*puff-20100127 (04 Jul 2010)
+
+ 04 Jul 2010; Thomas Beierlein <tomjbe@gentoo.org> +puff-20100127.ebuild,
+ +metadata.xml:
+ Initial ebuild (see bug #316807)
+
diff --git a/sci-electronics/puff/metadata.xml b/sci-electronics/puff/metadata.xml
new file mode 100644
index 000000000000..54e80a6841ab
--- /dev/null
+++ b/sci-electronics/puff/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/puff/puff-20100127.ebuild b/sci-electronics/puff/puff-20100127.ebuild
new file mode 100644
index 000000000000..6424914d7662
--- /dev/null
+++ b/sci-electronics/puff/puff-20100127.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/puff/puff-20100127.ebuild,v 1.1 2011/01/02 15:36:10 tomjbe Exp $
+
+EAPI="2"
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="microwave CAD software"
+HOMEPAGE="http://www.vf.utwente.nl/~ptdeboer/ham/puff/"
+SRC_URI="http://www.vf.utwente.nl/~ptdeboer/ham/${PN}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/fpc
+ amd64? ( >=dev-lang/fpc-2.4.0 )"
+
+src_prepare() {
+ # fix lib path for X11 and dont ignore LDFLAGS
+ sed -i -e "s#lib\\\/#$(get_libdir)\\\/#" \
+ -e 's/link.res pu/link.res $(LDFLAGS) pu/' Makefile || die
+}
+
+src_compile() {
+ LDFLAGS="$(raw-ldflags)"
+ emake -j1 || die
+}
+
+src_install() {
+ dobin puff || die
+
+ dodoc changelog.txt README.txt || die
+ newdoc "Puff Manual.pdf" Puff_Manual.pdf || die
+
+ insinto /usr/share/${PN}
+ doins setup.puf || die
+ doins -r orig_dev_and_puf_files || die
+}
+
+pkg_postinst() {
+ elog "You must copy /usr/share/${PN}/setup.puf into your working directory"
+ elog "before using the program."
+}