summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-03-06 16:55:17 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-03-06 16:55:17 +0000
commit59c190a34206ccf3a3ae528bacd014bccc492f0e (patch)
treec001408326b501853bf147bb85718ec6c22a5e20 /sci-electronics/xcircuit/xcircuit-3.3.10.ebuild
parentx86 sparc mips stable (diff)
downloadgentoo-2-59c190a34206ccf3a3ae528bacd014bccc492f0e.tar.gz
gentoo-2-59c190a34206ccf3a3ae528bacd014bccc492f0e.tar.bz2
gentoo-2-59c190a34206ccf3a3ae528bacd014bccc492f0e.zip
Version bump; remove some old versions.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-electronics/xcircuit/xcircuit-3.3.10.ebuild')
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.3.10.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-electronics/xcircuit/xcircuit-3.3.10.ebuild b/sci-electronics/xcircuit/xcircuit-3.3.10.ebuild
new file mode 100644
index 000000000000..cc5814db1f34
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.3.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.3.10.ebuild,v 1.1 2005/03/06 16:55:17 plasmaroo Exp $
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://xcircuit.ece.jhu.edu/archive/${P}.tgz"
+HOMEPAGE="http://xcircuit.ece.jhu.edu"
+
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="tcltk"
+
+DEPEND="virtual/x11
+ virtual/ghostscript
+ tcltk? ( dev-lang/tk )"
+
+src_compile() {
+
+ sed -e '693s:LDFLAGS="":LDFLAGS="-L/usr/X11R6/lib":;694i LIBS="${LIBS} ${LIB_SPECS}"' -i configure.in
+ aclocal && autoconf || die "Could not recreate configuration files!"
+
+ if use tcltk; then
+ econf --with-tcl --with-tk || die "econf failed"
+ else
+ econf || die "econf failed"
+ fi
+
+ if use tcltk; then
+ sed -e '67s/extern //' -i events.c
+ sed -e 's/extern Tcl_Interp/Tcl_Interp/' -i tclxcircuit.c
+ sed -e '2982d; 3069d;' -i xcircuit.c
+ make tcl || die
+ fi
+ make || die
+
+}
+
+src_install () {
+
+ emake DESTDIR=${D} install || die "Installation failed"
+ if use tcltk; then
+ emake DESTDIR=${D} install-tcl || die "Installation failed"
+ fi
+ dodoc COPYRIGHT README*
+
+}