summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-05-30 06:23:32 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-05-30 06:23:32 +0000
commit0aa3069a42337332143fae5565bc55e78a1bdb66 (patch)
treefa94e346ad894bac2ff4ba71b5e2b09361508caf /sci-electronics
parentstable x86, bug 179893 (diff)
downloadgentoo-2-0aa3069a42337332143fae5565bc55e78a1bdb66.tar.gz
gentoo-2-0aa3069a42337332143fae5565bc55e78a1bdb66.tar.bz2
gentoo-2-0aa3069a42337332143fae5565bc55e78a1bdb66.zip
Reverting changes made by Ryan Hill on 19 May 2007 until we obtain an explanation of what the upcoming changes are.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/ChangeLog7
-rw-r--r--sci-electronics/kicad/kicad-20060828.ebuild10
-rw-r--r--sci-electronics/kicad/kicad-20070115.ebuild10
3 files changed, 16 insertions, 11 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 6f8350a1d891..e84c1a8558a1 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.17 2007/05/19 09:02:50 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.18 2007/05/30 06:23:32 calchan Exp $
+
+ 30 May 2007; Denis Dupeyron <calchan@gentoo.org> kicad-20060828.ebuild,
+ kicad-20070115.ebuild:
+ Reverting changes made by Ryan Hill on 19 May 2007 until we obtain an
+ explanation of what the upcoming changes are.
19 May 2007; Ryan Hill <dirtyepic@gentoo.org> kicad-20060828.ebuild,
kicad-20070115.ebuild:
diff --git a/sci-electronics/kicad/kicad-20060828.ebuild b/sci-electronics/kicad/kicad-20060828.ebuild
index 0cfcc994e70d..40a3d58863da 100644
--- a/sci-electronics/kicad/kicad-20060828.ebuild
+++ b/sci-electronics/kicad/kicad-20060828.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20060828.ebuild,v 1.2 2007/05/19 09:02:50 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20060828.ebuild,v 1.3 2007/05/30 06:23:32 calchan Exp $
inherit wxwidgets
@@ -15,12 +15,12 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="unicode doc examples minimal"
-DEPEND="=x11-libs/wxGTK-2.6*
+DEPEND=">=x11-libs/wxGTK-2.6
media-gfx/wings"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need.
- WX_GTK_VER="2.6"
+ # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
+ WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -28,7 +28,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {
diff --git a/sci-electronics/kicad/kicad-20070115.ebuild b/sci-electronics/kicad/kicad-20070115.ebuild
index fdc56fd09f1e..2805641f348f 100644
--- a/sci-electronics/kicad/kicad-20070115.ebuild
+++ b/sci-electronics/kicad/kicad-20070115.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.4 2007/05/19 09:02:50 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.5 2007/05/30 06:23:32 calchan Exp $
inherit wxwidgets
@@ -15,12 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc64 x86"
IUSE="unicode doc examples minimal"
-DEPEND="=x11-libs/wxGTK-2.6*
+DEPEND=">=x11-libs/wxGTK-2.6
media-gfx/wings"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need.
- WX_GTK_VER="2.6"
+ # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
+ WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -28,7 +28,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {