summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2010-09-26 20:57:53 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2010-09-26 20:57:53 +0000
commit28b4439bd160940580626457343467420086535e (patch)
treee160b7116e9bebab659e33f0ded0123b3dc617b3 /sci-electronics
parentStable on amd64 wrt bug #338652 (diff)
downloadgentoo-2-28b4439bd160940580626457343467420086535e.tar.gz
gentoo-2-28b4439bd160940580626457343467420086535e.tar.bz2
gentoo-2-28b4439bd160940580626457343467420086535e.zip
Added openssl as a dep per bug #337277; set SLOT=5 for future expansion
(Portage version: 2.1.9.9/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/eagle/ChangeLog9
-rw-r--r--sci-electronics/eagle/eagle-5.10.0-r1.ebuild104
2 files changed, 112 insertions, 1 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index 19da0c39a1a9..cac16a7ad518 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-electronics/eagle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.41 2010/08/22 20:19:15 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.42 2010/09/26 20:57:53 nixphoeni Exp $
+
+*eagle-5.10.0-r1 (26 Sep 2010)
+
+ 26 Sep 2010; Joe Sapp <nixphoeni@gentoo.org> +eagle-5.10.0-r1.ebuild:
+ Added openssl as a dep per bug #337277 (thanks to Juergen Rose for
+ reporting); also added it to SLOT="5" for future SLOTting of major
+ versions
22 Aug 2010; Joe Sapp <nixphoeni@gentoo.org> eagle-5.10.0.ebuild:
Moved to EAPI 1 so I could use slot deps. Also set RESTRICT=test since
diff --git a/sci-electronics/eagle/eagle-5.10.0-r1.ebuild b/sci-electronics/eagle/eagle-5.10.0-r1.ebuild
new file mode 100644
index 000000000000..cfe701b0f229
--- /dev/null
+++ b/sci-electronics/eagle/eagle-5.10.0-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.10.0-r1.ebuild,v 1.1 2010/09/26 20:57:53 nixphoeni Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="CadSoft EAGLE schematic and printed circuit board (PCB) layout editor"
+HOMEPAGE="http://www.cadsoft.de"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_de linguas_zh doc"
+LICENSE="cadsoft"
+RESTRICT="strip test"
+SLOT="5"
+
+# Cadsoft has used the suffix "_p" in the past which we translate to "r"
+MY_PV=${PV/_p/r}
+
+SRC_URI="ftp://ftp.cadsoft.de/eagle/program/${PV%\.[0-9]}/${PN}-lin-${MY_PV}.run"
+
+QA_DT_HASH="opt/eagle-${PV}/bin/eagle"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x86? ( media-libs/jpeg:62
+ media-libs/libpng:1.2
+ =dev-libs/openssl-0.9.8* )
+ amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs )"
+
+# Append ${PV} since that's what upstream installs to
+INSTALLDIR="/opt/eagle-${PV}"
+case "${LINGUAS}" in
+ *de*)
+ MY_LANG="de";;
+ *)
+ MY_LANG="en";;
+esac
+# Mandatory documentation being installed
+DOCS="README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt"
+
+src_unpack() {
+
+ # Extract the built-in .tar.bz2 file starting at __DATA__
+ sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
+
+}
+
+src_install() {
+
+ # Set MY_LANG for this function only since UPDATE_zh and README_zh
+ # don't exist
+ [[ ${LINGUAS} == *zh* ]] && MY_INST_LANG="zh" || MY_INST_LANG="${MY_LANG}"
+
+ cd "${S}"
+ dodir ${INSTALLDIR}
+ # Copy all to INSTALLDIR
+ cp -r . "${D}"/${INSTALLDIR}
+
+ # Install wrapper (suppressing leading tabs)
+ # see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
+ exeinto /usr/bin
+ newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ # Finally, append the path of the eagle binary respecting INSTALLDIR and any
+ # arguments passed to the script (thanks Denilson)
+ echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle"
+
+ # Install the documentation
+ cd doc
+ dodoc ${DOCS}
+ doman eagle.1
+ # Install extra documentation if requested
+ use doc && dodoc elektro-tutorial.pdf manual_${MY_INST_LANG}.pdf tutorial_${MY_INST_LANG}.pdf
+ # Remove docs left in INSTALLDIR
+ rm -rf "${D}${INSTALLDIR}/doc"
+ cd ..
+
+ echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle"
+ doenvd "${S}/90eagle"
+
+ # Create desktop entry
+ doicon bin/${PN}icon50.png
+ make_desktop_entry "${ROOT}/usr/bin/eagle" ${PN} ${PN}icon50 "Graphics;Electronics"
+
+}
+
+pkg_postinst() {
+
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
+ elog "You must first run eagle as root to invoke product registration."
+ echo
+ ewarn "Due to some necessary changes in the data structure, once you edit"
+ ewarn "a file with version 5.x you will no longer be able to edit it"
+ ewarn "with versions prior to 5.0!"
+ ewarn
+ ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 4.xx."
+
+}