summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2005-05-26 22:27:28 +0000
committerChris Bainbridge <chrb@gentoo.org>2005-05-26 22:27:28 +0000
commit4be09033157fe2850e7397b598233ab20518d758 (patch)
treec65f2f5a02f380e4f80dd75127bdd45ebe18df91 /sci-electronics
parentgames herd, not my herd (diff)
downloadgentoo-2-4be09033157fe2850e7397b598233ab20518d758.tar.gz
gentoo-2-4be09033157fe2850e7397b598233ab20518d758.tar.bz2
gentoo-2-4be09033157fe2850e7397b598233ab20518d758.zip
Version bump. Verilog simulator wrappers not built for the moment.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/balsa/ChangeLog7
-rw-r--r--sci-electronics/balsa/balsa-3.4.3.ebuild152
-rw-r--r--sci-electronics/balsa/files/digest-balsa-3.4.36
3 files changed, 164 insertions, 1 deletions
diff --git a/sci-electronics/balsa/ChangeLog b/sci-electronics/balsa/ChangeLog
index 360996ff2480..80878bca798e 100644
--- a/sci-electronics/balsa/ChangeLog
+++ b/sci-electronics/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/balsa
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.3 2005/05/06 14:07:31 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.4 2005/05/26 22:27:28 chrb Exp $
+
+*balsa-3.4.3 (26 May 2005)
+
+ 26 May 2005; Chris Bainbridge <chrb@gentoo.org> +balsa-3.4.3.ebuild:
+ Version bump. Verilog simulator wrappers not built for the moment.
06 May 2005; David Holm <dholm@gentoo.org> balsa-3.4.ebuild:
Added to ~ppc.
diff --git a/sci-electronics/balsa/balsa-3.4.3.ebuild b/sci-electronics/balsa/balsa-3.4.3.ebuild
new file mode 100644
index 000000000000..5a0c98d79113
--- /dev/null
+++ b/sci-electronics/balsa/balsa-3.4.3.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-3.4.3.ebuild,v 1.1 2005/05/26 22:27:28 chrb Exp $
+
+inherit eutils
+
+IUSE=""
+Name="balsa"
+My_PV="3.4.3"
+
+DESCRIPTION="The Balsa asynchronous synthesis system"
+HOMEPAGE="http://www.cs.manchester.ac.uk/apt/projects/tools/balsa/"
+SRC_URI="ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/${Name}-${My_PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/BalsaManual3.4.2.pdf
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/${Name}-tech-example-3.4.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/${Name}-sim-verilog-3.4.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/${Name}-tech-xilinx-${My_PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${My_PV}/BalsaExamples3.4.tar.gz"
+# ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-tech-verilog-20030204.tar.gz
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/libc
+ sys-devel/binutils
+ dev-libs/gmp
+ dev-lang/perl
+ x11-libs/gtk+
+ sci-electronics/iverilog
+ sci-electronics/gplcver"
+
+RDEPEND="${DEPEND}
+ dev-util/guile
+ media-gfx/graphviz
+ sci-electronics/gtkwave
+ sci-electronics/espresso-ab"
+
+S=${WORKDIR}/${Name}-${My_PV}
+
+if [ -f ${DISTDIR}/balsa-tech-ams-20030506.tar.gz ]; then
+ TECH_AMS=1
+fi
+
+src_unpack() {
+ unpack ${A}
+ if [ $TECH_AMS ]; then
+ unpack balsa-tech-ams-20030506.tar.gz
+ fi
+ sed -i -e "s/types.breeze: types.balsa/types.breeze: types.balsa basic.breeze/" ${S}/share/balsa/types/Makefile.in
+ cd ${WORKDIR}
+ #sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I${S}/src/libs/ \2/:" ${WORKDIR}/balsa-sim-verilog-${PV}/libs/Makefile.in
+ epatch ${FILESDIR}/balsa-tech-3.4-configure.patch
+ epatch ${FILESDIR}/balsa-sim-3.4-configure.patch
+ sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' ${S}/bin/Makefile.in
+ sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' ${S}/share/balsa/types/Makefile.in
+ sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' ${S}/share/balsa/sim/Makefile.in
+}
+
+src_compile() {
+ # compile balsa
+ einfo "Compiling balsa"
+ ./configure --prefix=/usr/ || die "econf failed"
+ emake -j1 || die
+
+ # configure AMS035 tech
+ if [ $TECH_AMS ]; then
+ einfo "Compiling AMS035 tech"
+ cd ${WORKDIR}/balsa-tech-ams-20030506
+ econf || die "econf failed"
+ fi
+
+ # config generic verilog backend
+# cd ${WORKDIR}/balsa-tech-verilog-20030204
+# econf || die "econf failed"
+
+ # config Xilinx FPGA backend
+# cd ${WORKDIR}/balsa-tech-xilinx-20021029
+# econf || die "econf failed"
+
+ # config example tech
+ cd ${WORKDIR}/balsa-tech-example-${My_PV}
+ einfo "Compiling tech example"
+ econf || die "econf failed"
+
+ # config verilog simulator wrappers
+ cd ${WORKDIR}/balsa-sim-verilog-3.4
+ einfo "Compiling verilog simulator wrappers"
+ ./configure --includedir=`pwd`/../balsa-3.4/src/libs/balsasim \
+ --with-icarus-includes=/usr/include \
+ --with-icarus-libs=/usr/lib \
+ --with-cver-includes=/usr/include/cver_pli_incs || die
+}
+
+src_install() {
+ # install balsa
+ cd ${S}
+ einfo "Installing balsa"
+ make DESTDIR=${D} install || die
+
+ # install manual and examples
+ dodir /usr/share/doc/${P}/
+ cp -ar ${WORKDIR}/Examples ${D}/usr/share/doc/${P}/
+ dodoc ${DISTDIR}/BalsaManual${My_PV}.pdf
+
+ # install AMS035 tech
+ if [ $TECH_AMS ]; then
+ einfo "Installing AMS035 tech"
+ cd ${WORKDIR}/balsa-tech-ams-20030506
+ make DESTDIR=${D} install || die "make install failed"
+ fi
+
+# cd ${WORKDIR}/balsa-tech-verilog-20030204
+# make DESTDIR=${D} install || die "make install failed"
+
+# cd ${WORKDIR}/balsa-tech-xilinx-20021029
+# make DESTDIR=${D} install || die "make install failed"
+
+ # install example tech
+ cd ${WORKDIR}/balsa-tech-example-${My_PV}
+ einfo "Installing example tech"
+ make DESTDIR=${D} install || die "make install failed"
+
+ # install verilog simulator wrappers
+# cd ${WORKDIR}/balsa-sim-verilog-3.4
+# einfo "Installing verilog simulator wrappers"
+# DESTDIR=${D} make install || die "make verilog wrappers failed"
+
+ # fix paths
+ cd ${D}
+ einfo "Fixing paths"
+ find . -exec sed -i -e "s:${D}::" {} \;
+ find . -name "sed*" -exec rm -f {} \;
+
+ # add some docs
+ cd ${S}
+ einfo "Installing docs"
+ dodoc AUTHORS COPYING NEWS README TODO
+ mv ${D}/usr/doc/* ${D}/usr/share/doc/${P}/
+ rmdir ${D}/usr/doc
+}
+
+pkg_postinst() {
+ if [ ! $TECH_AMS ]; then
+ einfo "No tech libraries were installed."
+ einfo "If you have the appropriate licenses request"
+ einfo "the tech support files directly from balsa@cs.man.ac.uk"
+ einfo "and add them to /usr/portage/distfiles before emerging."
+ else
+ einfo "The AMS035 tech library was found and installed."
+ fi
+}
diff --git a/sci-electronics/balsa/files/digest-balsa-3.4.3 b/sci-electronics/balsa/files/digest-balsa-3.4.3
new file mode 100644
index 000000000000..347cf64d28f6
--- /dev/null
+++ b/sci-electronics/balsa/files/digest-balsa-3.4.3
@@ -0,0 +1,6 @@
+MD5 a5691f1c82b2545ad7b2ec399564cc8a balsa-3.4.3.tar.gz 2530217
+MD5 dc8003da5d6a48032629326636b53d68 BalsaManual3.4.2.pdf 8330850
+MD5 03dd0cee9a87556e2866bd0035b04235 balsa-tech-example-3.4.tar.gz 62925
+MD5 41ce42eae26cc77e38fd9ce51374e3da balsa-sim-verilog-3.4.tar.gz 199212
+MD5 9a94fd5c036f389096ecf0680e0bd7ec balsa-tech-xilinx-3.4.3.tar.gz 168452
+MD5 da642d17eee00d8e8cba7fe796ce0e9d BalsaExamples3.4.tar.gz 2420060