summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 19:48:35 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 19:48:35 +0000
commitd886cbd1aff7342efa4954cf5566713fff499004 (patch)
tree930b7d96746cccd66d7bcfb9b5caa52f848d477a /sci-geosciences/gmt/files
parentAdded nopiessp support for gcc-4 (diff)
downloadgentoo-2-d886cbd1aff7342efa4954cf5566713fff499004.tar.gz
gentoo-2-d886cbd1aff7342efa4954cf5566713fff499004.tar.bz2
gentoo-2-d886cbd1aff7342efa4954cf5566713fff499004.zip
Correct handling of *FLAGS, thanks Martin von Gagern for providing the patch
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gmt/files')
-rw-r--r--sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch78
1 files changed, 58 insertions, 20 deletions
diff --git a/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch b/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
index 463133c657df..f0fe4c3e833e 100644
--- a/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
+++ b/sci-geosciences/gmt/files/gmt-4.5.0-no-strip.patch
@@ -1,24 +1,62 @@
-diff -ur GMT4.5.0.orig/configure GMT4.5.0/configure
---- GMT4.5.0.orig/configure 2009-07-26 12:11:29.000000000 +0200
-+++ GMT4.5.0/configure 2009-07-26 12:14:56.000000000 +0200
-@@ -11284,8 +11284,6 @@
- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
- if test "$os" = "Darwin" ; then
- LDFLAGS="$LDFLAGS -Wl,-x"
+Drop manipulation of several flags:
+
+* stripping of -g from CFLAGS, as it interferes with deliberate
+ generation of debug symbols and breaks on flags like -ggdb.
+* Addition of -s resp. -Wl,-x to LDFLAGS, as stipping of binaries is
+ done as a separate step on Gentoo (and many other distros) in order
+ to faciliate retention or splitting of debug symbols.
+* Setting of optimization flags, as the user should be free to choose
+ them.
+
+2009-07-27 Martin von Gagern
+
+Reference: http://bugs.gentoo.org/279268
+
+Index: GMT4.5.0/configure
+===================================================================
+--- GMT4.5.0.orig/configure
++++ GMT4.5.0/configure
+@@ -10665,19 +10665,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ echo "${ECHO_T}yes" >&6; }
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
- else
- LDFLAGS="$LDFLAGS -s"
- fi
- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
- CFLAGS="$CFLAGS -O2"
-diff -ur GMT4.5.0.orig/configure.ac GMT4.5.0/configure.ac
---- GMT4.5.0.orig/configure.ac 2009-07-26 12:11:29.000000000 +0200
-+++ GMT4.5.0/configure.ac 2009-07-26 12:15:15.000000000 +0200
-@@ -530,8 +530,6 @@
- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
- if test "$os" = "Darwin" ; then
- LDFLAGS="$LDFLAGS -Wl,-x"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ { echo "$as_me:$LINENO: result: no" >&5
+ echo "${ECHO_T}no" >&6; }
+ fi
+Index: GMT4.5.0/configure.ac
+===================================================================
+--- GMT4.5.0.orig/configure.ac
++++ GMT4.5.0/configure.ac
+@@ -527,19 +527,6 @@ if test "X$enable_debug" = "Xyes" ; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="$CFLAGS -g"
+ else
+- CFLAGS=`echo $CFLAGS | sed 's/-g//'`
+- if test "$os" = "Darwin" ; then
+- LDFLAGS="$LDFLAGS -Wl,-x"
- else
- LDFLAGS="$LDFLAGS -s"
- fi
- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
- CFLAGS="$CFLAGS -O2"
+- fi
+- if test "$GCC" = "yes" || test "$os" = "Linux" || test "$os" = "AIX"; then
+- CFLAGS="$CFLAGS -O2"
+- elif test "$chip" = "alpha" || test "$os" = "AUX" || test "$os" = "HP-UX"; then
+- CFLAGS="$CFLAGS"
+- else
+- CFLAGS="$CFLAGS -O"
+- fi
+ AC_MSG_RESULT(no)
+ fi
+ dnl -----------------------------------------------------------------