summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-08 12:22:57 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-08 12:22:57 +0000
commit1de933522ebeedeb9071531e23024f5445f1b3ec (patch)
tree6c251a72c9bb19ae22876e5039a934fba8efc53d /sci-geosciences/gpscorrelate
parentDrop old pacman-3.3.3. (diff)
downloadgentoo-2-1de933522ebeedeb9071531e23024f5445f1b3ec.tar.gz
gentoo-2-1de933522ebeedeb9071531e23024f5445f1b3ec.tar.bz2
gentoo-2-1de933522ebeedeb9071531e23024f5445f1b3ec.zip
Update the makefile patch so the gtk is really optional.
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gpscorrelate')
-rw-r--r--sci-geosciences/gpscorrelate/ChangeLog6
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch33
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild4
3 files changed, 27 insertions, 16 deletions
diff --git a/sci-geosciences/gpscorrelate/ChangeLog b/sci-geosciences/gpscorrelate/ChangeLog
index 73d24832ecaa..de20c06f083b 100644
--- a/sci-geosciences/gpscorrelate/ChangeLog
+++ b/sci-geosciences/gpscorrelate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/gpscorrelate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/ChangeLog,v 1.9 2011/06/07 09:14:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/ChangeLog,v 1.10 2011/06/08 12:22:57 scarabeus Exp $
+
+ 08 Jun 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ gpscorrelate-1.6.1.ebuild, files/gpscorrelate-1.6.1-makefile.patch:
+ Update the makefile patch so the gtk is really optional.
*gpscorrelate-1.6.1 (07 Jun 2011)
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
index 653d7dac6087..14b00c92b74c 100644
--- a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
@@ -1,7 +1,7 @@
diff -urN gpscorrelate-1.6.1.old/Makefile gpscorrelate-1.6.1/Makefile
---- gpscorrelate-1.6.1.old/Makefile 2011-06-07 11:01:35.671339619 +0200
-+++ gpscorrelate-1.6.1/Makefile 2011-06-07 11:09:31.705388371 +0200
-@@ -4,11 +4,10 @@
+--- gpscorrelate-1.6.1.old/Makefile 2011-06-08 13:51:06.000000000 +0200
++++ gpscorrelate-1.6.1/Makefile 2011-06-08 14:13:18.000000000 +0200
+@@ -4,11 +4,15 @@
COBJS = main-command.o unixtime.o gpx-read.o correlate.o exif-gps.o
GOBJS = main-gui.o gui.o unixtime.o gpx-read.o correlate.o exif-gps.o
@@ -10,31 +10,38 @@ diff -urN gpscorrelate-1.6.1.old/Makefile gpscorrelate-1.6.1/Makefile
-OFLAGS = -Wall
-override OFLAGS += $(shell pkg-config --libs libxml-2.0 gtk+-2.0) -lm -lexiv2
-prefix = /usr/local
-+CFLAGS += $(shell pkg-config --cflags libxml-2.0 gtk+-2.0) -I/usr/include/exiv2
-+CXXFLAGS += $(shell pkg-config --cflags libxml-2.0 gtk+-2.0) -I/usr/include/exiv2
-+CLIBS += $(shell pkg-config --libs libxml-2.0 gtk+-2.0) -lm -lexiv2
++CFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
++CXXFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
++CLIBS += $(shell pkg-config --libs libxml-2.0) -lm -lexiv2 -lstdc++
++ifdef BUILD_GUI
++CXXFLAGS += $(shell pkg-config --cflags gtk+-2.0)
++CFLAGS += $(shell pkg-config --cflags gtk+-2.0)
++CLIBS += $(shell pkg-config --libs gtk+-2.0)
++endif
+prefix ?= /usr/local
bindir = $(prefix)/bin
datadir = $(prefix)/share
mandir = $(datadir)/man
-@@ -18,16 +17,16 @@
+@@ -18,16 +22,16 @@
all: gpscorrelate gpscorrelate-gui gpscorrelate.1
gpscorrelate: $(COBJS)
- g++ $(OFLAGS) -o $@ $(COBJS)
-+ $(CXX) $(LDFLAGS) -o $@ $(COBJS) $(CLIBS)
++ $(CXX) $(LDFLAGS) $(COBJS) $(CLIBS) -o $@
gpscorrelate-gui: $(GOBJS)
- g++ $(OFLAGS) -o $@ $(GOBJS)
-+ $(CXX) $(LDFLAGS) -o $@ $(GOBJS) $(CLIBS)
++ $(CXX) $(LDFLAGS) $(GOBJS) $(CLIBS) -o $@
- .c.o:
+-.c.o:
- gcc $(CFLAGS) -c -o $*.o $<
-+ $(CC) $(CFLAGS) -c -o $*.o $<
++%.o: %.c
++ $(CC) -c -o $@ $< $(CFLAGS)
- .cpp.o:
+-.cpp.o:
- g++ $(CFLAGS) -c -o $*.o $<
-+ $(CXX) $(CXXFLAGS) -c -o $*.o $<
++%.o: %.cpp $(DEPS)
++ $(CXX) -c -o $@ $< $(CXXFLAGS)
clean:
rm -f *.o gpscorrelate{,.exe} gpscorrelate-gui{,.exe}
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild
index bb426c600f23..b5125427ac23 100644
--- a/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild,v 1.1 2011/06/07 09:14:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1.ebuild,v 1.2 2011/06/08 12:22:57 scarabeus Exp $
EAPI=4
@@ -29,7 +29,7 @@ src_prepare() {
src_compile() {
tc-export CC CXX
local opts="gpscorrelate gpscorrelate.1"
- use gtk && opts+=" gpscorrelate-gui"
+ use gtk && opts+=" gpscorrelate-gui BUILD_GUI=1"
emake ${opts}
}