summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-29 11:42:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-29 11:42:28 +0000
commitf23d46cecb34dff8c9b156c773625c2ebd8430aa (patch)
tree18daa8c5cc47a5f27955575954393249eb1d3744 /sci-geosciences/gtk-g-rays2
parentVersion bump. (diff)
downloadgentoo-2-f23d46cecb34dff8c9b156c773625c2ebd8430aa.tar.gz
gentoo-2-f23d46cecb34dff8c9b156c773625c2ebd8430aa.tar.bz2
gentoo-2-f23d46cecb34dff8c9b156c773625c2ebd8430aa.zip
Fix building with CFLAGS="-O0".
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gtk-g-rays2')
-rw-r--r--sci-geosciences/gtk-g-rays2/ChangeLog6
-rw-r--r--sci-geosciences/gtk-g-rays2/files/gtk-g-rays2-1.20-locale_h.patch16
-rw-r--r--sci-geosciences/gtk-g-rays2/gtk-g-rays2-1.20.ebuild5
3 files changed, 24 insertions, 3 deletions
diff --git a/sci-geosciences/gtk-g-rays2/ChangeLog b/sci-geosciences/gtk-g-rays2/ChangeLog
index 33c88e1f2a1d..52884a8dd92d 100644
--- a/sci-geosciences/gtk-g-rays2/ChangeLog
+++ b/sci-geosciences/gtk-g-rays2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/gtk-g-rays2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gtk-g-rays2/ChangeLog,v 1.3 2010/04/27 10:59:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gtk-g-rays2/ChangeLog,v 1.4 2010/07/29 11:42:27 ssuominen Exp $
+
+ 29 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ gtk-g-rays2-1.20.ebuild, +files/gtk-g-rays2-1.20-locale_h.patch:
+ Fix building with CFLAGS="-O0".
*gtk-g-rays2-1.20 (27 Apr 2010)
diff --git a/sci-geosciences/gtk-g-rays2/files/gtk-g-rays2-1.20-locale_h.patch b/sci-geosciences/gtk-g-rays2/files/gtk-g-rays2-1.20-locale_h.patch
new file mode 100644
index 000000000000..b88169630a7e
--- /dev/null
+++ b/sci-geosciences/gtk-g-rays2/files/gtk-g-rays2-1.20-locale_h.patch
@@ -0,0 +1,16 @@
+Fix build failure with CFLAGS="-O0" and libc
+messages.c:44:15: error: ‘LC_NUMERIC’ undeclared (first use in this function)
+
+--- src/messages.c
++++ src/messages.c
+@@ -14,6 +14,10 @@
+ #include <time.h>
+ #include "wbt201.h"
+
++#ifdef HAVE_LOCALE_H
++#include <locale.h>
++#endif
++
+ static char *wmodes[] = {
+ /*0,1*/ NULL,NULL,
+ /*2,3*/ "low_speed_limit1", "high_speed_limit1",
diff --git a/sci-geosciences/gtk-g-rays2/gtk-g-rays2-1.20.ebuild b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-1.20.ebuild
index 80b6458fdded..697f2cfd7d61 100644
--- a/sci-geosciences/gtk-g-rays2/gtk-g-rays2-1.20.ebuild
+++ b/sci-geosciences/gtk-g-rays2/gtk-g-rays2-1.20.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gtk-g-rays2/gtk-g-rays2-1.20.ebuild,v 1.1 2010/04/27 10:59:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gtk-g-rays2/gtk-g-rays2-1.20.ebuild,v 1.2 2010/07/29 11:42:27 ssuominen Exp $
EAPI="3"
-inherit gnome2 base
+inherit eutils gnome2 base
DESCRIPTION="GUI for accessing the Wintec WBT 201 / G-Rays 2 GPS device"
HOMEPAGE="http://www.daria.co.uk/gps"
@@ -24,6 +24,7 @@ DEPEND="${DEPEND}
src_prepare() {
rm -rf debian/
+ epatch "${FILESDIR}"/${P}-locale_h.patch
}
src_configure() {