summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-23 17:15:18 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-23 17:15:18 +0000
commitf0c90a91821ede44775cc37a541658ad46c946f0 (patch)
treefbeaf792cd353bfc6034ef389c83298adf3c403d /sci-geosciences/qgis/files
parentVersion bump. And remove HPPA keywording because xfce-base/thunar is not keyw... (diff)
downloadgentoo-2-f0c90a91821ede44775cc37a541658ad46c946f0.tar.gz
gentoo-2-f0c90a91821ede44775cc37a541658ad46c946f0.tar.bz2
gentoo-2-f0c90a91821ede44775cc37a541658ad46c946f0.zip
Fix compilation with newest pyqt. Per bug #352493
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/qgis/files')
-rw-r--r--sci-geosciences/qgis/files/qgis-1.5.0-qset.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-geosciences/qgis/files/qgis-1.5.0-qset.patch b/sci-geosciences/qgis/files/qgis-1.5.0-qset.patch
new file mode 100644
index 000000000000..418b90092659
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-1.5.0-qset.patch
@@ -0,0 +1,44 @@
+diff -ur qgis-1.5.0/python/CMakeLists.txt qgis-1.5.0-patched/python/CMakeLists.txt
+--- qgis-1.5.0/python/CMakeLists.txt 2011-01-23 14:24:20.655999989 +0200
++++ qgis-1.5.0-patched/python/CMakeLists.txt 2011-01-23 14:29:03.930999748 +0200
+@@ -43,6 +43,10 @@
+ SET(SIP_DISABLE_FEATURES ${SIP_DISABLE_FEATURES} QSETINT_CONVERSION)
+ ENDIF(NOT PYQT4_VERSION_NUM LESS 263941)
+
++IF(NOT PYQT4_VERSION_NUM LESS 264194) # 0x040802
++ SET(SIP_DISABLE_FEATURES ${SIP_DISABLE_FEATURES} QSETTYPE_CONVERSION)
++ENDIF(NOT PYQT4_VERSION_NUM LESS 264194)
++
+ # core module
+ FILE(GLOB sip_files_core core/*.sip)
+ set(SIP_EXTRA_FILES_DEPEND ${sip_files_core})
+diff -ur qgis-1.5.0/python/core/conversions.sip qgis-1.5.0-patched/python/core/conversions.sip
+--- qgis-1.5.0/python/core/conversions.sip 2011-01-23 14:24:20.656999987 +0200
++++ qgis-1.5.0-patched/python/core/conversions.sip 2011-01-23 14:30:08.901999769 +0200
+@@ -15,6 +15,7 @@
+ */
+
+ %Feature QSETINT_CONVERSION
++%Feature QSETTYPE_CONVERSION
+
+ %ModuleHeaderCode
+ // From Python 2.5, some functions use Py_ssize_t instead of int
+@@ -321,7 +322,7 @@
+ };
+ %End
+
+-
++%If (QSETTYPE_CONVERSION)
+ template <TYPE>
+ %MappedType QSet<TYPE>
+ {
+@@ -395,8 +396,7 @@
+ %End
+
+ };
+-
+-
++%End
+
+ template<TYPE>
+ %MappedType QMap<int, QMap<int, TYPE> >