summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-06-27 10:31:15 +0000
committerUlrich Müller <ulm@gentoo.org>2008-06-27 10:31:15 +0000
commita1cde988685e86f24f9cb6b533689cc993b3281f (patch)
tree0ee18cea979059c27a92da1e230497af4acea6fc /sci-geosciences
parentChange dependency from virtual/motif to x11-libs/openmotif, bug 224749. (diff)
downloadgentoo-2-a1cde988685e86f24f9cb6b533689cc993b3281f.tar.gz
gentoo-2-a1cde988685e86f24f9cb6b533689cc993b3281f.tar.bz2
gentoo-2-a1cde988685e86f24f9cb6b533689cc993b3281f.zip
Change dependency from virtual/motif to x11-libs/openmotif, bug 224749.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog7
-rw-r--r--sci-geosciences/gpsd/gpsd-2.32.ebuild24
-rw-r--r--sci-geosciences/gpsd/gpsd-2.33-r1.ebuild32
-rw-r--r--sci-geosciences/gpsd/gpsd-2.34-r1.ebuild52
-rw-r--r--sci-geosciences/gpsd/gpsd-2.36.ebuild58
-rw-r--r--sci-geosciences/gpsd/gpsd-2.37.ebuild58
6 files changed, 118 insertions, 113 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index daaae213330a..4a5c2208cb8f 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.32 2008/06/02 20:01:03 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.33 2008/06/27 10:31:15 ulm Exp $
+
+ 27 Jun 2008; Ulrich Mueller <ulm@gentoo.org> gpsd-2.32.ebuild,
+ gpsd-2.33-r1.ebuild, gpsd-2.34-r1.ebuild, gpsd-2.36.ebuild,
+ gpsd-2.37.ebuild:
+ Change dependency from virtual/motif to x11-libs/openmotif, bug 224749.
*gpsd-2.37 (02 Jun 2008)
diff --git a/sci-geosciences/gpsd/gpsd-2.32.ebuild b/sci-geosciences/gpsd/gpsd-2.32.ebuild
index 668347577072..5904a5217720 100644
--- a/sci-geosciences/gpsd/gpsd-2.32.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.6 2008/05/06 16:51:51 djay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.32.ebuild,v 1.7 2008/06/27 10:31:15 ulm Exp $
inherit eutils libtool distutils
@@ -24,7 +24,7 @@ RDEPEND="X? (
x11-libs/libICE
x11-libs/libXpm
x11-libs/libXaw
- virtual/motif
+ x11-libs/openmotif
)
usb? ( sys-apps/hotplug )
dbus? ( >=sys-apps/dbus-0.6 )
@@ -59,19 +59,19 @@ src_install() {
make DESTDIR="${D}" install
if use usb ; then
- sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
- insinto /etc/hotplug/usb
- doins gpsd.usermap
- exeinto /etc/hotplug/usb
- newexe gpsd.hotplug gpsd
+ sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ newexe gpsd.hotplug gpsd
else
- newconfd "${FILESDIR}"/gpsd.conf gpsd
- newinitd "${FILESDIR}"/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
- insinto /etc/X11/app-defaults
- newins xgps.ad Xgps
- newins xgpsspeed.ad Xgpsspeed
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
fi
dobin logextract
diropts "-m0644"
diff --git a/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild b/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
index bf89e1cdcc1f..fd072cf2fa17 100644
--- a/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild,v 1.5 2008/05/06 16:51:51 djay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild,v 1.6 2008/06/27 10:31:15 ulm Exp $
inherit eutils libtool distutils
@@ -24,7 +24,7 @@ RDEPEND="X? (
x11-libs/libICE
x11-libs/libXpm
x11-libs/libXaw
- virtual/motif
+ x11-libs/openmotif
)
dev-lang/python
app-text/xmlto
@@ -55,17 +55,17 @@ src_compile() {
local my_conf="--enable-shared"
if ! use static; then
- my_conf="${my_conf} --with-pic --disable-static"
+ my_conf="${my_conf} --with-pic --disable-static"
else
- my_conf="${my_conf} --enable-static"
+ my_conf="${my_conf} --enable-static"
fi
if ! use ntp; then
- my_conf="${my_conf} --disable-ntpshm"
+ my_conf="${my_conf} --disable-ntpshm"
fi
econf ${my_conf} $(use_enable dbus) $(use_enable tntc tnt) \
- $(use_with X x) || die "econf failed"
+ $(use_with X x) || die "econf failed"
emake LDFLAGS="${LDFLAGS} -lm" || die "emake failed"
}
@@ -74,20 +74,20 @@ src_install() {
make DESTDIR="${D}" install
if use usb ; then
- sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
- insinto /etc/hotplug/usb
- doins gpsd.usermap
- exeinto /etc/hotplug/usb
- newexe gpsd.hotplug gpsd
+ sed -i -e "s/gpsd.hotplug/gpsd/g" gpsd.hotplug gpsd.usermap
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ newexe gpsd.hotplug gpsd
keepdir /var/run/usb # needed for REMOVER
else
- newconfd "${FILESDIR}"/gpsd.conf gpsd
- newinitd "${FILESDIR}"/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
- insinto /etc/X11/app-defaults
- newins xgps.ad Xgps
- newins xgpsspeed.ad Xgpsspeed
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
fi
dobin logextract
diropts "-m0644"
diff --git a/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild b/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
index 7b62cba1542b..bc00ebd91155 100644
--- a/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild,v 1.5 2008/05/17 18:27:15 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild,v 1.6 2008/06/27 10:31:15 ulm Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF=2.5
@@ -27,7 +27,7 @@ RDEPEND="X? (
x11-libs/libICE
x11-libs/libXpm
x11-libs/libXaw
- virtual/motif
+ x11-libs/openmotif
)
python? ( dev-lang/python )
dbus? ( >=sys-apps/dbus-0.94
@@ -57,29 +57,29 @@ src_compile() {
local my_conf="--enable-shared"
if ! use static; then
- my_conf="${my_conf} --with-pic --disable-static"
+ my_conf="${my_conf} --with-pic --disable-static"
else
- my_conf="${my_conf} --enable-static"
+ my_conf="${my_conf} --enable-static"
fi
if ! use ntp; then
- my_conf="${my_conf} --disable-ntpshm"
+ my_conf="${my_conf} --disable-ntpshm"
fi
if use minimal; then
- local max_clients="5"
- local max_devices="1"
- my_conf="${my_conf} --enable-squelch --disable-pps"
- my_conf="${my_conf} --enable-max-clients=${max_clients} \
+ local max_clients="5"
+ local max_devices="1"
+ my_conf="${my_conf} --enable-squelch --disable-pps"
+ my_conf="${my_conf} --enable-max-clients=${max_clients} \
--enable-max-devices=${max_devices}"
- WITH_XSLTPROC=no WITH_XMLTO=no econf ${my_conf} \
+ WITH_XSLTPROC=no WITH_XMLTO=no econf ${my_conf} \
$(use_enable dbus) $(use_with X x) \
$(use_enable tntc tnt) $(use_enable italk) \
$(use_enable itrax) $(use_enable python) \
|| die "econf failed"
else
- econf ${my_conf} $(use_enable dbus) $(use_with X x) \
+ econf ${my_conf} $(use_enable dbus) $(use_with X x) \
$(use_enable tntc tnt) $(use_enable italk) \
$(use_enable itrax) $(use_enable python) \
|| die "econf failed"
@@ -93,22 +93,22 @@ src_install() {
make DESTDIR="${D}" install
if use usb ; then
- insinto /etc/hotplug/usb
- doins gpsd.usermap
- exeinto /etc/hotplug/usb
- doexe gpsd.hotplug
- keepdir /var/run/usb # needed for REMOVER
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ doexe gpsd.hotplug
+ keepdir /var/run/usb # needed for REMOVER
else
- newconfd "${FILESDIR}"/gpsd.conf gpsd
- newinitd "${FILESDIR}"/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
- insinto /etc/X11/app-defaults
- newins xgps.ad Xgps
- newins xgpsspeed.ad Xgpsspeed
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
else
- rm "${D}usr/share/man/man1/xgpsspeed.1.bz2" \
+ rm "${D}usr/share/man/man1/xgpsspeed.1.bz2" \
"${D}usr/share/man/man1/xgps.1.bz2"
fi
@@ -116,13 +116,13 @@ src_install() {
diropts "-m0644"
if use python ; then
- exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
- doexe gps.py gpsfake.py gpspacket.so
+ exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doexe gps.py gpsfake.py gpspacket.so
fi
if use minimal; then
- doman gpsctl.1 gpsflash.1 gpspipe.1 gps.1 gpsd.8
- use python && doman gpsprof.1 gpsfake.1 gpscat.1
+ doman gpsctl.1 gpsflash.1 gpspipe.1 gps.1 gpsd.8
+ use python && doman gpsprof.1 gpsfake.1 gpscat.1
fi
dodoc AUTHORS INSTALL README TODO
diff --git a/sci-geosciences/gpsd/gpsd-2.36.ebuild b/sci-geosciences/gpsd/gpsd-2.36.ebuild
index 8b0ee4daac66..7073f21fd4be 100644
--- a/sci-geosciences/gpsd/gpsd-2.36.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.36.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.36.ebuild,v 1.3 2008/05/06 19:08:58 djay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.36.ebuild,v 1.4 2008/06/27 10:31:15 ulm Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF=2.5
@@ -28,7 +28,7 @@ RDEPEND="X? (
x11-libs/libICE
x11-libs/libXpm
x11-libs/libXaw
- virtual/motif
+ x11-libs/openmotif
)
python? ( dev-lang/python )
@@ -59,33 +59,33 @@ src_unpack() {
src_compile() {
local my_conf="--enable-shared --with-pic --enable-static \
- --disable-garmin --disable-garmintxt"
+ --disable-garmin --disable-garmintxt"
# Garmin support is broken in this version
use python && distutils_python_version
if use ntp; then
- my_conf="${my_conf} --enable-ntpshm --enable-pps"
+ my_conf="${my_conf} --enable-ntpshm --enable-pps"
else
- my_conf="${my_conf} --disable-ntpshm --disable-pps"
+ my_conf="${my_conf} --disable-ntpshm --disable-pps"
fi
if use minimal; then
- local max_clients="5"
- local max_devices="2"
- if ! use ntp; then
+ local max_clients="5"
+ local max_devices="2"
+ if ! use ntp; then
my_conf="${my_conf} --disable-pps"
- fi
- my_conf="${my_conf} --enable-squelch --without-x \
+ fi
+ my_conf="${my_conf} --enable-squelch --without-x \
--enable-max-devices=${max_devices} \
--enable-max-clients=${max_clients}"
- WITH_XSLTPROC=no WITH_XMLTO=no econf ${my_conf} \
+ WITH_XSLTPROC=no WITH_XMLTO=no econf ${my_conf} \
$(use_enable dbus) $(use_enable italk) \
$(use_enable itrax) $(use_enable python) \
|| die "econf failed"
else
- econf ${my_conf} $(use_enable dbus) $(use_enable italk) \
+ econf ${my_conf} $(use_enable dbus) $(use_enable italk) \
$(use_enable itrax) $(use_enable python) $(use_with X x) \
|| die "econf failed"
fi
@@ -100,24 +100,24 @@ src_install() {
make DESTDIR="${D}" install
if use usb ; then
- insinto /etc/hotplug/usb
- doins gpsd.usermap
- exeinto /etc/hotplug/usb
- doexe gpsd.hotplug
- insinto /etc/udev/rules.d
- doins "${FILESDIR}"/99-gpsd-usb.rules
- keepdir /var/run/usb # needed for REMOVER
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ doexe gpsd.hotplug
+ insinto /etc/udev/rules.d
+ doins "${FILESDIR}"/99-gpsd-usb.rules
+ keepdir /var/run/usb # needed for REMOVER
else
- newconfd "${FILESDIR}"/gpsd.conf gpsd
- newinitd "${FILESDIR}"/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X && ! use minimal ; then
- insinto /etc/X11/app-defaults
- newins xgps.ad Xgps
- newins xgpsspeed.ad Xgpsspeed
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
else
- rm "${D}usr/share/man/man1/xgpsspeed.1.bz2" \
+ rm "${D}usr/share/man/man1/xgpsspeed.1.bz2" \
"${D}usr/share/man/man1/xgps.1.bz2"
fi
@@ -125,13 +125,13 @@ src_install() {
dobin logextract
if use python ; then
- exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
- doexe gps.py gpsfake.py gpspacket.so
+ exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doexe gps.py gpsfake.py gpspacket.so
fi
if use minimal; then
- doman gpsctl.1 gpsflash.1 gpspipe.1 gpsd.8 gps.1
- use python && doman gpsprof.1 gpsfake.1 gpscat.1
+ doman gpsctl.1 gpsflash.1 gpspipe.1 gpsd.8 gps.1
+ use python && doman gpsprof.1 gpsfake.1 gpscat.1
fi
dodoc INSTALL README TODO
diff --git a/sci-geosciences/gpsd/gpsd-2.37.ebuild b/sci-geosciences/gpsd/gpsd-2.37.ebuild
index d6753eb8f594..da0ff55f5161 100644
--- a/sci-geosciences/gpsd/gpsd-2.37.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.37.ebuild,v 1.1 2008/06/02 20:01:03 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.37.ebuild,v 1.2 2008/06/27 10:31:15 ulm Exp $
inherit eutils distutils
@@ -25,7 +25,7 @@ RDEPEND="X? (
x11-libs/libICE
x11-libs/libXpm
x11-libs/libXaw
- virtual/motif
+ x11-libs/openmotif
)
python? ( dev-lang/python )
@@ -48,33 +48,33 @@ DEPEND="${RDEPEND}
src_compile() {
local my_conf="--enable-shared --with-pic --enable-static \
- --disable-garmin --disable-garmintxt"
+ --disable-garmin --disable-garmintxt"
# Garmin support is broken in this version
use python && distutils_python_version
if use ntp; then
- my_conf="${my_conf} --enable-ntpshm --enable-pps"
+ my_conf="${my_conf} --enable-ntpshm --enable-pps"
else
- my_conf="${my_conf} --disable-ntpshm --disable-pps"
+ my_conf="${my_conf} --disable-ntpshm --disable-pps"
fi
if use minimal; then
- local max_clients="5"
- local max_devices="2"
- if ! use ntp; then
+ local max_clients="5"
+ local max_devices="2"
+ if ! use ntp; then
my_conf="${my_conf} --disable-pps"
- fi
- my_conf="${my_conf} --enable-squelch --without-x \
+ fi
+ my_conf="${my_conf} --enable-squelch --without-x \
--enable-max-devices=${max_devices} \
--enable-max-clients=${max_clients}"
- WITH_XSLTPROC=no WITH_XMLTO=no econf ${my_conf} \
+ WITH_XSLTPROC=no WITH_XMLTO=no econf ${my_conf} \
$(use_enable dbus) $(use_enable italk) \
$(use_enable itrax) $(use_enable python) \
|| die "econf failed"
else
- econf ${my_conf} $(use_enable dbus) $(use_enable italk) \
+ econf ${my_conf} $(use_enable dbus) $(use_enable italk) \
$(use_enable itrax) $(use_enable python) $(use_with X x) \
|| die "econf failed"
fi
@@ -89,24 +89,24 @@ src_install() {
make DESTDIR="${D}" install
if use usb ; then
- insinto /etc/hotplug/usb
- doins gpsd.usermap
- exeinto /etc/hotplug/usb
- doexe gpsd.hotplug
- insinto /etc/udev/rules.d
- doins "${FILESDIR}"/99-gpsd-usb.rules
- keepdir /var/run/usb # needed for REMOVER
+ insinto /etc/hotplug/usb
+ doins gpsd.usermap
+ exeinto /etc/hotplug/usb
+ doexe gpsd.hotplug
+ insinto /etc/udev/rules.d
+ doins "${FILESDIR}"/99-gpsd-usb.rules
+ keepdir /var/run/usb # needed for REMOVER
else
- newconfd "${FILESDIR}"/gpsd.conf gpsd
- newinitd "${FILESDIR}"/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X && ! use minimal ; then
- insinto /etc/X11/app-defaults
- newins xgps.ad Xgps
- newins xgpsspeed.ad Xgpsspeed
+ insinto /etc/X11/app-defaults
+ newins xgps.ad Xgps
+ newins xgpsspeed.ad Xgpsspeed
else
- rm "${D}usr/share/man/man1/xgpsspeed.1.bz2" \
+ rm "${D}usr/share/man/man1/xgpsspeed.1.bz2" \
"${D}usr/share/man/man1/xgps.1.bz2"
fi
@@ -114,13 +114,13 @@ src_install() {
dobin logextract
if use python ; then
- exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
- doexe gps.py gpsfake.py gpspacket.so
+ exeinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doexe gps.py gpsfake.py gpspacket.so
fi
if use minimal; then
- doman gpsctl.1 gpsflash.1 gpspipe.1 gpsd.8 gps.1
- use python && doman gpsprof.1 gpsfake.1 gpscat.1
+ doman gpsctl.1 gpsflash.1 gpspipe.1 gpsd.8 gps.1
+ use python && doman gpsprof.1 gpsfake.1 gpscat.1
fi
dodoc INSTALL README TODO