summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-03-03 19:10:38 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-03-03 19:10:38 +0000
commit8dc58a635722ee412e038a481d65b10a6c0a8557 (patch)
tree582e615c485ad4284264de9293d8b044b0736094 /sci-libs/adolc
parentStable for ppc64, wrt bug #458712 (diff)
downloadgentoo-2-8dc58a635722ee412e038a481d65b10a6c0a8557.tar.gz
gentoo-2-8dc58a635722ee412e038a481d65b10a6c0a8557.tar.bz2
gentoo-2-8dc58a635722ee412e038a481d65b10a6c0a8557.zip
Version bump. Thanks Jauhien Piatlicki (bug #459880)
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/adolc')
-rw-r--r--sci-libs/adolc/ChangeLog10
-rw-r--r--sci-libs/adolc/adolc-2.4.0.ebuild39
-rw-r--r--sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch24
3 files changed, 71 insertions, 2 deletions
diff --git a/sci-libs/adolc/ChangeLog b/sci-libs/adolc/ChangeLog
index dca52be126e1..eca64f5437de 100644
--- a/sci-libs/adolc/ChangeLog
+++ b/sci-libs/adolc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/adolc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/adolc/ChangeLog,v 1.2 2012/07/19 20:18:26 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/adolc/ChangeLog,v 1.3 2013/03/03 19:10:38 bicatali Exp $
+
+*adolc-2.4.0 (03 Mar 2013)
+
+ 03 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> +adolc-2.4.0.ebuild,
+ +files/adolc-2.4.0-no-colpack.patch:
+ Version bump. Thanks Jauhien Piatlicki (bug #459880)
*adolc-2.3.0-r1 (19 Jul 2012)
diff --git a/sci-libs/adolc/adolc-2.4.0.ebuild b/sci-libs/adolc/adolc-2.4.0.ebuild
new file mode 100644
index 000000000000..2ec35e537303
--- /dev/null
+++ b/sci-libs/adolc/adolc-2.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/adolc/adolc-2.4.0.ebuild,v 1.1 2013/03/03 19:10:38 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+inherit autotools-utils toolchain-funcs
+
+MYPN=ADOL-C
+
+DESCRIPTION="Automatic differentiation system for C/C++"
+HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="|| ( EPL-1.0 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="sparse static-libs"
+
+RDEPEND="sparse? ( sci-libs/colpack )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+PATCHES=( "${FILESDIR}"/${P}-no-colpack.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable sparse)
+ $(use_with sparse colpack "${EPREFIX}"/usr)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ emake test
+}
diff --git a/sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch b/sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch
new file mode 100644
index 000000000000..e3b5a4a2ca5f
--- /dev/null
+++ b/sci-libs/adolc/files/adolc-2.4.0-no-colpack.patch
@@ -0,0 +1,24 @@
+do not test colpack when user says no even when it is installed
+
+--- configure.ac.orig 2012-07-19 13:04:37.426461811 -0700
++++ configure.ac 2012-07-19 13:06:06.477916144 -0700
+@@ -281,7 +281,7 @@
+ COLPACK_LIBDIR=""
+ COLPACK_LIBS="-lColPack"
+ ])
+-
++if test x$colpack != xno; then
+ AC_LANG_PUSH([C++])
+ save_CPPFLAGS="$CPPFLAGS"
+ save_LIBS="$LIBS"
+@@ -301,7 +301,9 @@
+ CPPFLAGS="$save_CPPFLAGS"
+ LIBS="$save_LIBS"
+ AC_LANG_POP([C++])
+-
++else
++ have_colpack=no
++fi
+ AM_CONDITIONAL(HAVE_LIBCOLPACK,[test x$have_colpack = xyes])
+ if test x$have_colpack = xyes; then
+ sparse=yes