summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-01-03 05:33:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-01-03 05:33:16 +0000
commit1fea6b66ef85fbc0df6e0109dc80d47c288857f1 (patch)
tree1446393fb277649e28c8c63d2d1d02cbed482d15 /sci-libs/armadillo/armadillo-3.4.4.ebuild
parentUse generic pkg-config (diff)
downloadgentoo-2-1fea6b66ef85fbc0df6e0109dc80d47c288857f1.tar.gz
gentoo-2-1fea6b66ef85fbc0df6e0109dc80d47c288857f1.tar.bz2
gentoo-2-1fea6b66ef85fbc0df6e0109dc80d47c288857f1.zip
Use generic pkg-config
(Portage version: 2.2.01.21476-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/armadillo/armadillo-3.4.4.ebuild')
-rw-r--r--sci-libs/armadillo/armadillo-3.4.4.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-libs/armadillo/armadillo-3.4.4.ebuild b/sci-libs/armadillo/armadillo-3.4.4.ebuild
index 22d13354b50b..8bd2db2bf79a 100644
--- a/sci-libs/armadillo/armadillo-3.4.4.ebuild
+++ b/sci-libs/armadillo/armadillo-3.4.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.5 2012/12/25 03:26:02 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.4.4.ebuild,v 1.6 2013/01/03 05:33:16 bicatali Exp $
EAPI=4
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake-utils
+inherit cmake-utils toolchain-funcs
DESCRIPTION="Streamlined C++ linear algebra library"
HOMEPAGE="http://arma.sourceforge.net/"
@@ -35,13 +35,13 @@ src_configure() {
if use blas; then
mycmakeargs+=(
-DBLAS_FOUND=ON
- -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ -DBLAS_LIBRARIES="$($(tc-getPKGCONFIG) --libs blas)"
)
fi
if use lapack; then
mycmakeargs+=(
-DLAPACK_FOUND=ON
- -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ -DLAPACK_LIBRARIES="$($(tc-getPKGCONFIG) --libs lapack)"
)
fi
cmake-utils_src_configure